Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12966 Discussions

Brand new NUC8I7HNK2 not outputting any display


Hi, I have brand new NUC817HNK2. I have added memory and SSD. It turns on fine and I get a green light which I take to be positive but it is not outputting any display. I have tried with and without the boot USB I have created, two different monitors and HDMI and mini-display port. Nothing is output. I have not done this before so it is possible I am missing something but I cannot think what that might be. Can anyone on the community help?

Thanks, Rob.

0 Kudos
2 Replies
Super User

Hello Rob,

1. What is the P?N off the SODIMM memory you have installed?

2. Remove the SODIMs and the SSD. Power ON your NUC, the power LED shall blink, indicating memory failure (since there is no memory installed). This will indicate that POST is executed.

3. If you saw LED blinking in previous test, power ON your NUC with only one SODIMM installed (without SSD. Disconnect any external devices connected to USB port, except keyboard and mouse). Try first installing each SODIMM in the lower memory slot and then in the upper slot. You should see the Intel logo and you should be able to enter bios after pressing on F2. Check also that your monitor is set to the right input.



Hi Leon,

Thanks for your suggestions. In response:

1. Part number is CT16G4SFD824A. I checked on the Crucial website and it says it is compatible

2. I removed SODIMM and SSD as you suggest: the power light is continuously on (and blue) (i.e. not blinking). The 3rd LED is green and continuously on.

3. I put the SODIMM back in the upper slot (it had been in the lower slot) and.....

... it works :-)

So - who knows: maybe I had not seated the SODIMM correctly the first time or maybe it only works in the upper slot. Whatever it works now so thank you very much for your suggestion.