Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ngbeslhang
Novice
477 Views

Brand new NUC8i7HNK does not work with specific monitor

Jump to solution

I only got the NUC specified today, the very first monitor (powered by USB 3, only HDMI input and NO USB input) ​didn't post anything on both HDMI ports even though the LED is static green. Tried both a TV and another monitor which works and use the latter to install Win10.

After experimenting with the ports ​I found out that the USB Type-C dongle's HDMI port along with a dedicated USB 3 power works, but the display looks very weird:

20190415_004812.jpg

0 Kudos

Accepted Solutions
ngbeslhang
Novice
75 Views

RIght, so after hours of testing I finally found the cause (and it's not at all software related so I won't be attaching the results).

 

Apparently, the monitor itself didn't output enough power via HDMI for the NUC to detect it (which is why the NUC is stuck in the BIOS splash page when I somehow saw it, and the NUC shut downs almost instantly the moment I press the power button). Stupidly enough, the fix for that would be to plug both HDMI ports *into* the NUC (anything that can sufficiently power up the HDMI, really), wait until the disk LED lights up then switch one end to the monitor itself. This means I won't be able to access the BIOS without a second screen but I don't fiddle with it much, so it works for the time being.

 

In case if you ask about the monitor's USB power, it still works by plugging directly into any of the NUC's USB ports as long as you provide the HDMI cable enough power until Win10 launches.

 

As for the weird display issue on Win10, I already fixed it by reinstalling Win10 (probably best not to plug the other end onto a laptop's HDMI port again). I initially had scaling issue but turns out it's easily fixed by going to Radeon Settings > change the pixel format of the display (in my case, full RGB).

View solution in original post

4 Replies
LeonWaksman
Super User
75 Views

Are you supplying power to your monitor from the USB port on your NUC? If yes, be aware that USB3 port on this NUC is capable to supply only 900mA? So, if you connected your monitor power input to the USB3 socket on NUC, you are causing overcurrent protection trip.

 

Leon

 

ngbeslhang
Novice
75 Views

I have in fact tried using both the USB port from the NUC and a dedicated power supply, both launching the monitor's splash screen but it went into power saving due to "no input".​

EDIT: The same monitor is supposed to be powered by and work with a laptop, phone (e.g. Samsung DeX), game consoles, desktop PC etc. and they all still work well with it; the NUC is the only device I have that totally doesn't work out-of-the-box.​

LeonWaksman
Super User
75 Views

Please download Intel System Support Utility https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- . After running system scan, please save the result and please attach the txt file to your post.

 

Leon

 

ngbeslhang
Novice
76 Views

RIght, so after hours of testing I finally found the cause (and it's not at all software related so I won't be attaching the results).

 

Apparently, the monitor itself didn't output enough power via HDMI for the NUC to detect it (which is why the NUC is stuck in the BIOS splash page when I somehow saw it, and the NUC shut downs almost instantly the moment I press the power button). Stupidly enough, the fix for that would be to plug both HDMI ports *into* the NUC (anything that can sufficiently power up the HDMI, really), wait until the disk LED lights up then switch one end to the monitor itself. This means I won't be able to access the BIOS without a second screen but I don't fiddle with it much, so it works for the time being.

 

In case if you ask about the monitor's USB power, it still works by plugging directly into any of the NUC's USB ports as long as you provide the HDMI cable enough power until Win10 launches.

 

As for the weird display issue on Win10, I already fixed it by reinstalling Win10 (probably best not to plug the other end onto a laptop's HDMI port again). I initially had scaling issue but turns out it's easily fixed by going to Radeon Settings > change the pixel format of the display (in my case, full RGB).

View solution in original post