Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11977 Discussions

CPU temperature in bios is always 0, balanced fan control mode is not working

mihail-h
Beginner
337 Views

I have NUC8V7PNB board. It was working well for several months, but recently balanced fan control mode stopped working (the board is very hot, but the fan is not spinning).

Moreover:
1. Fixed fan control mode is working fine (the fan is always spinning).
2. CPU temperature in BIOS is always 0 (obviously it is the problem), but linux command "sensors" shows correct CPU core temperature.
3. BIOS version is latest (PNv0042.CAP).

Why can the CPU temperature in bios be 0? How can I detect the reason?

 

BIOS:

bios-1.jpg

bios-2.jpg

bios-3.jpg

 

Linux "sensors" result:

sensors-result.png

0 Kudos
1 Reply
n_scott_pearson
Super User Retired Employee
280 Views

Fan speed control on the NUCs is implemented in a separate Embedded Controller (EC). This EC gets temperature data from the processor and chipset via the PECI bus. It sounds like the EC is not working properly. What I suggest you do is the following:

  1. If you haven't already, update the BIOS to the latest version available. Do this via the standard Windows EBU or BIOS F7 processes.
  2. Reinstall the latest BIOS again, this time via the BIOS Recovery process. Instructions for doing so can be found here: 

    Intel NUC BIOS Update and Recovery Instructions for Aptio V BIOS Core.

If this doesn't result in the sensors working again, you may need to get your NUC replaced.

...S

Reply