Community
cancel
Showing results for 
Search instead for 
Did you mean: 
hgl
Beginner
3,409 Views

Can't boot from M.2 NVMe SSD

I purchased NUC8i3CYSM early this year. It comes with a 1TB 2.5 HDD, with windows 10 pre-installed.

I installed a new Samsumg PM981a 250G NVMe SSD yesterday. It was recognized in the BIOS (both in Devices - SATA and Devices - PCI), which had been upgraded to the latest version 2020.0612.1715.

I plugged in an USB drive that was formatted using the official tool that creates Windows 10 installation media.

The SSD was recognized in the Windows installing process where it asked me to select a target disk. I deleted every partition, resulting two unallocated disks. I then selected the SSD and clicked next. After finishing installing Windows, the computer restarted. I removed the USB drive, before the BIOS logo showed, after which I was prompted with a message saying there was no bootable device.

I then rebooted and pressed F2 to enter BIOS. My SSD was not in the UEFI boot order section. If legacy boot is enabled, the SSD shows up in the legacy boot order section, and it's possible to select it in the boot menu, but it won't boot into windows. Fast boot was not enabled.

If I install Windows in 2.5 HDD, it boots successfully. Disabling the SATA Port (which disables the HDD) didn't help.

I'm not sure what more options could I tweak to make SSD boot.

Please help.

0 Kudos
12 Replies
hgl
Beginner
3,404 Views

Why were my posts constantly being deleted?

hgl
Beginner
3,393 Views

Here is the report from Intel® System Support Utility for Windows.

I installed Windows on my HDD, and ran the scanning. When I first ran it, my SSD wasn't in the result. I had to go to disk management, created a partition for the disk and gave it a label for the utility to discover it. But it seemed it then identified it as a generic disk. Not sure if it helps.

LeonWaksman
Super User
3,372 Views

1. I suggest you to reinstall Windows using the following method:
2. Please prepare your installation media (you need 8GB – 32GB USB stick), using Microsoft Media Creation Tool. This will install version 2004. I understand that you have prepared already this installation USB.
3. Your bios should be set to default settings. Enter bios (press F2 during boot) and then press F9 (Y) to set defaults and F10 (Y) to save settings and exit.
4. With the installation media inserted into rear USB slot, power ON your NUC and repeatably press F10 to get Boot Menu.
5. In this menu, choose UEFI option of you Installation media. Could be that you installed Windows from legacy option?
6. Continue with installation.


Leon

hgl
Beginner
3,351 Views

Thanks for the reply.

I did set BIOS to default settings, which wouldn’t allow the USB to boot in any way except for UEFI. After installing Windows, it wouldn’t boot from SSD.

I also tried enabling legacy boot after setting to the default settings. Choosing UEFI opinion of my USB drive in the boot menu still had the same issue.

I also tried non-UEFI option, during the installation process, Windows refused to install on the SSD.

So I’m pretty sure I picked UEFI.

n_scott_pearson
Super User Retired Employee
3,327 Views

During the Windows installation process, when you get to the scene where you pick the partition to install WIndows to, you must delete *all* partitions on the NVMe drive and then tell Windows to install to the Unallocated space (which not encompasses the entire drive). By deleting all partitions, this tells the installer to create a new, in this case GPT, partition table.

If you don't like Windows partitioning of the drive, delete all partitions and then let it progress to the next step. Kill the installations at this point and then start again. When you come to this selection scene, you can delete the partitions that Windows created, set up your own and then point to the one you want Windows installed to.

Hope this helps,

...S

hgl
Beginner
3,322 Views

That was what I did. As mentioned in the OP, I deleted all partitions (both HDD and SSD’s), selected unallocated disk, and clicked next.

When Windows failed to boot, I re-entered the installation, using cmd line diskpart to list disks. The SSD had the star under the GPT column.

n_scott_pearson
Super User Retired Employee
3,316 Views

Can you boot from the SSD using the F10 key at BIOS POST and selecting the UEFI entry for this drive?

hgl
Beginner
3,311 Views

Nope, if legacy boot isn’t enabled, there won’t be any UEFI boot options for the SSD, only ip4 and ipv6 net boot options. If legacy boot is enabled, SSD shows up, with no UEFI mentioned. Selecting it won’t boot into Windows.
LeonWaksman
Super User
3,278 Views

Samsung PM981a is an OEM drive, could be that there is compatibility problem with this drive. Can you check an other consumer line NVMe SSD?

Leon

 

MRoss5200
New Contributor III
3,267 Views

I have seen this when installing Windows onto a drive that is not fully cleaned. Boot off a USB Windows Installer with UEFI Boot and Secure Boot enabled. When you get to the very first install dialog, press Shift+F10 to get to a command prompt.

type: "diskpart" then press Enter.

type "list disk"

type "select disk X" with X being the drive number you want to clean. Make sure you are selecting the correct drive as this tool will NOT prompt you at all.

type "clean"  this will wipe everything off the drive just as it was from the factory. You will NOT be prompted before this is done so make sure you have the correct drive selected.

type "list disk" again to make sure the drive shows no bytes being used. The type "exit" twice to return to the Windows install dialog.

Go through the Windows install again and you should be able to boot then. If this does not work, the PM981a drive may have some firmware that prevents it from working on this NUC. You may want to try it on another computer to see if the drive is the issue.

hgl
Beginner
3,255 Views

When I first installed Windows, the SSD was brand new, with no data had been written.

I guess it's a compatibility issue. I have returned the SSD, although my vendor refused to sell me another SSD :(.

PM981a is quite popular on desktop systems. Given its performance and price. Hope NUC could support more SSDs in the future.

I'll stick with HDD for now.

LeonWaksman
Super User
3,204 Views

Hi @hgl 

Sorry for so late response. I would recommend to buy a M.2 PCIe NVMe SSD. On this list you have some SSD validated by Intel to use on your NUC. 

 

Leon

 

Reply