Intel® NUCs
Support for Intel® NUC products
12118 Discussions

Can't update BIOS on D54250WYK

idata
Community Manager
1,660 Views

Hi Guys,

I'm new here and probably limited in my tech ability, so please be nice

I have a D54250WYK, and its currently on BIOS 24. I notice the current BIOS is 42 so I'm well behind. I am having some difficulty updating the BIOS.

Firstly, what are the advantages of updating the BIOS? Things seem to be running okay on my NUC running LibreElec, but if there are any improvements, that would be great.

So my issue is for some reason when I try hitting F7 when the NUC Boots, I get a blank screen, which flashes/flickers a green line ever few seconds, requiring a hard reset.

I can get in to the F2 BIOS, but I don't think I can upgrade from there?

I have followed the instructions on the Intel site and tried to do the Power button update, which allows me to select F7, select the 00042.BIOS file, but then when I press enter for ok, the NUC just resets and launches Libreelec/Kodi boot again with no BIOS update.

Any help would be much apprecaited

0 Kudos
8 Replies
LeonWaksman
Super User
552 Views

Hello Chongwho

1. In my opinion, it is advised to update so old version of bios. Any way, this document details all changes and improvements included in the newer bios versions:https://downloadmirror.intel.com/26159/eng/WY_0042_ReleaseNotes.pdf https://downloadmirror.intel.com/26159/eng/WY_0042_ReleaseNotes.pdf

2. In your case use the recovery mode to update bios: once you enter the Power Button Menu (with WY0042.BIO file on USB stick in USB socket), press F4 key instead of F7. Wait few seconds and the bios recovery will start automatically and continue to the end. The computer turns off when the recovery process is complete, or it prompts you to turn it off.

idata
Community Manager
552 Views

Thank you very much!

I will have a read through the updates to see what has changed since BIO 24.

I had tried the F4 recovery initially, however it turns out that it was a problem with the USB Flash drive the whole time! Feel a bit silly, but I have been able to update now!

Cheers

n_scott_pearson
Super User Retired Employee
552 Views

Louis,

I too would recommend that you upgrade to the latest available BIOS release. Every interim release of the BIOS introduced fixes for uncovered bugs and/or updated versions of firmware with improvements and/or new features. This is all well worth having.

I also recommend that you install the latest BIOS using the Recovery Method. This ensures that all firmware components are updated or refreshed, not just the BIOS. Here's my recommended process for performing this update:

  1. Format (or reformat, as the case may be) a USB flash disk using the FAT32 file system. Stay away from ExFAT and other clone file systems.
  2. Download the .BIO file for the latest BIOS and copy it onto this USB flash disk. It should be the only file on the flash disk.
  3. If it is not already, completely power off the NUC and disconnect its power cord.
  4. Plug the USB flash disk into one of the NUC's USB ports.
  5. Flip the NUC over onto its top (I flip it over onto an old mouse pad so its surface isn't marred by anything).
  6. Undo the four screws so you can remove the bottom panel. For WYKH owners, carefully lift and flip the bottom panel off to side so that the SATA data and power cables are not pulled off the board. For WYK owners, just remove the bottom panel.
  7. Remove the yellow jumper from the board.
  8. Reconnect the power cord and reach under the NUC and press the power button.
  9. The NUC should power up and automatically start the Recovery Update process. Onscreen, you should see its progress being displayed. When it is complete, it will tell you so. Note: if you see no display at all, wait 10 minutes before powering off, just in case the update is actually running (without a display).
  10. Remove the power cord and replace the yellow jumper on the header (across pins 1 and 2).
  11. Restore the bottom cover and screw tight. For WYKH owners, be careful to not unplug SATA data and power cables as you do so.
  12. Flip unit back over, reconnect power, remove USB flash disk and then power unit on.
  13. When BIOS splash screen appears, press F2 and enter BIOS Setup (Visual BIOS).
  14. Press F9 and then Y to have the BIOS Configuration set to defaults.
  15. Go through the configuration screens and change only those necessary to boot (the Boot Order and UEFI configuration, primarily, but I also disable NUMLOCK and a few other things like that). While the parameters supported may have changed during the many interim BIOS updates, most will be the same and the ones that were changed from their previous setting to the default setting will be highlighted. You can thus easily review which you absolutely need to change back to their previous setting.
  16. Exit from BIOS Setup saving the BIOS Configuration.
  17. Proceed to boot into your O/S.

Hope this helps,

...S

idata
Community Manager
552 Views

Thanks Scott.

Your instructions made me check the USB flash drive again. I was using a pretty crappy pharmacy promotional USB Drive.

I changed this up and reformated, and then it worked with the F4 recovery mode.

Thanks so much for your detailed response!

Now all I need to do is work out why the NUC keeps turning on randomly by itself without receiving a command from my Harmony Elite Hub. (might be a question for another thread)

Cheers

idata
Community Manager
552 Views

Hello Chongwho,

I am glad to hear that you were able to update the BIOS. In this case, yes the best support should be provided by https://community.logitech.com/s/ Forums, https://forum.libreelec.tv/ https://forum.libreelec.tv/ and http://forum.kodi.tv/ http://forum.kodi.tv/.

Thank you to all the peers for the help.

If you need further assistance let us know.

Regards,

Amy.

LeonWaksman
Super User
552 Views

Hello Chongwho

Try to disable boot from network (in advanced bios settings).

TheRealAdrian
Novice
416 Views

Hi Scott,

Just wanted to say that these steps have enabled me to update the BIOS on my D54250WYKH from v26 to v54.

All the update options given on the Intel NUC site failed in various ways and I was beginning to think I would have to go through each update version in turn.

Express BIOS (Windows-based) Update said it couldn't cope with 'Legacy'

Booting into the BIOS Setup with F2 and then selecting F7 Update BIOS from internet just resulted in a "Version not found" message. And it couldn't see the USB stick I'd formatted in exFat

F7 Update got part way through and then failed on 'Flashing image for Intel Management firmware'

BIOS Recovery by Power Button Menu is impossible - press on button for more than 3 and less than 4 seconds! Couldn't do it even with a stop watch!

So thanks for highlighting the Security Jumper way and only using a USB formatted with FAT32. Worked a treat

Adrian

TheRealAdrian
Novice
367 Views

Quick update

I've just run this process on another D54250WYK. At first I used an older USB stick and it didn't work, it just sat there with the blue power light on and a blank display. Then I tried a more modern USB stick and did a full format to FAT32. I turned off Quick Format. This time it worked properly.

I think you need to use a modern, high quality USB of something like 2 to 8GB. Maybe you can get away with a Quick Format. But to eliminate troubles just do a Full Format.

Adrian

Reply