Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12771 Discussions

Compatibility Win 7and Intel 8th gen core processor


Dear all,


I will schematically give some more detailed info, to let understand the issue.


1.     The notebook model is HP 15-da0087nl

2.     Preinstalled OS Win 10

3.     HDD internal 1TB TOSHIBA MQ04ABF100

4.     DVD drive present


My need is to install Win 7 to a partition in order to have a dual boot system.

Therefore, I tried out all the following actions:


1.     made a partition on Win 10 (main OS, Disk Management action) of about 500GB and formatted (slow formatting) NTFS

2.     modified the UEFI/BIOS by setting Legacy ENABLED and Security DISABLED.

3.     set the BIOS boot priority as follows:

a.     DVD driver

b.     USB port

c.      HDD

d.     USB externa DVD driver

4.     F10 save and exit BIOS

5.     restart with Win 7 PRO installation on DVD driver

6.     the installation started, but the process couldn’t detect any drive and partition. Then, a message popped up asking for a device driver for CD-DVD unit.

7.     Downloaded from Intel the following drivers:


8.     Burned a CD with driver and started the installation from point 5.

9.     When the message popped up, I inserted the CD and the detected driver was the:

a. for 32-bit versions of the operating system

10. The OS installation started loading the driver, but after a while has stuck and a message popped up saying the impossibility such a driver… contact the supplier for an updated driver.

11. I repeated everything from point 5. , but this time with Win 7 Ultimate 64bit. This time the detected driver was the:

a. - for 64-bit versions of the operating system

12. Same result: the OS installation started loading the driver, but after a while has stuck and a message popped up saying the impossibility such a driver… contact the supplier for an updated driver.

13. Changed 1st strategy: I made an ISO image of both OS Win 7, then two different bootable USB key with Rufus -> same results by booting from USB port, with both Win 7 PRO and Ultimate 64bit.

14. Downloaded a Win 10 image from Microsoft and made a USB bootable key -> this OS installation can correctly detect all partition and start installation without problem.

15. Changed 2nd strategy: I went back to Win 7 Ultimate, but by launching the installation from Win 10, after set back BIOS to UEFI, Legacy DISABLED and Security DISABLED, and from prompt executing the following in order to disable the digital signature:

a.     bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS

b.     bcdedit.exe -set TESTSIGNING ON

c.      Restart

16. The result was the best one from the beginning -> all the files of Win 7 Ultimate 64bit where correctly installed, but at the first restart the new OS stuck on STARTING, and the installation COULDN’T BE COMPLETED!

17. Turning on the computer, that’s the situation at the moment, the system detects the dual boot with Win 10 as second option, but the Win 7 first option actually report “SETUP INSTALLATION”. By following the installation setup, the new OS stuck again on starting.


I purchased an external DVD driver as well, I’ll receive it by next 10 days.


Could be any incompatibility between Win 7 and the BIOS version F.02 of the notebook?

Does it make sense?


What could I do more?


Thanks a lot for the attention and help.




0 Kudos
3 Replies
Super User

The issue is, simply, that ONLY Windows 10 is supported on 7th gen and later processors. Personally, I would enable Hyper-V, and install Windows 7 as a VM under Windows 10.






Hi Al,

Thanks a lot for the answer.

I know and I use fhe VM too.

The fact is that I would like to use the full RAM and​ resources with a main OS (Win 7 actually) because I would need to make heavy simulations.

VM is normally limited ​to use a portion of resource, that's why I wished to have a dual boot.

Will you confirm me than I really would have no chance about it?​ no way to use Win 7 with 8th gen processor?



Super User

There is no support for anything less W10 on 7th gen and later processors. You may want to visit one of those forums on the net that love hacking through this. Again, you will be unsupported.