Showing results for 
Search instead for 
Did you mean: 

D54250WYK - Windows 7 Installation Problems

I recently purchased a D54250WYK (D54) for a special purpose application as a Sound Engine Computer in a Virtual Pipe Organ. Prior to this, I had purchased and installed a D53427HYE (D53) and was extremely pleased with the ease of getting it running and its performance. I am starting another organ rebuilding project and wanted to use the latest NUC offering.

The Sound Engine software runs under Windows 7 64 bit Home Premium, often without a monitor, keyboard, mouse or network connection, once it has been set up. I have installed 2 4GB memory cards and a Crucial 120 GB mSATA SSD.

The actions and problems I have experienced so far.

1. Attempted to load W7 from USB Samsung Optical Disk Drive using Legacy USB (2.0?) mode - NOT Recognized by the NUC. Drive seems to work properly on other computers and worked fine on the D53.

2. Updated the BIOS to V 24 (latest) - Same results a 1. above. Event Log reported (4) (Errors?), but it seems to work OK.

3. Made a Boot Flash Drive and copied W7 to it.

4. Boot Flash Drive worked and W7 started its initial load.

5. After about 2 or 3 screens, It halted and gave an error that it could not find CD/DVD Driver and asked for the driver files..

6. I downloaded and extracted the driver files and copied iaAHCIC.inf, and 4 other files specified in the instructions to another Flash Drive.

7 I plugged in the Flash Drive and W7 found the allegedly applicable files for chipset 8 (the others were hidden).

8. When I said to install the drivers, W7 said that they were not the correct files for this computer.

Any suggestions would be appreciated on where to find the appropriate drivers for W7 and D54.

0 Kudos
7 Replies
New Contributor II

My experience: D54250WYK, BIOS V 24, new/empty Intel SSD, Samsung optical drive, genuine Windows 7 Pro DVD 64 bit, Legacy boot: Windows 7 installs right away.


Thanks Ubbe and Jan,

I have a recently purchased and licensed copy of W7 Home Premium on DVD that I used to make the Flash Drive copy.. I guess the problem could be a bad SSD, because the error occurs at about the point where W7 files would start being copied to the SSD. One thing I don't understand is why the D54 BIOS does not recognize that the Samsung external Optical Drive is plugged into one of the USB 3.0 ports and show it as a Boot Device.. All USB ports show as enabled in the BIOS and the mouse and keyboard I have plugged in work fine. I think I recall reading that there were some problems with the USB 3.0 ports on the NUC having problems dealing with USB 2.0 devices.

New Contributor II

I understand your thoughts about the SSD.

Did you try to connect your optical drive to one of the USB ports at the back? I think I recall reading that the front and the rear ports could behave differently. But it doesn't matter in my case.



I tried both front and back ports and nothing positive. It is possible that the BIOS is corrupted and cannot read any of the ports. I considered using the 2.0 USB ports on the inside header, but the pin spacing is 2.0 mm rather than the typical 2.54 mm spacing of a USB 2.0 port on a motherboard. Without a proper 2.0 mm connector to USB 2.0 female, the two inside ports are worthless.

I gave up trying to use that particular D54 and exchanged it for another. I used the same memory, but changed the SSD and the USB cable on the optical drive. I plugged the mouse and the keyboard into the Front USB connectors and the Samsung optical drive into the lower USB port on the Back.

When I powered this D54, The BIOS setup (F2) immediately recognized the Samsung Optical drive. I set that a # 1 in the boot order, saved the changes (F10) and let it restart.

Windows 7 loaded without any problems from the Samsung and it appears to be going through its startup ritual.

Thanks for helping



Hi Carl,

I had exactly the same problem with my D54250WYK, I found my problem was my optical mouse. It appears that the NUC bios looks for an optical device when it reboots following the initial file load of W7 from the DVD drive, and when it found the mouse it looked for suitable drivers, which obviously didn't exist - don't forget the bios is only as clever as the person who writes the program.

Anyway, my cure was simple; when W7 reboots following the initial file load, pull out the mouse USB plug until the NUC has found the correct DVD drive and started loading files again, then simply plug the mouse back in and it works just fine.

Hope this helps someone else.

Cheers, ... John


I had the problem that my NUC (same board) didn't recognise my USB3.0 stick from which I wanted to install Win7 64-bit.

Downgrading to bios version 21 solved my problem. My stick was finally visible as a bootable device and Win7 was installed on my SSD within 10 minutes. Hope this helps!