Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,183 Views

D54250WYK screen problem

Jump to solution

Hello,

I have the above nuc. I don't know what happened but the graphics no longer display on the monitor. When I press power, I can hear the unit turning on but nothing is shown on the screen. The monitor says no signal. I thought maybe the msata drive or memory died so I went and bought a replacement. After putting a brand new msata and memories into the unit, same problem. Nothing shows on the screen. Does anyone know what's going on?

Thanks.

Robert

0 Kudos

Accepted Solutions
Highlighted
Super User
19 Views

Hello Robert,

-Is the Power Led illuminated when you switch the unit ON?

-Can you try other video cable and/or other video input in monitor (i.e. Display Port or HDMI)?

-If you don't see any video output at all (even not an Intel logo during boot), try to recover your bios: https://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html BIOS Recovery Update Instructions for Intel® NUC and

https://www.youtube.com/watch?v=ZAMLk62Pb9s BIOS Recovery Demo | Intel - YouTube The latest bios file WY0045.bio download here: https://downloadcenter.intel.com/download/26632/BIOS-Update-WYLPT10H-86A-?product=76977 Download BIOS Update [WYLPT10H.86A]

Hope this helps

Leon

View solution in original post

0 Kudos
4 Replies
Highlighted
Super User
20 Views

Hello Robert,

-Is the Power Led illuminated when you switch the unit ON?

-Can you try other video cable and/or other video input in monitor (i.e. Display Port or HDMI)?

-If you don't see any video output at all (even not an Intel logo during boot), try to recover your bios: https://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html BIOS Recovery Update Instructions for Intel® NUC and

https://www.youtube.com/watch?v=ZAMLk62Pb9s BIOS Recovery Demo | Intel - YouTube The latest bios file WY0045.bio download here: https://downloadcenter.intel.com/download/26632/BIOS-Update-WYLPT10H-86A-?product=76977 Download BIOS Update [WYLPT10H.86A]

Hope this helps

Leon

View solution in original post

0 Kudos
Highlighted
Super User Retired Employee
19 Views

For the most part, I agree with Leon. My prioritized list of things you should try is as follows:

  1. Perform a CMOS reset. This is detailed here: http://www.intel.com/content/www/us/en/support/boards-and-kits/000005805.html Intel NUC Clearing CMOS.
  2. Perform a BIOS recovery using the latest available BIOS. This is detailed here: http://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html?wapkw=bios+recovery Intel NUC BIOS Recovery Update Instructions. Leon's link to video showing process is good too.

...S

0 Kudos
Highlighted
Novice
19 Views

Hi Leon,

Yes the power led is illuminated.

And yes, you are correct. Changing the video cable fixed the problem. I am getting video output again. That would be the last thing I would think about changing. How could a cable gone bad? I don't get it. Does this happen often?

Thanks!

Robert

0 Kudos
Highlighted
Novice
19 Views

Thanks N. Scott. Changing the video cable helped. Don't know why but it did.

Robert.

0 Kudos