Community
cancel
Showing results for 
Search instead for 
Did you mean: 
HSart
Beginner
228 Views

DSA fails to install all 5 updates

Problem for 5 months since it worked great.
I uninstalled, rebooted, downloaded & installed as Administrator.
5 updates are shown available.  Tried to install one a time and all, but all failed to install.  
What is the next step to troubleshoot.
Thanks.   /Howard

0 Kudos
9 Replies
AlHill
Super User
207 Views

So the Intel support engineers can have more information about your system, Download, run, and save the results of this utility as a text file:
https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

Then ATTACH the text file using the instructions under the reply window ( Drag and drop here or browse files to attach ).

Doc (not an Intel employee or contractor)

HSart
Beginner
197 Views

Attached, Al.   BTW the DSA works perfectly in all my clients NUCs - just mine is giving me problems!!!

HSart
Beginner
149 Views

Thank you.  the process went as you described.

The boot is to IPX, but I can fix that.

Bios looks updated.  But the IDSA 21.2.13.9 detected 4 available updates and this showed up in the Windows Action Center, neither one loaded.

Thanks. / Howard 

 

 

LeonWaksman
Super User
142 Views

Hi Howard,

I can see that the BIOS is now updated to the latest version. I'm assuming that you have installed the Chipset Device Software and the Management Engine Driver. If not yet, I suggest that you download the Chipset Device Software and Management Engine Driver. Unzip the zipped drivers and install by clicking on SetupChipset.exe and MEISetup.exe accordingly. Reboot your NUC.

Next, you need clean reinstall the Intel Graphics Driver:

1. Download the Intel DCH Graphics Driver. Unzip the downloaded file.

2. Disconnect the Internet and open Device Manager.

3. Click on Display adapters and then right click on Intel HD Graphics. Next, click on Uninstall device (check the "Delete device software..." option). Reboot your NUC.

4. Check in Device Manager that now you see Microsoft Basic Graphics Driver in place of Intel driver. If not yet, repeat para. 3-4.

5. Install the previously downloaded Intel DCH Graphics Driver version 27.20.100.8681. Reconnect the Internet and reboot your NUC.

6. Check now the IDSA.

 

Leon

 

 

 

HSart
Beginner
122 Views

Got it all done this time including the DCH Graphics.  NUC works faster now. but still lists 5 updates available:

5 software updates available
   Intel® Wireless Bluetooth® Driver for Windows® 10 64-Bit for Intel® NUC             
   Intel® Ethernet (LAN) Network Connection Driver for Windows® 10 for Intel® NUC
  
   Intel® Wireless Technology-Based Driver for Windows® 10 64-Bit for Intel® NUC
   Thunderbolt™ 3 DCH Driver for Windows® 10 for Intel® NUC
   BIOS Update [FNCML357]

uninstalled, rebooted several times, but no improvement. What next?

Thanks you! 
/Howard

LeonWaksman
Super User
110 Views

Hi Howard,

"... but still lists 5 updates available:" do you mean that still IDSA suggesting that 5 drivers are available to update? If I understand you correctly, then download and update those drivers using IDSA. The IDSA was designed for drivers and BIOS updating.

About the BIOS update: currently you have installed BIOS version 0051 (FNCML357.0051.2021.0324.1859). In the last day a new version for this BIOS 0052 (FNCML357.0052.2021.0409.1144), was added to the download center. So, update BIOS again. Since you have BIOS updated already to version 0051, the express method (using IDSA), should work.

 

Leon

 

 

HSart
Beginner
76 Views

Thank you, Leon.
I went to C:\ProgramData\Intel\DSA\Downloads.
I saw the new BIOS version there.   To use it I changed the permissions and ran the .exe   and the process competed normally, correctly.

So the remaining problem is that the other updates are not installed.  Result is "install failed" changes to  "install"
Can I replace the software associated with the install process.  I'm not sure which program is involve.  the two Services seem to be running correctly.    (I have uninstalled and re-installed several times.)

Thanks. /Howard

HSart
Beginner
177 Views

Al,

I'm resend - I think I forgot on how to attach. 

Thanks for your help!!

/Howard

LeonWaksman
Super User
167 Views

Hi @HSart 

1. Your BIOS is very outdated. You have installed version 0038, while today we have version 0051 released. So, you need to start with BIOS update. Since, probably you never updated BIOS and update from version 0038 to 0051 is quite big step, I suggest that to update BIOS, you should use BIOS Recovery by BIOS Secure Jumper method. If you will try other methods ( express, F7, or Recovery by Power Button Menu), the update may fail.  To be on safe side, use better Recovery by BIOS Security Jumper Removed:
2. Prepare USB stick fully formatted to FAT32 . Format your USB with Quick Format option unchecked. Do not format your USB in MAC (OS) or Linux machine. Use Windows.
3. Download the BIOS Recovery [FNCML357.0051.RECOVERY.zip and extract the FNCML357.cap file from this archive. Copy the FNCML357.cap to the root of the previously prepared USB stick.
4. Disconnect the power adapter and remove the bottom panel from your NUC.
5. Remove the Yellow Bios Security Jumper (see page 33 in the Technical Product Specification for jumper location)
5. Insert the USB with the BIOS file into rear USB slot.
6. Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min. The Recovery process will start automatically and will end after 2 -5 minutes.
7. When bios recovery is completed, press and hold the Power Button to switch the power OFF, remove the power adapter and replace the Security Jumper (pins 1-2) . Reinstall the bottom panel.
8. Power your NUC ON.
9. Enter Bios setting by pressing F2 during boot process.
10. Press F9(confirm by Enter), to set Bios to default settings. Press F10 (confirm), to save the settings and exit to O.S. Let the NUC fully reboot.
11. If before BIOS recovery you changed BIOS settings, now you may enter BIOS and set the settings again as required.

12. After BIOS update please download the Chipset Device Software and Management Engine Driver.  Unzip the downloaded files and install both drivers. Reboot your NUC.

13. Only now try to update drivers, using IDSA

Leon

 

Reply