Intel® NUCs
Support for Intel® NUC products
11772 Discussions

Disable Secure Boot Hades Canyon NUC



I'm running into a bit of an odd issue that I can't seem to resolve. In short, I have a Hades Canyon NUC that will be running Ubuntu Server (I've tried 16.04 and 18.04 LTS releases) with VirtualBox on it. Due to the fact that VirtualBox utilizes unsigned Kernel Modules, I need to disable Secure Boot. However when I disable Secure Boot via the checkbox in the following menu: Advanced->Boot->Secure Boot->Uncheck Secure Boot, Ubuntu completely stops booting. This is whether I'm attempting to boot Ubuntu from the local disk, or an Ubuntu Flash Drive installer. Grub displays, I select a boot option (either Ubuntu or Install Ubuntu Server depending on if I'm attempting to boot from local disk or Flash Drive), the screen goes black (using HDMI) and all of the USB ports stop functioning (Keyboard, Mouse, etc...). As soon as I reenable Secure Boot, everything is back in working order..rinse wash and repeat. I've tried everything I can think of and can't find a resolution. I've tried updating the bios, clearing secure boot data, and a few other things, none of which has worked. Does anyone have any ideas on what the issue could be? I can confirm UEFI booting is still enabled and my flash drive is setup with UEFI and not legacy bios.

Thanks in advance!

0 Kudos
3 Replies

Talk about coincidence. I ran into the same issue yesterday. Yet to figure work out a working solution.


Same, at this point I feel like I've narrowed it down to an UEFI bug or something really stupid I'm doing (or not doing)...honestly, I'm hoping for the latter.

Community Manager

Hello all,



Thank you for joining this Intel Community.



I understand that your Intel® NUC experiencies no boot issues when disabling Secure Boot in BIOS. I would like to provide some information about this issue.



Intel does not test and validate Intel® NUC on Linux. However, we know that a lot of Intel® NUC owners are using it successfully on many different Linux distros. I recommend you to check your Linux distro's website and forums for peer assistance with this inquiry. You can also refer to these support websites below:



It is worth noting that you can make sure that your Intel® NUC is up to date.



Wanner G.