Intel® NUCs
Assistance in Intel® NUC products
All support for Intel® NUC 7 - 13 systems is transitioning to ASUS. Read more.
13487 Discussions

Does anyone have Thunderbolt working ona NUC7I5 machine?


I own two NUCs with Thunderbolt support, a NUC8I5BEH and a NUC7I5BNH.  The NUC8 works just fine with my Razer Thunderbolt eGPU but the NUC7 does not.  They are both running the latest version of Windows 10 Pro.

I previously opened a thread here about the NUC7 but have had no luck following the suggested ideas on how to fix the Thunderbolt problem and they have given up.

The NUC7 works just fine for everything but Thunderbolt.

I am unclear what generation NUCs started to have Thunderbolt support but I think it was the NUC7 generation.

I am wondering if Thunderbolt support ever worked correctly on the NUC 7 machines.

It would not be the first time by any means that an initial implementation of a new feature never quite worked right and was fixed in a later version.

Can anyone actually verify that they got a Thunderbolt 3 device to work successfully on a NUCI7 series machine and if so tell me what that device was?

I only have one Thunderbolt device to test with but since it works fine on my NUC8 I would think it should work fine on the NUC7 as well unless there is a bigger problem.




0 Kudos
2 Replies

Hello @JCahow

Thank you for posting on the Intel® communities.


Since Intel® Customer Support provided assistance through the thread that you have mentioned, and since we found that you have an internal open case describing the same issue and the same hardware/software environment as the one in this thread, to avoid duplication of effort we will close this inquiry now from our end. However, we will leave the thread open for other users to participate.


If you need any additional information, please submit a new question as this thread will no longer be monitored. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician


0 Kudos
New Contributor III

Cant even get the latest driver to install, Not to worried I only have a Display attached via a USB C to HDMI and that works perfectly. I have the pervious TB driver installed but the last one Gets Fatal error.

Tried a few times and the forgot about it.

0 Kudos