Intel® NUCs
Support for Intel® NUC products
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
12546 Discussions

Driver assistant fails to install a driver 2

SandS
Novice
434 Views

 

When I try to install the driver it just does a rescan and dis[lays the Install button again.

Intel® Ethernet (LAN) Network Connection Driver for Windows® 10 & Windows 11* for Intel® NUC8i7HVK & NUC8i7HNK

I saw that other people had this problem and the solution was to uninstall the Driver Assistant, reinstall it and restart the NUC.

I have done this 5 or 6 times and the problem still persists.

Please help

Cheers

0 Kudos
5 Replies
charlesv
Beginner
407 Views

I have a NUC5 and Win8.1 and dont want to steer you the wrong way but that assistant never worked for me. When I asked in the forum I was told to ditch it, download and install needed items one by one. Also no good is the online assistant that scans and creates a list. What is the correct list of items you need? Ask it as a new question. I got great help at the time and wrote down the whole list which I keep in case of needing to re-install everything which I had to do at least five times before the dang thing settled down. There is an order to installing drivers and updates and you have to follow it in steps. Its been three years and never did I have to return to the problem. Having said this, it may or may not apply to you if you have correctly installed drivers previously up to this point.

Alberto_R_Intel
Moderator
319 Views

SandS, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this matter, we just wanted to confirm a few details about your system:

Is this a new Intel® NUC?

When did you purchase it?

Were you able to properly install the LAN drivers with the Intel® Driver Support Assistant before on this specific machine?

If so, when did the issue start?

Did you make any recent hardware/software changes that might cause this problem?

Which Windows* version are you using?

Does the problem happen at home or in the work environment?


We recommend to try scanning with different browsers. Intel® DSA only works with: Chrome, Firefox and Edge. 

Then you can also try to clear the browser cache then try rescanning the Intel® DSA tool.


If the problem persists, run the Intel® Driver & Support Assistant Uninstaller version 22.1.8.8:

https://www.intel.com/content/www/us/en/download/19333/intel-driver-support-assistant-uninstaller.ht...


Restart and install the latest Intel® Driver & Support Assistant tool version 22.1.8.8:

https://www.intel.com/content/www/us/en/download/18002/intel-driver-support-assistant.html?wapkw=int...


If the issue remains, Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...


The latest Intel® Driver & Support Assistant Uninstaller log file: using File Explorer, search for DSAUninstaller.log


The latest Intel® Driver & Support Assistant log files: using File Explorer: go to folder = C:\ProgramData\Intel\DSA, and zip the Log files or entire folder.

Note: Uncheck "Hide System Files" to see the AppData folder.

Show hidden files

https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician



SandS
Novice
268 Views

Thanks for that.

I ran the DSA in Chrome and it completed the update. I was using Edge before and it hadn't worked.

Thanks

Alberto_R_Intel
Moderator
247 Views

SandS, You are very welcome, thank you very much for letting us know those details.


"I ran the DSA in Chrome and it completed the update", perfect, excellent, we are glad to know the problem got fixed and the update was properly completed while using Chrome as the browser.


Any other inquiries, do not hesitate to contact us again.


Regards,

Albert R.


Intel Customer Support Technician


Garitaar
Novice
228 Views

Hello @SandS  @Alberto_R_Intel  @charlesv  

 

There are several threads on this topic, and Intel unambiguously have more than one issue in their workflow that enabled the compounded challenge with this LAN update.

 

Intel have apparently not communicated with Microsoft so they can push 1.0.2.14.

 

This approach succeeded for me.  If you are doing this and it is not succeeding, I would be curious to know more.

 

Let's take it from the top.

 

1)  download the driver.

https://www.intel.com/content/www/us/en/download/19711/intel-ethernet-lan-network-connection-driver-...

 

2)  unzip the driver folder so you can point Device Manager to the folder containing the driver.

 

3)  Open Device Manager, Network Adapters, Ethernet Controller (3) I225-LM, and open the Driver tab.

 

4)  If any version other than 1.0.2.14 is presented, choose Uninstall Device and check the box for attempting to remove the driver.

 

5)  Close the Ethernet Controller (3) I225-LM dialog box.

 

6)  Within the Device Manager, right-click on Network Adapters and select Scan for Hardware Changes.

 

7)  Ethernet Controller (3) I225-LM should reappear in the list. 

 

  Reopen the dialog box for Ethernet Controller (3) I225-LM and go to the Driver tab.

 

9)  Within the dialog box, select Update Driver and Browse My Computer.

 

10)  Locate the folder where you unzipped LAN-Win10_Win11-1.0.2.14 and select the folder as the driver source.

 

11)  Driver version 1.0.2.14 should successfully install.

 

12)  Reboot.

 

13)  Run Microsoft Updates.

 

14)  when/if Windows Update reverts the driver to version 1.0.2.6 then use the Device Manager function "Roll Back Driver" to the previously installed version which was 1.0.2.14.

 

(Note that the rollback function appears to be about the order in which drivers are loaded, not about version numbers or their dates.)

 

Reply