Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
455 Views

Enabling legacy boot options in NC8i7BEKQA2 visual bios

Hello,

 

I need to install a legacy linux system on a new NUC computer.

 

In the bios, the legacy options are greyed out even after disabling UEFI boot.

 

I've tried to upgrade / reset the bios settings and change the hard drive (NVMe -> mSATA) but the options are still greyed out.

 

Anyone have a solution for this ?

Tags (1)
0 Kudos
5 Replies
Highlighted
Super User
186 Views

  1. If you installed system with UEFI boot, you can't enable Legacy Boot option any more.
  2. If you have not installed UEFI system yet, disable Secure Boot option first.
  3. Be aware that if you have NVMe SSD drive installed on your system, UEFI boot is mandatory.

Leon

 

0 Kudos
Highlighted
Beginner
186 Views

Thank for your quick answer.

 

The NUC and the hard drive are brand new and never had a OS installed on them.

We did , in fact use a NVMe SSD drive , if we replace it by a M2 SATA, can this enable th elegacy options, if not have we a solution to "reset" the BIOS to a state with the options availble?

0 Kudos
Highlighted
Super User
186 Views

  1. In the last bios versions, Intel have removed.disabled the possibility to boot with Legacy boot option enabled. I don't like it neither.
  2. I've checked on NUC7i7DNHE and I did not succeed to enable the legacy option. The reason for this may be that I have Optane Memory module installed in M.2 slot.
  3. You may try by your self:
  4. Prepare bootable USB (with legacy boot).
  5. Disable Secure Boot in Bios.
  6. Disable UEFI boot and enable Legacy boot. Press F10 followed by "Y" to save changes and exit from bios.
  7. During boot process, press on F10 to get Boot Menu.
  8. See if you can see your USB in this menu.
  9. You can also wait for answer from Intel's Engineer.

 

Leon

 

0 Kudos
Highlighted
Super User
186 Views

Hi @Shalien​ ,

Have performed this test again on NUC7i7DNHE. This time I've removed the Optane memory module, changed SATA mode to AHCI, disabled UEFI boot and finally enabled Legacy boot. After pressingg on F10 (Y), the NUC successfully booted to USB with Legacy MBR boot. So, try to do this on your NUC. You don't need SSD for this test, just bootable USB. However if the Legacy boot option in your NUC can't be enabled after disabling UEFI boot, you can't do this. In my other NUC - NUC8i7HVK, legacy boot option doesn't exist in Bios at all.

 

Leon

 

0 Kudos
Highlighted
Super User Retired Employee
186 Views

The NUC8i7HNK, NUC8i7HVK and NUC8i#BE* NUCs do not have a CSM in their BIOS and thus cannot support Legacy boot. In this day and age, there is simply no acceptable reason for why you would require Legacy boot. All Linux distros that have support for the processors and chipset used in this generation also have support for UEFI boot.

...S

0 Kudos