Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MigAndrade
Beginner
407 Views

Ethernet I219-V Internet Speed bottleneck

Hi i have an Intel® NUC 10 Performance kit - NUC10i3FNH windows windows 10, but i have a problem with internet speeds.This box have the Ethernet Intel®(10) I219-V i updated to the last drivers 12.18.9.23 but the speeds over internet only can achieve half.

Test transfer files file between PCs with Ethernet I219-V

980Mbps   - This is OK

 

Test internet speedtest with Ethernet I219-V

60Mbps   -Half because i have 120Mbps

 

Test internet speedtest with wifi

120Mbps   -This is OK

 

If i configure the Ethernet I219-V to 100Mbps Full Duplex it can reach 98Mbps at the speedtest.

Already tried this in Ubuntu 20.04 same problem with internet speeds, so this is something with bios?

 

I tested with more 3 devices in same network and cable utp cat6(Toshiba, Apple, Insys) everyone give 120Mbps in the speed tests by Ethernet, my router is a Fritz!Box 7390.

 

After check google i see many people with problems with this Ethernet I219-V 

0 Kudos
6 Replies
Sebastian_M_Intel
Moderator
381 Views

Hello MigAndrade, 

 

Thank you for posting on the Intel® communities.   

 

In order to get more details about this behavior, please provide the following: 

 

1. Run the Intel® System Support Utility (Intel® SSU) and attach the report generated:  

  • Open the application, check the "Everything" box, and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".   
  • Click on the menu where it says "Summary" to change to "Detailed View".   
  • To save your scan, click on "Next", then "Save".   
  • Use the option under the reply window to attach the report to the thread (Drag and drop here or browse files to attach).  

 

2. Did the system work as expected before? If yes, do you remember making any changes before the issue started?  

3. How do you measure the speeds? Can you please share a screenshot of the reported speed using the ethernet port?  

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician  


MigAndrade
Beginner
360 Views

Hi @Sebastian_M_Intel  after doing some research already have a temporary fix.
Now I have 120Mbps over internet with  I219-V.

ok120mbps.jpg

 

We need to go: Control Panel\Network and Internet\Network Connections\Ethernet\Properties\Configure
Interrupt Moderation: Enable
Interrupt Moderarion Rate: Extreme

 

i219_v_internet_speed.png

 

Now its fiexd in windows 10, dont now why we need to make this changes to work, but its works.

In ubuntu can we do something like this to?

Sebastian_M_Intel
Moderator
341 Views

Hello MigAndrade,  

 

Thank you for your reply.


For Linux* support, we highly recommend you checking with your distro's community since Intel does not provide support for these Operating Systems (OS): 

https://ubuntu.com/community 

 

However; we would like to check this behavior internally, please kindly wait for a response. As soon as we have an update we will post it on this thread. 

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician   


Links to third-party sites and references to third-party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third-party endorsement of Intel or any of its products is implied. 


Ronny_G_Intel
Moderator
325 Views

Hi MigAndrade and Sebastian_M_Intel,

I would still recommend (as mentioned previously by Sebastian) to check on the Ubuntu* community but see below some tips that may help you find a way to configure these settings when running Ubuntu.

Interrupt moderation parameters can be controlled by the user using ethtool. In order to view the current settings use the following:

# ethtool -c ethX
Coalesce parameters for ethX:
Adaptive RX: off TX: off

rx-usecs: 8
rx-frames: 32

tx-usecs: 16
tx-frames: 32

Note: Adaptive moderation must be disabled in order to ensure that static values are in use.
It is possible to change the values for ethtool as well:

ethtool -C ethX rx-usecs 0 rx-frames 10 tx-usecs 16 tx-frames 100

Afterwards, the new values should show:

# ethtool -c ethX
Coalesce parameters for ethX:
Adaptive RX: off TX: off

rx-usecs: 0
rx-frames: 10

tx-usecs: 16
tx-frames: 100

Finally, I would also recommend that you check this article: https://www.intel.com/content/www/us/en/support/articles/000005593/network-and-i-o/ethernet-products... run a search for Interrupt moderation rate, this explains why these settings help with the ethernet performance.

I hope this helps.

Regards,

Ronny G

Sebastian_M_Intel
Moderator
293 Views

Hello MigAndrade,  

 

Were you able to check the previous posts and follow our recommendations? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician  


Sebastian_M_Intel
Moderator
254 Views

Hello MigAndrade,  

  

We have not heard back from you, so we will close this inquiry. If you need further assistance or if you have additional questions, please create a new thread and we will gladly assist you.  

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician  


Reply