Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
197 Views

External DVD drive suddenly stopped being detected

I have an external ASUS SBC-06DX-U DVD drive on my NUC nuc8i7beh. Originally when I bought it, it was not recognized and I had to do the registry subkey edit (Method 6 in the link below). I has worked since until about a couple weeks ago or so. I have been doing regular updates, and if that is the cause on the non-detect I don't know which update it would have been.

 

I can plug the DVD into my other PC and it is recognized and works fine. On the NUC there is no DVD drive listed in the device manager.

 

I have checked the registry values as per info online info and it looks fine, as per the last two things here:

https://support.microsoft.com/en-us/help/314060/your-cd-or-dvd-drive-is-not-recognized-by-windows-or...

 

I tried uninstalling-reinstalling the ATPI driver to no effect as per Method 4.

 

I also tried plugging the DVD into the NUC directly and into a powered USB3 hub - no effect.

 

Running out of options! Any ideas?

0 Kudos
1 Reply
Highlighted
Moderator
8 Views

Hello GYare,

 

Thank you for posting on the Intel® communities. 

 

We were doing some research about this issue and also we tried to test this behavior on our end.

 

If the DVD player was working before and it is now not being recognized by the system but other USB devices work, the problem might be related to the Operating System since the registry subkey was edited as well.

 

We recommend you to contact the system manufacturer of the DVD player (ASUS) or Microsoft support to report this issue as well.

 

Regards,

 

Adrian M.

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos