Intel® NUCs
Assistance in Intel® NUC products
All support for Intel® NUC 7 - 13 systems is transitioning to ASUS. Read more.
13504 Discussions

F2, F7 and F10 keys not displaying


I purchased a NUC8i7BEH two months ago and updated my BIOS from version 73 to Version 74.


The NUC has been extremely unstable, the biggest problem being that often on start up, although the ON switch would light up blue, nothing would happen, the system would not boot. I would have to switch my NUC off, reboot it, and it would boot fine. Note that a CMOS reset did nothing to help.


I have just upgraded to BIOS 75.


Now the system seems stable and boots normally. However, I need to wait a little bit longer before declaring that the problem has disappeared as it happened on a random basis.


There still remains a little problem, not very serious indeed, but showing that the BIOS seems somewhat unstable.


When the NUC splash screen is displayed on boot, I want the F2, F7 and F10 key descriptions to be displayed as well, so I ticked the relevant boxes in the BIOS to get them displayed.


However, they never did, whether with BIOS version 73, 74 and they still do not with version 75.


I am wondering why.

0 Kudos
4 Replies
Super User

Hi @Mediomatricus​ 

  1. Enter Bios settings.
  2. Press F9 followed bu "Y" to set Bios settings to default.
  3. Enter Advance > Boot > Secure Boot.
  4. Check Secure Boot (if was checked already, uncheck it and then check again).
  5. Check Clear Secure Boot Data.
  6. Check Force Secure Boot Defaults.
  7. Press on F10 confirmed by "Y", to save Bios settings and exit to Windows.




0 Kudos

Thank you for your fast answer.

Your suggestions did the trick!

However, the options "Clear Secure Boot Data" and "Force Secure Boot Defaults" exclude one another and you cannot tick both.

I ticked the first, which solved the problem.

Should I enter again BIOS settings and check the second (which will uncheck the first) ?

The reason I am asking is that the main problem (computer sitting doing nothing while the ON switch has been pressed and lit up blue) has reappeared.

So updating to 75 did not help and I am at a loss what to do.

Perhaps checking Force Secure Boot Default might help?


0 Kudos
Super User


  1. I was misunderstood. My intention was depress first the "Clear Secure Boot Data", uncheck it and then depress the "Force Secure Boot Defaults" 
  2. If depressing the "Clear Secure Boot Data" solved your problem, enter Bios, uncheck the "Clear Secure Boot Data" and then depress "Force Secure Boot Defaults" .
  3. Depress F10 confirmed by "Y", to save Bios settings and exit to Windows.
  4. If your NUC is not booting now to Windows, update your Bios using Bios REcovery from the Power Button Menu:
  5. Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Format your USB on Windows machine (rather than Linux or MAC). Save the Bios file on this stick and insert it into front USB slot with amber color (NUC shall be OFF).
  6. Press Power Button for about 3 seconds. Count 1001, 1002, 1003,1004. Release the Power Button. NUC should reboot into Power Button Menu. You should release the Power Button before 4-sec shut down override.
  7. Press F4 and the recovery shall start (it can take up to 30 seconds for messages to appear on the screen).
  8. When the recovery finishes, press on Power Button and hold it, until NUC switches OFF. Pull out the power cord. Remove the USB stick.
  9. Replace the power cord and press Power Button to switch the computer to ON.





Deleted: "Uncheck the "Force Secure Boot Defaults" " in para 3

0 Kudos

Thank you again, Leon.

I did was you said.

Everything seems fine.

Actually when I said the computer did not boot to Windows, I meant "did not sometimes boot" to Windows. It does not do it every time.

If it did it, I had to reboot and lo and behold it would mysteriously go to Windows.


Actually, your trick may have solved that problem, too.


I was surprised to hear that checking and unchecking settings in BIOS without exiting and saving changes first, would still be effective, e.g. checking, then unchecking "Force Secure Boot Default", would work, without exiting and saving the changes.


Anyway, many thanks for your help! If my computer still randomly does not go to the OS, I will try your suggestions 5 to 9.


Actually, I have a dual boot system on my computer, Win10 and Ubuntu 18.04 LTS. I do not think however that my problems have anything to do with the dual boot as they occur before any access to the NVMe disk takes place.