Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AWang30
Beginner
2,049 Views

Fail to restart stream with D410/RealSense SDK for Android on Intel UP board

Hi, I setup D410 module on UP board with WIN10 and Android board.

On WIN10, the tool RealSense Viewer can on/off the camera stream without problem.

But with Android SDK running on UP Board, the camera get issue after the stopStreaming function been executed from streaming mode.

Test procedure:

1. connect D410 on UP board USB3.0 interface, run Android test AP.

2. execute startStreaming, check stream out is correct.

3. execute stopStreaming. Re-execute startStreaming, or restart test AP, won't get the same result as step 2.

4. D410 usb will be unmount from UP board USB bus. Have to replug the D410 module in order to let the test AP work again.

Anyone get similar issue? Thanks for any advice.

Regard,

Angus

0 Kudos
7 Replies
PSnip
New Contributor II
146 Views

Hi Angus,

This seem to be a known issue. I too have similar problem.

The issue was reported on git librealsense. As per Intel, this issue will be fixed in future firmware release, but no ETA.

Regards,

PS

AWang30
Beginner
146 Views

Hi,

Thanks for your information, I try to search issues on GIT, do you mean issue # 1164(https://github.com/IntelRealSense/librealsense/issues/1164 D415 loses IR stream on restart... · Issue # 1164 · IntelRealSense/librealsense · GitHub,

Regards,

Angus

MartyG
Honored Contributor III
146 Views

The issue I quoted is listed as "Realsense Viewer is not streaming after wake up from sleep mode (DSO-8094)"

MartyG
Honored Contributor III
146 Views

I apologize if I am of limited help in this case. Yours is only the second case I have dealt with in running SDK 2.0 on Android, though I do have experience with Android app development in general.

In that other case, the user's issues seemed to be related to the camera behaving like it was on a USB 2.0 connection instead of a USB 3.0 one (which the camera needs for full functionality).

PSnip
New Contributor II
146 Views

Hi Angus,

I too have this problem. However, there are instances where camera may just restart streaming fine.

I get similar problems under ROS, where camera requires a replug before it can stream again.

I thought it may be related to this issue https://github.com/IntelRealSense/librealsense/issues/1213 Sporadic errors, only workaround is to physically reconnect camera · Issue # 1213 · IntelRealSense/librealsense · GitHub

MartyG
Honored Contributor III
146 Views

The RealSense Viewer software currently has a Known Issue where the Viewer does not stream after waking up from sleep mode. I wonder if this is related to the problem that you are encountering.

AWang30
Beginner
146 Views

Hi Marty,

Thanks for your feedback.

Using RealSense Viewer on WIN10 won't get the same result. I can turn on/off the camera and get smooth video stream without problem.

I think issue related to the stopStreaming code on Android is not complete (compared with Realsense Viewer on WIN10).

Regards,

Angus

Reply