Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
303 Views

GRUB boot menu not shown with dual boot NUC8i7HVB

Hello,

 

I have a NUC8i7HVB version J68196-503 with bios version 0059.

 

On this I have a dual boot installation with each OS on it's own SSD.

  • Windows 10 Pro Version 2004 (10.0.19041)
  • Ubuntu 20.04

 

GRUB2 is installed and is used to choose between ubuntu and windows.

The problem is that the GRUB menu does not appear. The first screen shown is either the windows or ubuntu logon page. It's like the monitor is not switched on during the initial boot process. But the keyboard is working.

 

So if I guess the timing then I can scroll up or down to choose windows or ubuntu. I've looked through all the settings in the Intel Visual BIOS that might control this and I don't know if there is something I can change to set this. Also, there is only one boot entry in the visual BIOS so it makes no sense to step into the BIOS to choose the operating system to be loaded. There is only one entry in the BIOS, it is the ubuntu/grub entry.

 

How can I configure the system to show the boot menu so that I can see which system I am booting?

 

any help or tips would be much appreciated!

0 Kudos
10 Replies
Highlighted
Super User
246 Views

Why dual boot? Use Windows 10 Pro and run a virtual machine for ubuntu. Problem solved.

https://docs.microsoft.com/en-us/windows/wsl/install-win10

 

Doc

 

0 Kudos
Highlighted
Super User
246 Views

Enter BIOS and disable Secure Boot (Advanced > Boot > Secure Boot).

 

Leon

 

0 Kudos
Highlighted
Novice
246 Views

Hi Leon,

 

Secure Boot is already disabled. I've attached screenshots of the Secure Boot, Boot Configuration and Boot Priority screens.

 

What's new is that somehow (and I don't know how), I now have an entry for "UEFI: Build-in EFI Shell" in the UEFI Boot Priority. And if I boot into the EFI Shell then I eventually get a shell prompt. See EFI Shell screenshot. And if I press ESC on this screen it takes me to the GRUB menu.

 

I'm hoping there is a solution to this in the Visual BIOS settings. BootConfiguration.bmpSecureBoot.bmpEFI Shell.jpgBootPriority.bmp

Matthew

0 Kudos
Highlighted
Novice
246 Views

One more thing, if I hold down F2 on boot then I get to the Boot Priority screen in the BIOS. If I hold down F10 (on boot), nothing happens.

0 Kudos
Highlighted
Super User
246 Views

I'm not expert for Linux, neither for Grub. However, I guess that the new entry for "UEFI: Build-in EFI Shell" in the UEFI Boot Priority appears since you have enabled Internal UEFI Shell in Boot Configuration > Boot Devices. By default this item is disabled.

 

Leon

 

0 Kudos
Highlighted
Super User
246 Views

0 Kudos
Highlighted
Novice
246 Views

Thanks for the answer to the  "UEFI: Build-in EFI Shell". Yes I had enabled the Internal UEFI Shell in Boot Configuration > Boot Devices.

 

And thanks for sending the very good link to the ubuntu documentation on UEFI.

 

I've followed through the steps and both windows and ubuntu are using EFI.

 

The ubuntu UEFI page has a link to the boot-repair utility. https://help.ubuntu.com/community/Boot-Repair

 

I have run this twice. The first time with manually checking the advanced settings and the second time with default options.

 

With both runs the boot-repair utility result was a success.

Here are the logs:

https://paste.ubuntu.com/p/2SXN4VjqNj/

https://paste.ubuntu.com/p/HNjHNd9WP9/

 

Unfortunately this has not resolved the problem of the GRUB menu not showing on boot.

 

 

0 Kudos
Highlighted
Super User
246 Views

Again, Why dual boot? Use Windows 10 Pro and run a virtual machine for ubuntu. Problem solved. And, you will have access to both simultaneously (and at the same time)!

 

Also, Linux and Grub are not supported on your nuc. You should seek assistance from the linux community.

 

Doc

 

0 Kudos
Highlighted
Novice
246 Views

Hi Doc, your suggestion is a good one and is probably the best solution for most users, but I don't go down this route because of my learning objectives. I'm trying to get familiar with using both windows and ubuntu for development / data engineer workflows. I already have ubuntu 20.04 installed on windows 10 (using WSL2). And I don't find it a problem to run windows in a virtual machine on ubuntu. But my learning activities involve products running in containers and kubernetes clusters. Hadoop, Spark, PostgreSQL, Cassandra, etc. I initially did all my activities on windows, but I found windows slower and with higher memory utilization than working on ubuntu. You probably say, why not just use ubuntu? Well I still want to see how the things work on windows. And for some apps I still prefer windows. Well it's more a transition for me. I'm off the office apps already (excel, word etc.) but there are still windows apps without good/better linux equivalents. If I read between the lines in your question, I interpret this as saying that intel does not support dual-boot and that what I should be doing is using two computers. That may be so, but I don't think I am so far away in getting dual-boot to work on an intel nuc. It is almost working right now. GRUB actually works! It's just that the menu is not shown on the screen. Hence I give it a go to try and get in working! Maybe in vain, let's see!

Highlighted
Novice
246 Views

Hello,

 

A big thanks to everyone who responded on my questions and helped with this.

 

I've come to the conclusion that this is something that probably cannot be changed with the Intel Visual BIOS.

 

I think the problem is with my GRUB setup and my best guess is that I could have made better choices when I setup the /boot and /boot/efi partitions. Changing my existing installation looks risky and time consuming so I leave it as it is for now. I'll check my theory next time I make clean install of ubuntu!

 

As a workaround I've installed another boot manager to "front-end" GRUB. I've installed rEFInd and all seems to work good on my installation.

http://www.rodsbooks.com/refind/

 

Again, thanks for your help!