Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Theamy
Novice
119 Views

Ghost Canyon NUC 9 Extreme KIT stuck on Intel Nuc splash screen

Jump to solution

My new Ghost Canyon that has been working smoothely for a month. The Nuc now stuck on the Intel Nuc splash page with the usual options :

  • F2 to enter Setup,
  • F7 to Update BIOS,
  • F10 to Enter Boot Menu.

None of these options work. Just still locked on this screen for more than 5/6 minutes, then it starts the operating system [please see the attachment].

The Nuc works normally and starts the operating system quickly as soon as the power cable is unplugged  for a few seconds then replugged back in. [tested with the internal M2 DD and also with a bootable usb stick].

 

I also did the following tests :

  • I removed every device plugged in and no change,
  • I removed the memory one stick at a time and no change,
  • I plugged the monitor in using HDMI instead of display port and no change,
  • I tried booting to an ubuntu USB stick and am unable to boot from that,
  • Flashing old bios version “QX0052“ and no change [flash was done using the function F7, using recovery method with power button and also security jumper].

 

Here is my hardware configuration :

  • RAM : Crucial 2 x 32GB DDR4-2666 SODIMM
  • DD : Crucial MX500 M.2 SATA SSD
  • Running BIOS QX0054

Any help will be welcome.

 

Thanks!

0 Kudos

Accepted Solutions
Maria_R_Intel
Moderator
56 Views

Hello Theamy,


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.


If you will proceed with the warranty, feel free to provide this thread as a reference.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


View solution in original post

0 Kudos
4 Replies
Maria_R_Intel
Moderator
98 Views

Hello Theamy,


Thank you for posting on the Intel* Community.


With the information you provided I will proceed to check this case internally, please expect an update soon.


Best regards,

Maria R.

Intel Customer Support Technician


0 Kudos
Theamy
Novice
85 Views
Thank u Maria for your reply !

Can’t wait for having your final answer.
0 Kudos
Maria_R_Intel
Moderator
78 Views

Hello Theamy,


Thank you for patiently waiting.


We were trying to replicate this behavior in our Intel* lab, but we did not get the same results.


It seems to be a problem with the NUC's bios. In this case, our recommendation is to contact our internal support directly to verify the warranty of your unit:



Best regards,

Maria R.

Intel Customer Support Technician


0 Kudos
Maria_R_Intel
Moderator
57 Views

Hello Theamy,


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.


If you will proceed with the warranty, feel free to provide this thread as a reference.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


View solution in original post

0 Kudos