Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JamesKoziol
Beginner
1,209 Views

HD audio passthrough on NUC10i3FNK4 not working

Hello,

I appear to have a driver issue with the NUC10i3FNK unit. The HDMI port is connected to a Denon AVR-4700H receiver and LG GX OLED.

I have the latest BIOS (FNCML357) installed. The latest HDMI firmware is also installed.

Graphics driver version is: 26.20.100.8141, on windows 10 professional 2004 update. Fully up to date as far as windows update is concerned.

The issue is HDMI high resolution audio passthrough using the WASAPI protocol on windows. With the setup above, WASAPI allows for only PCM 2.0 audio and passthrough of AC3 audio only.

Directsound usage provides for 7.1 PCM audio, but is unable to bitstream anything other than AC3 and DTS (no Atmos, TrueHD or DTS-HD audio).

I have tested several software applications (VLC, Kodi, windows media player), and all are unable to bitstream any TrueHD or DTS-HD audio types over HDMI.

This is despite the windows audio control panel listing all these formats as supported by the NUC/Denon receiver interface.

Interestingly, a portable Linux installation will allow bitstreaming of these formats on this NUC. However, Linux currently does not support HDR video.

Any ideas?

0 Kudos
20 Replies
Maria_R_Intel
Moderator
1,181 Views

Hello JamesKoziol,

 

Thank you for posting on the Intel* Community Forums.

Please provide the specific version of the HDMI* firmware you're using. 

To better assist you, please run the following tool in Windows* and attach the report generated. 

  

Intel® System Support Utility (Intel® SSU) 

 

  • Intel® SSU Download
  • Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View". 
  • Click on the menu where it says "Summary" to change to "Detailed View". 
  • To save your scan, click on "Next", then "Save". 

 

Bar1ry,

 

Please, let us know if you are using the exact same configuration, if not, we encourage you to post a new thread so we will be able to assist you with the most accurate support for your system.

 

Best regards,

Maria R.

Intel Customer Support Technician

 

JamesKoziol
Beginner
1,177 Views

Of course, have attached the requested readout.

I have also attached a screenshot of the properties of  the audio device resulting from connecting the hdmi port to the denon receiver. The EDID communication appears to be working OK.

Based on forum reading, I have attempted to update the drivers again for everything, including reinstalling the intel management engine interface. Same problem occurs - no bitstreaming on HD audio formats in WASAPI API.

Bitstreaming only works for standard dolby or DTS audio. I can get that working through the WASAPI api now, but it works much more reliably through directsound.

JamesKoziol
Beginner
1,160 Views

Hmm. Was pretty sure the firmware tool reported the latest version already.
Had downloaded the version 1.77.04 firmware listed for HDMI to HDMI connections. That is already installed, but I tried reflashing anyway (after having to obtain a 32bit version of the C+ runtime library to get the flasher running).

I note there is a version 1.77.06 also on the website, but it looks to be for HDMI to DVI connections?

The Denon 4700h is a HDMI 2.1 device, but the port the NUC is plugged into is HDMI2.0b only...
Chris_V_Intel
Moderator
1,066 Views

Hi @JamesKoziol,

I'm still working on this, but a couple questions for you. 

You said your NUC6i3SYK works, is that when connected to an HDMI 2.1 port on the Denon AVR-X4700H?

You also mentioned "...the port the NUC is plugged into is HDMI2.0b only..." are you referring to the NUC10 or NUC6? And on the Denon? I downloaded the manual and I don't see anything about an HDMI 2.0x port. Of course it also doesn't say anything specific about HDMI 2.1 either. 

Basically does the NUC6 work where the NUC10 doesn't, on the same port, same AVR?

You also mentioned you tested Linux. Which version of Linux did you try? And did it play all formats? If so, did it play them out of the box or did you have to do any setup?

Lastly, have you tried a Type C to HDMI connection? Just to see if the surrond sound features work?

We've been told that HDMI 2.1 should be backwards compatible-it would be silly if not-so we're trying to narrow down where the issue lies.

Thanks!

JamesKoziol
Beginner
1,044 Views

Hi @Chris_V_Intel 

The NUC6i3SYK worked perfectly bitstreaming all DTS/Dolby high resolution audio formats when connected to any of the HDMI 2.0b inputs on the Denon AVC-4700h, and also on the 8k/HDMI 2.1 input.

The NUC10i3FNK could only bitstream vanilla AC3 or DTS (not HD audio) and PCM2.0 sound. AC3 and DTS would work with Directsound and WASAPI. PCM2.0 would work with Directsound only. PCM 7.1 would occasionally work with Directsound, but not reliably. This is whether it was connected to a HDMI 2.0b input or the single HDMI 2.1 port on the Denon AVC-4700h. The system was running latest build of Windows 10 64bit, latest drivers as per Intel website, latest HDMI firmware. I tried various players - built in Windows media players, Kodi (stable and latest alpha), VLC. All unable to bitstream HD audio, despite the Windows Audio Control panel EDID information listing the connection to the Denon as supporting these formats. I did note in Debug mode in Kodi, the logs showing significant lag when the unit was trying to bitstream the HD audio format. Playback of the video occurred, but would eventually crash. The amp reported no audio signal present. The video playback would occur without glitch when I had Kodi software decode and downmix the audio output to PCM2.0

I should confirm - the newest Denon amps have only 3 ports fully HDMI 2.1 compliant at 40Gbps - two of the monitor out ports and one single input labelled "8k." The rest of the input ports are technically only at 2.0b level with 18Gbps bandwidth. However, this should not be a limitation to HD audio bitstreaming, only for 4k HDR video content at >60fps, or 8k content (or, variable refresh rates).

So yes, basically the NUC6 worked perfectly in the exact same setup where the NUC10 did not (apart from having HDR output capability, which was the reason for the upgrade).

I've gone back over my testing pathway (tried to keep some records). Turns out I was mistaken about Linux - I had Linux running on the NUC6, but couldn't get a LibreELEC build running reliably on the NUC10 - was too new with the drivers. I managed to get a development build running on a bootable USB, but it crashed too much to do much testing.

Hadn't tried a USB-C connection, as limited to 10Gbps (4k video at 30fps or less). I don't currently have a converter like that, although a Thunderbolt one may be worth a try. Do you have one (if you still have a HDMI 2.1 class Denon amp to play with?)

Thanks for keeping at it. I still have the NUC10 on my workbench, but have replaced it for media player purposes with a Shield TV, which seems to be handling my use cases easily.

Chris_V_Intel
Moderator
1,032 Views

Hi @JamesKoziol 

Much appreciate the prompt reply James!

That's really interesting that the NUC 6 works. I'm going into the office on Friday, I'll try it myself. And yes, we now own a Denon AVR-X2700H, so testing is no longer an issue.

Thanks for clarifying your testing and about Linux.

Sorry, when I said Type C, I really mean Thunderbolt, but good to clarify between the two.

I don't have a Thunderbolt to HDMI adapter, but I do have a Type C to HDMI adapter that I'll test and according to DisplayPort's site: https://www.displayport.org/displayport-over-usb-c/ Type C can handle full 4K @ 60 Hz and HDR.

Chris_V_Intel_0-1602723844801.png

Glad you have something that works now, but still not giving up!  

Aviram
Beginner
903 Views

i have similar problem : 

i had the NUC5CPYH that work great with my YAMAHA receiver and passthrough TRUE-HD. while buying a new NUC : BXNUC10i5FNH is doesn't work.

i update the BIOS, and HDMI FIRMWARE, INSTALL a new clean copy of windows 10 pro 64bit and update all the newest drivers. and still... my receiver recognize only PCM
i didn't change the HDMI CABLE or the my receiver ,.. and these two work fine with the old NUC (NUC5CPYH).

help needed ...

thansk

Chris_V_Intel
Moderator
869 Views

I apologize.

I should have mentioned to any new comers that this issue is being worked on and I'm updating this thread: https://community.intel.com/t5/Intel-NUCs/NUC10i5-wont-bitstream-audio-to-brand-new-AVR-especially-D... with any new info.

Maria_R_Intel
Moderator
1,149 Views

Hello JamesKoziol,


Thank you for the information provided.


I will proceed to check this internally, I'll be contacting you as soon as I have an update.


Best regards,

Maria R.

Intel Customer Support Technician


JamesKoziol
Beginner
1,134 Views

Thank you Maria,

I had done a little searching of the forums, and it appears I'm having exactly the same issues as are cropping up in this post: https://community.intel.com/t5/Intel-NUCs/NUC10i5-wont-bitstream-audio-to-brand-new-AVR-especially-D...

There seems to be some incompatibility with denon HDMI 2.1 receivers and the 10th generation NUCs.

However, the denon 4700h I have worked flawlessly for bitstreamed audio using the same cables and setup but with a 6th generation NUC (NUC6i3SYK).

Have changed to the 10th generation so I can get HDR output over HDMI

AlHill
Super User
1,119 Views

Nice try, @Bar1ry .  You are a spammer

 

powwow
Beginner
729 Views

Hi James. 

Have you found a solution yet? I have exact same problem with my Denon AVC X3700H receiver and Intel NUC8 series. Dolby Digital, DTS and Atmos (DD+) are all fine but no lossless audio! I've lost whole weekend trying to figure out the problem. Super frustrating! Too many issues with the 2021 Denon receivers, I'll be sending the unit back.

P.S. I have an 2012 Yamaha Aventage receiver and it just works with anything I throw at it (no Atmos)

Aviram
Beginner
720 Views

hi , 
how does the yamaha advantage works ? mine doesn't work with the nuc10i5 only with the old nuc (celleron).

he doesn't pass through DTS, DOLBY DIGITAL , ATMOS , TRUE-HD

powwow
Beginner
716 Views

@Aviram
Mine works with NUC8. All formats lossless and lossy. (No Atmos and DTSX)
Yamaha RX-A1020
miroslavvassilev
Beginner
262 Views

Hi James,

Is there a solution ot this issue already ? I am having exactly the same issue with my Onkyo PR-SC5530 - only plain Dolby digital and DTS, no TrueHD or Atmos formats are being streamed. I have NUC10i3FNK. Latest BIOS and latest HDMI firmware already installed.

Your response will be much appreciated.

miroslavvassilev
Beginner
125 Views

This is RIDICULOUS. Intel - please resolve your issues! Why are we not gettinf any answers from Intel Technical support ?!?

Chris_V_Intel
Moderator
115 Views

I apologize for never answering the other thread. We released an HDMI firmware that fixed this.

 

Make sure to use the latest version: https://www.intel.com/content/www/us/en/download/19639/29779/hdmi-firmware-update-tool-for-nuc10i3fn... 

miroslavvassilev
Beginner
100 Views

But the firmware is only for NUCs with 10th gen Intel CPUs. I have this issue on a 11th gen i7 NUC.

Is there a firmware update for it and if yes - van you provide the download link?

Chris_V_Intel
Moderator
91 Views

Sorry, but this is on the thread for the 10th Gen NUC.

 

We are almost ready to release a fix for the 11th Gen NUCs, which 11th Gen NUC do you have?

n_scott_pearson
Super User Retired Employee
84 Views

@miroslavvassilev,

Why are you on this thread at all? Especially making specious demands for something not having anything to do with you. You should be opening a separate conversation of your own for your 11th gen issues.

...S

Reply