Showing results for 
Search instead for 
Did you mean: 
New Contributor III

HDMI Audio device missing after NUC7 sleep

I posted earlier in a thread that I had it fixed but I spoke to soon. This is what I have found.

Windows 10 Pro insider build 17686, same behavior seen in Build 1803.

If I put the NUC to sleep Manually using the sleep option on the windows power menu and wait till everything is down.

Using the power button(or space bar) on my Logitech keyboard to wake the computer after a minute or so everything comes up normal.

SHARP HDMI(Intel(R)Display Audio) showing.

If I on the other hand let the NUC fall asleep on it's own the SHARP HDMI(intel(R)Display Audio) is missing on wake up.....

A Reboot of the NUC brings back the HDMI Device again.

0 Kudos
6 Replies
Super User Retired Employee

Try disabling Monitor Sleep in Windows and see if this helps.


New Contributor III

Well, Ill be........

That seems to have done the Trick.

I set display to Never sleep in power option and pc sleep to one minute for testing(reverted back to 10 for the PC now)

PC goes to sleep and both screens go off TV says HDMI 1 No signal.

Wake up with Keyboard power button, both displays come on and SHARP HDMI is showing as speaker.

Let the PC fall asleep again and power off TV

Wake up PC and it comes up with my USB speaker as Audio device.

Turn on TV and audio automatically switches to SHARP HDMI..

I will update in a day or two I think this is the fix, but I thought I had it sorted before

This must be a (BIOS?)Bug since you should be able to have the monitor go to sleep at say 10 minutes and the PC after 30.

Thank you very Much for this tip.

Super User Retired Employee

No, not a BIOS bug; its a HD Graphics driver bug - and, sad to say, it has been around for 5 NUC generations now. In my case, doing a lot of NUC and Compute Stick testing, I have multiple 4-port DVI and 1080p & 4K HDMI KVMs to connect them all and this bug reared its head regularly. I solved (well, hid) the problem with this setting change. When I recently put together a 4K home theatre system with NUC attached, I found that this setting was again necessary. I am still fighting an audio loss issue, however.


New Contributor III

I think I found the culprit(he said hopefully)

My NUC-NUC7i5BNHXF has 16GB Optane and a one TB HDD.

Having set up as you suggested and tested and it seemed to work, Screen NEVER sleep and PC sleep after 5 Minutes of inactivity.

I was on the PC till Lunch and when I came back from Lunch waking up the PC the audio was Missing again.......

I realized that the only thing different from when I was testing was the duration of sleep state.

My HDD was set to sleep after 20 minutes(my Lunch was longer then that)

I tried to set HDD sleep to NEVER but for some reason that becomes 0 minutes when applied.

Now I have set HDD to sleep after 1440 minutes(24hours)and so far everything seems to work fine.

I let the PC fall asleep by doing nothing.

Wake up PC with TV on, it comes up with HDMI speaker selected

Wake up PC with TV off, it comes up with USB speaker selected

Turn on TV and it automatically switches to HDMI speakers

I'm not sure what happens with the disk when the PC sleeps but if it keeps spinning so be it......

I still have the monitor set to never sleep might test later if it's necessary mind you the monitor still goes to sleep with the PC.

I figure 24 hours should be enough on the HDD.........

New Contributor III

Wrong Again......

I decided to test with an extended sleep time of about 10 minutes and there it was again all audio devices missing on wakeup...

No more sleep for my NUC.

New Contributor III

Never Ever Give UP

I thought I'll have one more Go.

I uninstalled Realtek High Definition Audio. Disabled 2381 Intel Display Audio

I now have SHARP TV on HDMI Set as Default Audio Device and a small USB Soundbar on a generic audio driver. Microphone is Logitech Webcam.

Skype has been set to use Webcam mic. and USB audio device without any problem.

Display Sleep NEVER

PC Sleep after 5 Minutes

HDD Sleep after 24 Hours(1440Minutes)

I let the computer go to sleep by itself and let it sleep for more than 10 minutes(would loose my audio devices on wake up before)

TV Turned OFF

Wake up PC using keyboard power button, click mouse on wake-up screen pc switches to Log in screen.

Enter PIN, PC wakes up and USB speaker enabled and working

Turn on TV and HDMI AUDIO becomes enabled (already set as default device)

Looks promising.