Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DPete11
Beginner
2,143 Views

HDMI DRM Audio not playing

I have a new NUC7I5BNH, new LG OLED65C8 TV, brand new HDMI cable, clean install of Windows 10 Pro with all the latest updates and Intel drivers.

Whenever I play purchased movies and TV, I don't get any audio. When playing normal unprotected content, it works fine. I'm assuming it has something to do with DRM but not sure where to diagnose.

I've attached DXDIAG and System Support Utility logs.

Any ideas?

Thanks,

Dave

0 Kudos
15 Replies
n_scott_pearson
Super User Retired Employee
148 Views

DRM support is partially implemented within the security features running on the Intel Management Engine (ME), so you need to make sure that you have the ME software package installed. This usually happens automatically with Windows 10, but you should download and install the package from the Intel Download Center manually to be sure. Before installing this package, you should download and install the latest Chipset software package as well.

Hope this helps,

...S

DPete11
Beginner
148 Views

Thanks Scott. I checked and both the Chipset and Management Engine were already installed. I manually downloaded both, installed the Chipset first then the ME. Rebooted between both but still the same problem.

Dave

n_scott_pearson
Super User Retired Employee
148 Views

Hhmmm, is Intel HD Audio appearing and selected as the default in the Playback mixer?

DPete11
Beginner
148 Views

My playback device is LG TV Intel Display Audio. Unprotected content works fine for audio and video but only video with DRM content.

Netflix doesn't play audio, only video

Windows 10 Movies & TV purchased content is also video only

Windows 10 Movies & TV local MP4 video works fine for both audio & video.

Really strange.

Dave

DPete11
Beginner
148 Views

Further tests on my LG OLED65C8PUA:

1. Netflix Windows 10 App = No Audio

2. Netflix via Edge Browser = Audio Plays

3. Windows 10 Film & TV DRM Content = No Audio

4. Any non DRM content on any app - Audio Plays

Also... plugged the NUC into a Samsung 55" HD (not 4K)

1. All content, DRM or not plays fine.

When I look at my Playback devices, there are bars to show the level of audio going through. When playing DRM content, it doesn't show any volume. Non DRM content shows volume.

Is there some incompatibility with 4K, Windows 10 and DRM?

I had my brother try his MacBook to the TV and it plays 4K Audio just fine with DRM content from iTunes.

Dave

n_scott_pearson
Super User Retired Employee
148 Views

I have no further things to suggest; Intel Customer Support (intel_corp) will need to handle this subsequently...

...S

idata
Community Manager
148 Views

Hello DavidPet86,

 

 

I would like to investigate this issue further. Could you please attach a picture of the Playback mixer?

 

 

Also, please try installing the Intel® PROSet/Wireless Software and Drivers for Windows® 10 and let me know how it goes:

 

https://downloadcenter.intel.com/download/27750/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo...

 

 

Wanner G.
DPete11
Beginner
148 Views

Hi Wanner,

I've attached a few pictures for your reference. There are two "VolumeMixer" pictures. The VolumeMixer.PNG shows the snapshot when playing a DRM video and you can see there are no green bars. The VolumeMixerGood.png shows a non-DRM MP4 file where the sound is playing correctly and there are green bars showing sound going out the port.

I'm using a wired gigabit ethernet connect so not sure why I'd need the wireless software reinstalled. The SSU output is at the top of this thread as well.

Thanks,

Dave

idata
Community Manager
148 Views

Hello DavidPet86,

 

 

Thank you for your response.

 

 

Please follow these steps below.

 

 

1. Disconnect your unit from the internet.

 

2.Please uninstall both the Intel Graphics driver and the Intel Display audio driver. To do this, please follow the steps on the link below under these sections:

 

-Uninstalling the Intel Graphics Driver via the Device Manager Method

 

-Uninstalling the Intel® Display Audio Driver or the Intel® HDMI Audio Driver via the Device Manager Method.

 

https://www.intel.com/content/www/us/en/support/articles/000005598/graphics-drivers.html

 

 

3.Restart your Intel® NUC. Please go to the device manager and check if Windows installs another version of the graphics driver. If it does, please remove it and restart your computer one more time. Repeat the process until you get the Microsoft Basic Display Adapter.

 

4.Once you do, please proceed with the clean install of the latest graphics driver version.

 

https://downloadcenter.intel.com/download/27680/Graphics-Intel-Graphics-Driver-for-Windows-10?produc...

 

5.Once the latest driver has been installed, you may enable the internet connection again.

 

 

Make sure you are using a straight-through connection (HDMI-to-HDMI) with a single cable.

 

 

Please let me know how it goes.

 

 

Wanner G.
DPete11
Beginner
148 Views

Updated, same problem unfortunately.

I've attached screen captures of the Device Manager versions for both the display and audio adapters

Thanks,

 

Dave
idata
Community Manager
148 Views

Hello DavidPet86,

 

 

Thank you for your response.

 

 

Because you are able to play protected content when using a brower, the issue may not be related to the driver itself. To continue gathering information about this issue, I would like to reinstall the applications that you are using to play media. Make sure that you have the latest version available.

 

 

If possible, try different cables and/or display. In the meantime, I will continue doing research to know if there is something else we can do on our end to fix this issue.

 

 

Wanner G.
DPete11
Beginner
148 Views

Hi Wanner,

Tried multiple cables, same issue. I did find out more though.

I can recreate the problem across the Intel NUC, Surface Book (Intel Audio) and Dell Zino (AMD Audio). I plug any of those three into my old 1080p 55" TV, everything works great so it led me to being the TV itself. I went back to the store where I bought the TV and plugged the Surface book with the same behavior into the same TV model and it also did the same thing. I plugged the same laptop into a different 4K TV (Samsung instead of LG), it worked fine.

 

So we believe it's the firmware in the LG Tv causing the problem. I'm working through the LG support channels trying to find the right person.

In the meantime, I'm wondering if there is any logging I can enable to see if HDCP or other type of handshaking is not working right on the computer to help narrow down where the problem is so I can give feedback to LG?

Thanks for the help and patience.

Dave

idata
Community Manager
148 Views

Hello DavidPet86,

 

 

Thank you for the information provided regarding a possible firmware update required for your TV. Please keep me updated if you get additional information from the LG support Team.

 

 

Also, please allow me to do further research about the HDCP logging.

 

 

Wanner G.
idata
Community Manager
148 Views

Hello DavidPet86,

 

 

Were you able to get additional information from the LG support team about the firmware update for your TV?

 

 

Wanner G.
DPete11
Beginner
148 Views

Hi Wanner,

I talked to the LG rep who got in contact with their support team. Apparently it's an issue with Silverlight in the TV and they are hoping to fix it in their next software update. I didn't know Silverlight could be in a TV its so old!

Dave