Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PA-NUC-User
Novice
647 Views

HDMI screen goes off / on after waking from sleep

System wakes normally from sleep when I press the power button, but after waking, the HDMI screen cycles off/on at varying intervals, roughly 5 seconds on and 2 seconds off. New 8i7BEH, Acer CB281HK 3840x2160 59Hz, various HDMI cables tested. I've disabled sleep, but that's not the optimum solution.

 

I've studied this forum and verified default BIOS settings - "Auto Turn On TV"="From S3/S4/S5 Boot" and "Fast Boot" disabled.

 

HDMI firmware updated to 1.77. Graphics Driver updated to 6912. System report attached. "Your Intel software is up to date."

 

Any suggestions? Thank you very much.

0 Kudos
21 Replies
AlHill
Super User
257 Views

I just setup a NUC8i7BEH, and I have not experienced this issue.

 

Doc

 

n_scott_pearson
Super User Retired Employee
257 Views

This is the typical thing you see if the monitor and NUC are having a tough time communicating at the current settings. This is typically the result of poor quality cables.

 

My rules: (1) You get what you pay for. (2) If the cable came with a monitor, it is undoubtedly crap; trash it immediately. (3) Purchase only cables certified for HDMI 2.0b (i.e. 4K@60Hz with HDR10 support) or better.

 

Hope this helps. Lots of people have complained about seeing this issue. I have used literally every NUC model available and I have not seen this problem.

...S

PA-NUC-User
Novice
257 Views

Cable is a new Monoprice 24184: "Ultra Slim Certified Premium High Speed HDMI Cable, 4K@60Hz, HDR, 18Gbps, 36AWG, YCbCr 4:4:4, 3ft, Black"

 

"Monoprice's Certified Premium High Speed HDMI® Cable is designed to meet and exceed the highest standards of HDMI performance. Capable of delivering 18Gbps bandwidth, these are the only cables to be tested and certified by HDMI Authorized Test Centers to ensure they support all features in the latest HDMI specification. Guaranteed to work with all modern 4K equipment, the Certified Premium High Speed HDMI Cable is the perfect choice for all your 4K and High Speed HDMI display needs.

 

  • Premium Certified: These Certified Premium High Speed HDMI® Cables are the only HDMI cables to be tested and certified by HDMI Authorized Test Centers to ensure they support all features in the latest HDMI specification.
  • Comprehensive Testing: Each cable length has been individually tested and certified to deliver the full 18Gbps bandwidth with a high level of EMI resistance.
  • Dual Video Stream: This High Speed HDMI Cable supports the simultaneous delivery of dual video streams to a single display screen. This enables use of the Multi View feature found on newer LG® and Samsung® televisions, so you can watch football while the kids play video games on the same display.

 

Certified by HDMI® Authorized Test Centers

  • Each individual length of these cables has been tested to ensure that it is capable of delivering the full 6.0Gbps/channel (18Gbps total) bandwidth required by the latest HDMI specification.
  • Once the cable has passed the rigorous testing procedure, HDMI Licensing issues a Premium Certified Cable label, which includes a hologram and 2D barcode, so you can trust that the cable will deliver the highest level of HDMI performance.

And...

  • Supports all HDMI® resolutions up to 4K (3840x2160p @60Hz), including 3D and Multi View video
  • Supports the 21:9 cinema aspect ratio
  • Supports up to 32 audio channels and a 1536 kHz audio sampling rate
  • Simultaneous delivery of dual video streams to multiple users on the same screen
  • Supports SA-CD, DVD-Audio, DTS-HD Master Audio™, Dolby TrueHD™, and other high-definition audio standards
  • Supports Deep Color, up to 16-bits per channel, including Sony's x.v.Color™ standard
  • Supports extended CEC (Consumer Electronics Control) commands and functions, the HDMI Ethernet Channel, and the Audio Return Channel features
n_scott_pearson
Super User Retired Employee
257 Views

And?

 

PA-NUC-User
Novice
257 Views

This is the cable I've been using all along. I tried two others briefly and had the same result.

Do you think a better cable will solve the problem? Can you suggest a specific model?

PeterNUC
New Contributor I
257 Views

Have you tried another monitor/TV?

n_scott_pearson
Super User Retired Employee
257 Views

No, it sounds like you have what should be a good cable. Do you have a second one of similar quality you can try (just in case)?

 

Now,

 

 

 

If you would like to try this (much) newer version, feel free to do so. I am running it on my BE NUC and it is working just fine.

 

Hope this helps,

...S

AndrewG_Intel
Moderator
257 Views

Hello PA-NUC-User,

 

Thank you for posting on the Intel® communities.

 

We would like to know if you were able to test the recommendations provided by n.scott.pearson.

If you need further assistance, please let us know.

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

PA-NUC-User
Novice
257 Views

Thank you very much for the follow-up.

 

7463 made no difference. Cable swaps made no difference (other cable is an UNO UN-HDMI65, marked "4K 60Hz").

 

I switched to a USB-C/DisplayPort cable (my screen has HDMI/DP/DVI-D) and things now work fine - but eventually I'd like to free up the USB-C port.

 

To be clear - with HDMI, everything was great after a system boot. The off/on phenomenon happened only after the system went to sleep and then was awakened.

 

There is still one small glitch which happened with HDMI, too: after sleep, open desktop windows shrink (to 1024x768?) and snap to the top left corner. This suggested a problem with display detection... But Settings > Display > Advanced shows the correct make/model. And one of my first troubleshooting steps was to install the latest files from Acer (CB281HK.inf and .icm timestamp 2015-09-02 07:56).

 

Thank you again for looking into this.

AndrewG_Intel
Moderator
257 Views

Hello PA-NUC-User,

 

Thank you for your response and to let us know the issue is not present when using USB-C/DisplayPort™.

I would like to recommend trying these steps:

 

1- ​​​​​​If the issue occurred after any recent software, Operating System update, have you try to undo this (for instance going back to a previous Windows® restore point?)

 

2- Have you checked different Power Options on Power Options/Plan settings on Control Panel?

 

3- Does the issue happen if you lower the refresh rate on Display Settings (for instance, keeping the same resolution but using a refresh rate of 30-24Hz)

 

4- I understand you installed firmware for the display, have you checked the Power Settings/Eco Mode or similar on the display (if applicable).

 

5- Load defaults settings in the NUC's BIOS:

a- Press F2 during boot to enter BIOS Setup.

b- Press F9 to set defaults.

c- Press F10 to save and exit BIOS.

 

6- If loading defaults BIOS does not help, check the power sleep states on the NUC.

Go to the BIOS and check the following settings:

 

a- Advanced > Devices > Onboard Devices > Auto Turn On TV> Select "From S3/S4/S5 Boot" 

b- Advance > Power > Secondary Power Settings (Right Section) > Deep S4/S5 > Select Disabled

c- Advance > Power > Secondary Power Settings (Right Section) > USB S4/S5 Power > Enabled

d- Advance > Power > Secondary Power Settings (Right Section) > Wake on USB from S5 > Enabled.

 

For more information regarding Intel NUC's BIOS settings, please refer to BIOS Settings Glossary for Intel® NUC

 

7- Check correct voltage memory: Use the correct voltage memory modules for the Intel NUC. The memory specification for the Intel® NUC Kit NUC8i7BEH is DDR4-2400MHz 1.2V.

 

8- Just to discard any interference, did you test the NUC with minimal configuration by removing all non-necessary components?

 

9- Could you please try a BIOS recovery. First, try the Power Button Menu method, if it does not work, you may try the Security Jumper method.

 NOTE: Remove the internal SSD and all external components like USB HDDs, adapters, etc. before trying the BIOS recovery.

BIOS Recovery Update Instructions for Intel® NUC

Hope this helps.

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

PA-NUC-User
Novice
257 Views

Thanks again... I want to note again that the system runs perfectly after booting. The problem appears only after sleep.

 

After the steps you suggested (BIOS to defaults, then disable Deep S4/S5, enable USB S4/S5 Power, enable Wake on USB from S5) the problem remained at 59Hz.

 

I purchased this NUC preconfigured and haven't opened the box - 16GB 2667 MHz DRAM, 1TB NVMe, and Win 10 Pro were installed by the vendor.

 

Running at 30Hz seems to fix things. Not ideal, but acceptable, and I will leave things this way.

 

Thanks again.

PA-NUC-User
Novice
257 Views

I think this issue should be closed. I'll hope for a full solution in the future.

If I configure the screeen for 50Hz, all is OK. At 59Hz, it blinks and eventually shuts down.

There is evidently a difference in how the HDMI port is initiallly configured vs after sleep. Perhaps that will be corrected sometime.

Thanks everyone for your patient help.

MRoss5200
New Contributor III
257 Views

Have you changed the refresh rate to 60Hz? May be the monitor does not handle 59Hz very well? Also, try running at 1080p instead. I have never had this issue on a 1080p monitor.

PA-NUC-User
Novice
257 Views

To summarize:

My machine works great at 3840x2160 50Hz, 59Hz or 60Hz after booting or when I set a new display mode.

But when the machine wakes from sleep with the display set to 59Hz or 60Hz, it blinks off and on and eventually shuts down. This does not happen at 50Hz.

 

Apparently there is different display adapter/port setup for startup or display mode assertion than for waking from sleep, and problems occur when waking from sleep.

Ronny_G_Intel
Moderator
257 Views

Hi everyone,

 

Can you please try the following driver that was recently posted to the Intel Download Center: https://downloadcenter.intel.com/download/29230/Intel-Graphics-Windows-10-DCH-Drivers-for-Intel-NUC?... ?

 

This driver is supposed to address different issues including the display not to wake from sleep in some situations.

Please report back your results.

 

Regards,

Ronny G

PA-NUC-User
Novice
257 Views

Thanks very much for the follow-up! I happened to see last night that 7529 was posted. I installed it immediately, but it doesn't fix this problem.

 

As before: I can set the display mode to 59Hz or 60Hz and the display works OK after the mode change and after rebooting. But when it wakes from sleep, the monitor cycles on - off - on- off -- as if it's set to an unsupported mode.

 

I mentioned before that after waking, open windows are shrunk and moved to the top left quarter of the screen. I wonder if perhaps there was a problem with monitor detection which causes an invalid display mode to be recorded and asserted on wake-up?

 

Anyway I'm OK with running at 50Hz and moving windows around - but I'll also do whatever I can to help fix this.

Ronny_G_Intel
Moderator
257 Views

I am concerned about you having to run the monitor at 50Hz. It is not a big deal but the refresh rate is the number of times the monitor updates with new images each second, 50 Hz refresh rate means 50 times per second, if you were able to keep it at 59Hz (like my set up) it will result in a smoother picture.

 

I believe the driver alone is not causing the issue, it could be some sort of compatibility issue between the NUC/driver and monitor and if this is the case then it will be very difficult to resolve.

 

Have you tried a different monitor brand/model by any chance? Have you replaced the NUC already? Would you be willing to call our Technical Support Service so that we can explore other options? Here is the contact us information: https://www.intel.com/content/www/us/en/support/contact-support.html#@6 please make sure that select your region and when speaking to our representatives make reference to case 4420952.

 

On the other side, the Windows shrinking issue after resuming from sleep. This situation occurs due to an Operating System design. The OS is not storing and persisting the window size and placement upon the disconnection of some display devices.

 

We cannot promise that this is going to get fixed. Here is a community with more information: https://communities.intel.com/thread/102871 where we will be posting updates if they become available.

Other customers believe to have found a solution: http://rcaloca.blogspot.com/2014/12/windows-changing-size-position-after.html (keep in mind that this link is provided only for convenience and we do not endorse or recommend any steps listed there and it is customer's own responsibility to follow through with it).

 

I hope this helps,

Ronny G

PA-NUC-User
Novice
257 Views

Thanks again for the kind assistance - I am very grateful. It all works fine with a USB-C-DisplayPort cable. If I need to free up the USB-C port, I'll look into replacing the screen. I'm OK with leaving things like that.

Ronny_G_Intel
Moderator
257 Views

We are here to help!

Feel free to contact us back if you need anything

mmr001
Novice
110 Views

I am also facing this issue on intel nuc8i3beh with latest graphics drivers from intel. This problem where the screen keeps going on and off intermittenly does not always occur every time but occurs randomly, when the nuc tries to wake the monitor up eg when the monitor turns off at the lock screen due to console timeout and wakes up when I mouse the mouse. The issue would only temporarily go away by restarting the nuc or by turning the monitor off and then turning back on again. Would also appreciate if intel would release a fix for this problem.

Reply