Community
cancel
Showing results for 
Search instead for 
Did you mean: 
gsull1
Beginner
1,810 Views

How do I set up an IR device to wake my NUC?

The title pretty much says it all. I can get my Inteset 422-3 to control my Media Portal software but I have no clue how to get it to wake the computer or control it in any way.

0 Kudos
8 Replies
idata
Community Manager
341 Views

Hi Eightwt,

 

 

Thank you for bringing this to my attention, let me help you on this matter.

 

 

You first need to check if the infrared port is enabled at BIOS level. On Intel® NUC you will see after accessing the BIOS by pressing F2 while powering on, Advanced, Devices, Onboard devices, Enhanced Consumer IR.

 

 

Additionally, you need to have the IR driver installed. It will be important to have your current Intel® NUC model number, please run the following tool to https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- identify the Intel® NUC model and attach the results.

 

 

Thank you for your time.

 

Allan J.
idata
Community Manager
341 Views

Hi Eightwt,

 

 

I was wondering if you were able to run the utility to identify the Intel® NUC.

 

 

Thank you for your time.

 

Allan J.

gsull1
Beginner
341 Views

Yes, I ran the tool. Attached is the output. NUC model is NUC5PPB.

idata
Community Manager
341 Views

Hi Eightwt,

 

 

Thank you for the information.

 

 

Please check the following BIOS settings
  • Enhanced Consumer IR checked
  • S3 and S4/S5 set to allow wake on CIR
  • Power set to Max Performance
Update the following drivers: Additionally, see the list of tested peripherals for the http://compatibleproducts.intel.com/ProductDetails/ExportPeripheralInfo?moduleName=Intel%C2%AE%20NUC... Intel® NUC, there you can find Remote Controls that were tested and fully functional.

 

 

Regards,

 

 

Allan J.
gsull1
Beginner
341 Views

The BIOS settings were as you suggested.

I upgraded the BIOS.

I attempted to install the IR driver and got this:

There is a mistake when installing the driver:0x80070103

Aborts this installation.

Please reboot and try again.

I believe the driver was already installed as I found it in the Device Manager. I guess that was what the "mistake" was.

There is no device compatability list for my NUC at the link you gave me.

I would think that just pointing my IR remote at the computer and touching the ON button should bring the NUC out of sleep mode, but that's not happening. If there is a code to enter in the remote to make this happen, I don't have a clue how to obtain it.

n_scott_pearson
Super User Retired Employee
341 Views

I believe it has to be the sleep button that you hit...

...S

gsull1
Beginner
341 Views

I don't think my remote HAS a SLEEP button. Any other suggestions??

Mitchell_R_Intel
Employee
341 Views

What OS are you using? If you are using Windows 10, go to the "Power Options" control panel. On the left side, select "Choose what the power button does". Under "Power Button Settings" change it to Sleep.

Now when the system is ON, when you press the Power Button on the NUC or your remote it should put the system to sleep.