Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DZhan20
Beginner
934 Views

How to configure BIOS to PXE boot using only IPV4?

 
0 Kudos
7 Replies
David_V_Intel
Employee
327 Views

Hello DZhan20, Thank you for posting on the Intel ® communities. I will need more information of the situation, in this case, I can see that you have not provided me with the model of the Intel ® NUC. Also, I would like to know if you want to PXE boot strictly with IPv4. Let me know please. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation
DZhan20
Beginner
327 Views

Hi David,      Thank you for your reply. I have NUC5i5RYK and NUC5i3RYK. I updated the BIOS recently. The PXE boot try IPV6 first, and then IPV4, each takes a long time. To strictly use IPV4 at least saves half of the time. Also IPV6 is not being used in my environment.      I configured to boot disk, ipv4 and ipv6, and in that order from top down for UEFI. It doesn't seem I can take ipv6 away from the list. The PXE boot and the OS installation turned out successful. Dalton
David_V_Intel
Employee
327 Views

Hello DZhan20, Thank you for your response. I am glad to know that the OS installation was successful, IPv6 has a higher priority and always stays in the boot order before IPv4; however, as a workaround, you can uncheck/disable “Boot network Devices Last” in the BIOS and then set the Boot Order for IPv4 and IPv6. Let me know if you need further help. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation
DZhan20
Beginner
327 Views

Hi David,      Thank you for your reply. I unchecked "Boot network Devices Last". Tried first ipv4 higher in the list, and then ipv6 higher in the last, each time the system boot ipv6 first. Dalton
David_V_Intel
Employee
327 Views

Hello DZhan20, Thank you for your response. This is the expected behavior due to IPv6 having a higher priority, that is why it always goes before IPv4 in the boot order. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation
DZhan20
Beginner
327 Views

David,       Did I already perform your work around, or "uncheck" and "disable" are not the same thing (for Boot network Devices Last)? Dalton
David_V_Intel
Employee
327 Views

Hello DZhan20, Thank you for your response. My apologies but I do not understand, are you asking if "uncheck" and "disable" for boot network last is the same thing? As a workaround you can try both and see which works for you; however, keep in mind that as mentioned above, the system decides to go with IPv6 first because it has higher priority and it is expected. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation
Reply