Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FSydn
New Contributor I
705 Views

How to downgrade BIOS firmware version from BNKBL357.86A.0079 to BNKBL357.86A.0070 on Intel® NUC Board NUC7i7BNB ? I know it is mentioned in the release notes that this is not possible but this is a show stopper for us so I need some way to do it.

Jump to solution

Hi,

We are using Intel® NUC Board NUC7i7BNB and were previously running BIOS BNKBL357.86A.0070 version and everything was working fine.

 

But after installing the BN0079 version, the BIOS does not detect our Boot-able USB drives anymore and thus we are unable to install our Operating System. The USB drive has our custom ISO image built using genisoimage command on CentOS Operating System.

 

So please let me know how to downgrade BIOS firmware version from BNKBL357.86A.0079 back to BNKBL357.86A.0070 ?

 

Regards,

FST Sydney

0 Kudos
1 Solution
FSydn
New Contributor I
268 Views

Thanks for your response , but I didn't need to downgrade after all.

On subsequent checks, I realised that the original issue of not able to detect the custom Boot-able USB drives was due to the 'Optical Boot' option being turned off. After enabling it my boot image was detected and I could proceed with the installation.

 

But I am not sure why this Optical Boot option under Boot Configuration was needed to be On to detect a boot-image on a USB Drive. Anyways my problem is solved now.

View solution in original post

5 Replies
LeonWaksman
Super User
268 Views

Hi,

I don't know if it will work, however you may try the iFlash method: https://www.intel.com/content/www/us/en/support/articles/000006640/mini-pcs.html .

Prepare USB bootable stick with UEFI boot.

 

Leon

 

FSydn
New Contributor I
269 Views

Thanks for your response , but I didn't need to downgrade after all.

On subsequent checks, I realised that the original issue of not able to detect the custom Boot-able USB drives was due to the 'Optical Boot' option being turned off. After enabling it my boot image was detected and I could proceed with the installation.

 

But I am not sure why this Optical Boot option under Boot Configuration was needed to be On to detect a boot-image on a USB Drive. Anyways my problem is solved now.

View solution in original post

Wanner_G_Intel
Moderator
268 Views

Hello FSydn,

 

Thank you for posting on this Intel Community.

 

As you were saying, it is not possible to downgrade the BIOS version 0072 or earlier.

 

Have you tried installing the latest BIOS firmware version 0080?

 

After updating the BIOS firmware:

 

1. Press F2 during boot to enter BIOS Setup.

2. Press F9 to set defaults.

3. Press F10 to save and exit BIOS.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

FSydn
New Contributor I
268 Views

As explained in the previous reply, my problem is resolved now. The Optical Boot option had to be turned On.

Wanner_G_Intel
Moderator
268 Views

Hello FSydn,

 

Thank you for providing us with the resolution to this issue. We are glad to hear that the problem was fixed.

 

We will close this inquiry. If you need further assistance, please post a new question.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

Reply