Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
342 Views

How to fix BIOS 0079 and graphics driver 7985 update issues

Lots of people here having the same issues with BIOS and graphics drivers updates and nobody has posted resolutions which are readily available from other sources, so please allow me. (I hope this post doesn't get removed by admins. If it does, I tried...and shame on you Intel since this is supposed to be a support community where we help each other out.)

 

BIOS 0079 does not install because the "secure boot" option is enabled in BIOS which prevents the installer from running. Please note these instructions are purposely somewhat vague. If you don't understand them you definitely shouldn't be messing about in your BIOS!

 

Put the new BIOS image on a USB flash drive and plug it in to the NUC. Use the Windows Recovery/Advanced startup option to boot into UEFI BIOS and disable the "secure boot" option. When boot options appear in lower right corner press F7 to update BIOS. Select the BIOS file on the USB device and confirm. When BIOS update completes and unit powers down, remove the USB device. At next boot press F2 to enter BIOS setup and re-enable secure boot. NUC should restart and boot to Windows. Check device manager to confirm BIOS version.

 

I my case it tried to boot Windows before I could re-enable the secure boot option and I ended up in bitlocker recovery. I pressed and held power to shut unit down and was able to use F2 at the next boot to enable it after which my unit started Windows normally.

 

Again, if you're not 100% comfortable with BIOS ops, DO NOT do this and just wait for Intel to deliver a fix. You can brick your NUC if you do it wrong or mess something up. Use at your own risk.

 

For the version 7985 graphics driver issue, follow these steps I received from Intel support, specifically noting STEP 5 (or just get the latest 8141 driver which installs properly):

 

1) Download the latest Graphics Driver Version: 26.20.100.7985

2) Disconnect from the Internet.

3) Open Windows* Apps and features and uninstall the Intel* Graphics driver.

4) Open the Device Manager, Display Adapters section.

5) Go to Windows* Device Manager and check if Windows* installed another version of the graphics driver. If it does, please remove it and restart your computer one more time. Note: Repeat this process until you get the Microsoft Basic Display Adapter.

6) Install the previously downloaded Graphics Driver.

7) Reconnect the Internet and reboot your PC. 

 

I can confirm this process works. That said, as soon as I reconnected to the web, Windows Update tried to reinstall the old 7529 driver! I stopped it and disabled WU from updating drivers but in the end just installed v8141 when I found the 7985 driver didn't fix the BIOS update issue.

 

HTH, YMMV and good luck!

0 Kudos
6 Replies
Highlighted
New Contributor I
95 Views

Hi, DougG5. I tried those methods couple of days ago of updating to the latest Intel Graphics driver on my Intel NUC7 and NUC8 and even turns off the No button in the Device Installation settings but after several days when Windows Update tries to check for newer updates it persist to install the outdated driver to 26.20.100.7529 . Luckily, the Intel DSA won't detect that to be outdated. So, I didn't try again that method as Intel have suggested to their customers. If we apply any changes to our PC by installing official drivers from computer manufacturers [here in this case is Intel], Microsoft won't bother if this is outdated or not as long as Windows manages to continue to apply newer updates even if these updates is not new at all like this Intel Graphics driver 26.20.100.7529. As for the case of Bios Update failed to install correctly, I tried to turn off the fast start up and secure boot so that both the Express Bios update and manual F7 Bios update will be applied thoroughly, but to no avail it did not solve the issue. We'll just wait for Intel to provide a fix on this matter. Shalom!

0 Kudos
Highlighted
New Contributor III
95 Views

I tried updating using the EBU file and the BIO file and both fail. If you used the EBU file and the system keeps trying to re-flash on reboot, go into the Device Manager and uninstall the FIRMWARE item for BE0079. This should be yellow banged because of the failure. Make sure to check the box "delete the driver software for this device" so it does not get reinstalled on next boot. This should fix the re-flash cycle.

Looks like we will have to wait for an updated BIOS from Intel.

 

0 Kudos
Highlighted
New Contributor III
95 Views

Uninstall The 7529 Gfx driver from Device Manager. Make sure to check the box "delete the driver software for this device" so it does not get reinstalled on next boot. Disconnect from the internet also to prevent Windows Update from finding the older driver. Once back to the desktop, install the latest 8141 driver and you should be fine.

 

You can also update straight from 7529 to 8141 without issues. As long as both drivers are DCH versions it should work. 8141 does not require specific IDs in the NUC like previous gfx drivers did. This means we should not have to go through this again on newer releases.

 

0 Kudos
Highlighted
New Contributor I
95 Views

Hi, MRoss5200. I did that already two times last April 30 on Intel NUC7PJYH1 and on May 4, 2020 Windows Update check for drivers and the driver presented is Intel UHD Graphics 605 version 26.20.100.7529 which is outdated and my current graphics driver at that time is version 26.20.100.7985. I tried to disconnect from the internet and chose the "No" button on Device installation settings so that Windows 10 will not update the manufacturer's apps when Windows Update tries to check for newer updates. The next day, I connected to the WiFi and then Windows Update checks again for newer updates and have Intel Display Graphics version 26.20.100.7529 ready to be downloaded and installed. I continue the process and yes it is installed and replaced the current version to older version. Surprisingly, Intel DSA recognized the driver as up to date. So, I don't worry anymore as long as it being check by Intel DSA and it says, "up to date". I also tried this on my Intel NUC8i5BEH1 yesterday: uninstalling this driver and delete from the device and reboot and when Microsoft Display Adapter appears , turn off the WiFi and install the current driver and set the Device Installation settings to "NO" and then reboot again. And when you come back, see the updated driver in Device Manager. Yes your method works in here. Today, after I connected to the WiFi and then Windows Update checks again for newer updates even though I already set to "NO" that it will not update the manufacturer's apps when Windows 10 check for updates. I just continue the process of downloading and installing, just like that. Also, Intel DSA says your system is up to date. If we go through all this method, naturally it will work as suggested but Microsoft Windows 10 won't bother if it is the current or outdated driver at hand, he just persist to update this machine because we are running this OS. i don't mean to offend everyone here. Let's allow Intel and Microsoft to provide us the solution. For now, I will just wait for the right time to solve this issue.

0 Kudos
Highlighted
New Contributor I
95 Views

Hi, everyone. I recently updated my Intel Graphics Driver to the latest version via Intel DSA. This version is 26.20.100.8141. Before this happens, I turn on the "Yes" button to update the manufacturer's apps when Windows 10 update this device and then tried to click on Windows Update to see if it persist to update to version 26.20.100.7529. To my surprise, it didn't. By the way, I'm only applying this graphics update on my Intel NUC8i5BEH1. I'll try this method via Intel DSA on my Intel NUC7PJYH1 to see the same results; if not, I'll try the method presented earlier on this post.. Have a nice day ahead folks.Annotation 2020-05-07 Intel Graphics Driver latest version via Intel DSA.png

0 Kudos
Highlighted
Moderator
95 Views

Hi DougG5, Thank you very much for sharing your feedback, we are sure it will be very helpful for all the peers viewing this thread.

 

We found an issue that when updating to BIOS version 0079 the system initiates the update process but it cannot be completed, this happens if "Secure Boot" option is enabled in BIOS.

BIOS version 0079 is being removed from the Download Center and will be replaced with a version that allows the update with “Secure Boot” option enabled.

 

While BIOS update to version 0079 can be executed with “Secure Boot” option set to disabled, We would recommend that you wait until we release a more recent BIOS version for your system.

On the other hand, and this is especially important if you were running Intel® Driver and Support Assistant:<https://www.intel.com/content/www/us/en/support/products/128824/software/software-applications/intel...

 

When you encountered the issue with BIOS 0079. It is possible that when you tried to update to the latest Intel® Graphics Driver the system showed up the following error “The Driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer manufacturer.” This issue was happening due to a device ID conflict within the driver and should be corrected by now in Intel® Driver and Support Assistant.

 

If you still have issues updating the driver please try one of the options below:

- Try driver 8141:

https://downloadcenter.intel.com/download/29530/Intel-Graphics-Windows-10-DCH-Drivers?product=80939 this driver should resolve the driver ID conflict

-If running driver version 8141 via the regular installation procedure doesn’t resolve this issue or cannot be installed, try the “have disk” method: 

https://www.intel.com/content/www/us/en/support/articles/000005629/graphics-drivers.html

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos