Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KSpil1
Beginner
346 Views

How to install Windows 10 on NUC8i7HNK (Hades Canyon)?

I realize this question has been asked & answered already before, but none of the suggested solutions worked for me so far because I think my issue is slightly different.

 

The crux of my issue is that when I boot into the Windows 10 installer I get the "Missing media drivers" error message. However, this occurs during the very first step of the installation when the installer is collecting information about the system, not the second step when it actually runs the install itself. That is, I boot into the installer, I click "Next" on the first screen (asking about language & region settings), then I click "Install now" and get the wait screen for about 5 seconds before the error pops up. Has anyone esle experienced this exact issue before? Has anyone discovered a fix or work-around?

 

More details: it's a brand new NUC8i7HNK with 32GB of RAM and a 1 TB Samsung 970 Evo PLUS m.2 NVME SSD. I updated the bios to the latest (0059 released 2019-11-12). I downloaded the Windows 10 install ISO (November 2019 Update) and manually copied it to a 16GB Sandisk Cruzer USB stick.

 

All of my RAM is detected in the BIOS, and my m.2 ssd is also correctly identified. I tried connecting the m.2 ssd in both the A and B connectors (identified as labels L and N, respectively, on page 43 of the NUC8i7HNK Technical Product Specification PDF); it is correctly identified by the BIOS in both slots but the same issue occurs at install time regardless of which slot I use. My storage config is set to AHCI in the BIOS, not RAID.

 

I know some people recommend using Microsoft's Windows Media Creation Tool to create a bootable USB installer however when I tried that it created a USB stick that wouldn't even boot. However, I don't suspect either my USB stick or the ISO is at fault because the USB stick I created from Linux boots into the installer successfully.

 

I also don't think the m.2 ssd or my BIOS settings are at fault, either (although I have tried resetting my BIOS settings to factory defaults a few times just to be sure). I say that both because the ssd is correctly identified by the BIOS, and also because I was able to successfully install Linux on the ssd.

 

I downloaded some of the drivers from the NUC8i7HNK Support Files page, including the USB 3 type C power driver, the Thunderbolt drivers, and the chipset driver, and added them to my USB stick. When the error occurs I've tried browsing to those files and installing the "missing" driver from there, but in every case so far the installs fail with a message saying "No new drivers installed" which I interpret to mean those aren't the "missing media driver."

 

I really wish the installer would provide some more information to help me identify which driver it thinks is missing. As it is, trying to debug this problem feels like throwing darts in the dark trying to guess which hardware component it doesn't have a driver for.

 

If anyone has any advice or suggestions at all please let me know! It's difficult to believe the latest Windows 10 install image is missing drivers for two year old hardware so I'm hoping this is all just due to some simple configuration issue on my end. However, at this point I can't even begin to imagine what that might be.

 

Thank you in advance for reading this far!

0 Kudos
1 Reply
AlHill
Super User
208 Views

Your microsoft install media is bad, Follow my procedure exactly - no deviation.

https://forums.intel.com/s/question/0D50P00004Icw2bSAB/problems-with-microsoft-supplied-windows-10-i...

 

Doc

 

Reply