Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Volker_S_Intel
Employee
635 Views

How to set legacy mode on NUC8i7HVK FW 0058? I cannot uncheck UEFI Boot and there is no legacy boot tab. How to force legacy boot? Thank you.

 
0 Kudos
9 Replies
n_scott_pearson
Super User Retired Employee
280 Views

You cannot. The HN/HV NUC BIOS does not support Legacy Boot. The requisite CSM module is not included.

W​hile I do not necessarily agree with this decision, I certainly understand it and can argue for it. In this day and age, where new system attacks are seemingly an everyday occurrence, every attack vector that can be closed should be closed. Support for Secure Boot is an absolute must. Support for older O/Ss that do not support Secure Boot should be removed. UEFI offers the only complete solution for end-to-end secure boot. Legacy Boot has many security holes and can be circumvented without user awareness. All modern O/Ss support UEFI boot. Those older O/Ss and O/S versions that require Legacy Boot do not have support for the latest processor and chipset generations (or require significant patching to get it).

Sorry,

...S​

Volker_S_Intel
Employee
280 Views

Thank you Scott. Much appreciated.

 

To give you a bit a background on that: I'm made today a FW upgrade from 0052 to 0058 and then I was not anymore able to boot into linux. Reinstalling grub on the boot disk did not help. Then I searched for the legacy boot option but did not found. So how to get back to 0052 or earlier releases or which BIOS configuration I have to choose. On 0052 or earlier releases I was able to make linux was bootable. Thank you for help.

n_scott_pearson
Super User Retired Employee
280 Views

Sorry, if you need to convert an existing installation, you'll need to find someone more knowledgeable than I regarding the Linux boot process.

F​rankly, I too am unhappy that they made this change inflight. It is hard to agree with this part of the decision; they should have done this right from the get-go.

...S

Abigail_G_Intel
Employee
280 Views

Hello Contributer01,

 

Thank you for posting on the Intel Communities.

 

Since we noticed that this information is important for you, we are working on your inquiry, I will get back to you as soon as I can.

 

Thanks in advance for your patience, 

 

Abigail G

Intel Customer Support Technician

A Contingent Worker at Intel

LeonWaksman
Super User
280 Views

  1. If you where be able to boot into Linux with Bios 0052 you should be able to do this with Bios version 0058. There wasn't Legacy Boot option in Version 0052 neither.
  2. Uncheck the Security Boot option in Bios>Boot and try to boot into Linux.

 

Leon

 

Volker_S_Intel
Employee
280 Views

Security boot NEVER has been active, neither on 0052 nor on 0058.

Volker_S_Intel
Employee
280 Views

Security boot NEVER has been active, neither on 0052 nor on 0058.

LeonWaksman
Super User
280 Views

Abigail_G_Intel
Employee
280 Views

Hello Contributer01,

 

Thank you for waiting for our response.

 

Since the download is no longer available and this issue is related to a BIOS issue we would like you to get in contact with Intel Customer Support in order to check the warranty status and options on the unit.

 

Best Regards, 

 

 

Abigail G

Intel Customer Support Technician

A Contingent Worker at Intel.