Showing results for 
Search instead for 
Did you mean: 
New Contributor I

ITK 6 - Splash Screen Notes

This is a note to share with others some of the things I found today when adding a splash screen to a firmware .bio image to hopefully save others some time. Not actually a question (but it does include a suggestion for the Intel team)


  • NUC6CAYH and (I don't think this is NUC platform nor .bio specific)
  • ITK 6.1.6

I've been using the (old) Intel Integrators Toolkit (v5) for several years without problem, but need to update to ITK6 for compatibility with the future. After getting use to the terminology in the ITK User's Guide things went pretty smoothly except for the splash screen.

I used GIMP (2.8.18) to create an image and keep the .xcf file for future use and export a .jpg for use with ITK. When I built a new .bio and imported the .jpg file from GIMP, the splash image was not displayed, though the standard "F2 for setup.." etc. showed up. I opened the .jpg in IrfanView to check it and it looked fine, so I saved (from IrfanView) in the smaller "standard" NUC splash images sized (from the ITK zip file -- 307x230, 409x307, and 512x384) to see if that made a difference and they all worked fine (build .bio, then flash, boot and see the splash). I finally tried a full size (for me that's 1024x768) image (from IrfanView) and it worked fine. Interesting...

As part of the investigation to make the splash screen file size smaller, I reduced the jpg "quality" setting from 80 to 20, which did result in a smaller file size, but when I tried to build a .bio from itk6.efi, I got an error message from itk6.efi that said that the image size was too large (limits were 1920x1080) even though my image was 1024x768 - very strange.

What I've concluded from this work is that the ITK6 and/or the firmware that displays the splash screen at boot are (somewhat) picky about the .jpg file and that they may be happy with .jpg file from one creator/writer and not the same image, but from a different writer.

  • For Users: if your image doesn't show up, open in it another app (like IrfanView which worked for me) and resave it. That may be all you need.
  • For Intel: It would be nice to 1) have a tool to validate .jpg that are acceptable (to ITK and to the firmware that displays them) and 2) have more helpful error messages -- for example what dimensions did ITK think by 1024x768 image actually was...

My second learning (though actually ran into this first) is that ITK6 didn't like my logo files created with spaces in the name.

ITK6.eif -b -x -ib -ic -il "My Fancy Splash Screen.jpg"

failed with (vague) message "There is something wrong with the file" (that's a paraphrase since I didn't log the actual error message). I spent quite a lot of time (above) trying to figure out what was wrong with the file -- but for this error, the solution was just to remove the spaces from the file name.

ITK6.eif -b -x -ib -ic -il "Splash.jpg"

worked fine.

Hope this saves someone some headaches....

0 Kudos
1 Reply
Community Manager

Hello MDV55,



Thank you for contacting Intel® Communities Support.



We appreciate your time and feedback. I am pretty sure this will be useful for other customers.





Stephen C.
0 Kudos