Intel® NUCs
Support for Intel® NUC products
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11977 Discussions

Installed Ubuntu 18.04 on my NUC8I7HVK.. wow this thing is great! Here's how I have it configured.


I built up my NUC8i7HVK with the following:

32GB Crucial Dual Ranked memory

500GB M.2 Samsung M.2 NVME

OWC Thunderbolt JBOD (borrowed from my MacPro (Late 2013 black can)

All I have to say is WOW... It's great! I tested with some games running at 2k. I logged into Steam. Played an old game I like to play with family online..

Team Fortress 2, Rocket Leage, Metro: Last Night.. wow. My Gazebo Parrot-Sphinx flight simulator runs great! Next week I'll test my Nvidia eGPU (GTX970)

I use it mostly for experimenting for Tensor flow.

After this email is sent I will be testing video rendering time with kdenlive. I have melt configured for my rendering with GPU. I'll update later.

I got this NUC because I was tired of the problems with some of my OpenCL that runs on Linux crashing while running on my MacPro that runs Ubuntu 18.04 on bare metal.

Also Apple is dropping support for OpenGL in favor of their own API.. Metal. Dumb move . OpenGL is an open standard...

Anyway I bought the NUC8i7HVK because when I looked at the specs, overall the performance looked close to the MacPro. The Xeon processor is faster with intercore data, but the overall performance of the NUC with the VegaM is actually slightly better! That's huge! I am sure glad I didn't pay top dollar for my MacPro. My son got paid for a job he did with Hardware. He got the MacPro 6 core. A year later he sold it to be cheap, and I gave him $250.00 more than he asked for. He wanted a PC that was more "Open".. so he built his own with parts from MicroCenter.

One year later I came to the same conclusion with the MacPro.

This little NUC is awesome!

6 Replies
Community Manager

Hello jerryn,



We are glad to know that you got good results after installing Ubuntu* 18.04 on your Intel® NUC and that you were able to access some of your favorite websites and games. Your feedback is highly appreciated.



We hope other users take advantage of your experience with our Intel® NUC.



Wanner G.

After several weeks of use I ran into one issue.

Here's how my NUC is configured:

32GB Crucial Dual Ranked memory

500GB M.2 Samsung M.2 NVME

OWC Thunderbay 4 JBOD

Apple Thunderbolt 3 to Thunderbolt 2 adapter

Dell Monitor on mini DV1

Apple IPS monitor (built from Adafruit kit ) mini DV 2

Linux Bionic Beaver LTS 18.04

Akitio Node w/NVidia GTX 970 connected via thunderbolt 3

APC Back UPS XS 1500

The OS is loaded on the NVME drive, /home and /opt are on the JBOD, managed by LVM. Boots and works great everytime. As long as I don't power off the UPS after shutdown. After powering up the UPS. I have to play around hot plugging the jbod during boot up. Once the NUC is online it works fine. I can do a full shutdown, return the following day, boot up with no problems. Only when I power off the UPS there's an issue. I have "Green" power management disabled. The JBOD has power at this point, the status led is orange. It requires hotplugging the jbod several times before it is recognized and powers up.


The firmware on the NUC is the latest and greatest. I updated the firmware 2 weeks after the original install.

Could it be the firmware ? My Akitio node powers up every single time, ups recycle or not. Maybe power reset TB3/TB2 adapter has an issue ? I was investigating that route but the fact the NUC turns on the OWC JBOD every time as long as the UPS was not recycled makes me think otherwise. The JBOD is getting power or the status LED would not be orange.

any ideas ?


The above works extremely well. I use the eGPU for playing around with Tensorflow, OpenCV, and Gazebo. The AMD VegaM is used for the primary display, Steam Games works great

at 2K resolution. I am happy with the setup

Community Manager

Hello jerryn,



We provide limited support for Linux*. We do not validate Linux operating systems on Intel® NUC. However, we know it works.



You may refer to this information below in case you need any additional Linux Support. Linux* Support for Intel® NUC



Hopefully, another peer can respond to your post.



Wanner G.

I run Linux, and Windows 10, and soon I will build a Hackintosh image for the NUC. The issue is possibly a NUC firmware issue, it started with the last updated.

It affects Windows 10 and Linux. Here's how to duplicate it.

Connect thunderbolt attached jbod to NUC, power from APC XS 1500 managed power outlet

Connect Akitio Node via thunderbolt to NUC, power from APC XS 1500 managed power outlet

Connect main monitor, mini dv

Connect secondary monitor, mini dv

power up ups.. boot from internal storage.. jbod does not power up (a/c power is on)

Akitio node is switched on but does not power up

Shutdown NUC.

Turn JBOD power switch off

Turn Akitio Node power switch off

Turn off APC UPS. .. count to 20 Mississippi , turn it back on

Turn on APC ups

Count to 10 Mississippi

Turn on NUC, Turn Akitio node power switch on, turn jbod switch on

Turn on NUC.. All usb and thrunderbolt devices are on and active

Shutdown Nuc.. shuts off fine

Power up NUC.. everything powers up find.

Shut down NUC, Shutdown APC UPS

Turn on UPS, Turn on NUC.. thrunderbolt devices do not power up and you have to repeat the steps I mentioned all over again.

I disable the master outlet power management, all ports were on. same issue.

tomorrow night I will test without the UPS. The previous computer connected to it (macpro 2013 desktop) ran fine with the thunderbolt hardware attached to it.

What's the protocol for the thunderbolt 3 ports to enable power on the thrunderbolt attached devices ?

Also note.. all my thunderbolt devices are self powered.

When the environment is up it works great ! I've got Lightworks on Linux working great with the Akitio Node nvidia GTX970..

Can I back out of the last firmware update ?

Community Manager

Hello jerryn,



The board supports two Thunderbolt™ 3 ports. Each port can support up to 5V at 3A.



Now, if you are talking about the BIOS update, this link provides the versions available. You should be able to revert back to the previous version.



Wanner G.



I wanted to update this thread just in case anyone else encountered my problem. The problem was actually with my UPS. I have the backUPS Pro XS 1500 and use the Master/Controlled power saving feature to control the power to outlets. This way when I shut off the PC, the JBODs, USB3 hub, eGPU, main monitor, apple ips monitor.. all power off. When I started to work with my Hades Canyon, I connected it to the master outlet, where the MacPro was. I was working with the MacPro. Apparently the APC Master/Controlled configuration needed to be re-calibrated It's working fine now. Not a Thunderbolt issue at all.

I'm compiling TesnsorFlow right now.

By the way, have you seen how slick the new KDE Plasma Desktop is on Linux ?