Intel® NUCs
Support for Intel® NUC products
12506 Discussions

Intel Arc / Fedora won’t load graphics card on boot Nuc 12 Enthusiast

nucfan24
Beginner
350 Views

Running on Fedora rawhide, kernel 6.1, I cannot get Fedora to load the Intel Arc A770 / Intel integrated graphics devices on a **cold** boot.

Fedora will seemingly freeze just before the loading screen / login. It gets down to the point of 'force_probe .... tainting kernel' and then proceeds no further.

I have set the `WaylandEnabled=false` setting in gdm conf, and I have also added an i915.conf under /etc/modprobe.d that has:

`options i915 force_probe=5690`

I have also added the latest Intel gpu firmware to `/lib/firmware/updates/i915`. The logs below indicate they are used.

Still, the only way I can get into Fedora on a cold boot is by editing grub2 and setting `nomodeset`. Once I am inside, I check the logs for anything mentioning VGA, guc, huc, and there is nothing.

If I reboot at this point and log back in (still `nomodeset`), then I start to see the GPU in `lspci`:

 

```
lspci -nnv | grep -i "vga"
00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])
03:00.0 VGA compatible controller [0300]: Intel Corporation DG2 [Arc A770M] [8086:5690] (rev 08) (prog-if 00 [VGA controller])
```

At this point, if I edit grub2 conf and remove `nomodeset`, then reboot, the GPU is loaded and I am using the device (Settings indicates the card is in use, and does not say Software Rendering). However, here are some logs that look curious regarding HuC/GuC and I do not know what they mean or if they contribute to this issue:


```
[ 10.776214] i915 0000:00:02.0: [drm] GuC error state capture buffer maybe too small: 2097152 < 2360316 (min = 786772)
[ 10.780530] i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_70.bin version 70.5.1
[ 10.780542] i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc.bin version 7.9.3
[ 10.795827] i915 0000:00:02.0: [drm] HuC authenticated
[ 10.796623] i915 0000:00:02.0: [drm] GuC submission enabled
[ 10.796631] i915 0000:00:02.0: [drm] GuC SLPC enabled
[ 10.797263] i915 0000:00:02.0: [drm] GuC RC: enabled
[ 10.812205] i915 0000:03:00.0: [drm] Incompatible option enable_guc=3 - HuC is not supported!
[ 10.949684] i915 0000:03:00.0: [drm] GuC error state capture buffer maybe too small: 2097152 < 3737592 (min = 1245864)
[ 10.954581] i915 0000:03:00.0: [drm] GuC firmware i915/dg2_guc_70.bin version 70.5.1
[ 10.967389] i915 0000:03:00.0: [drm] GuC submission enabled
[ 10.967399] i915 0000:03:00.0: [drm] GuC SLPC enabled
[ 10.967837] i915 0000:03:00.0: [drm] GuC RC: enabled
```

At this point, I can reboot as much as I like and the GPU will be used. However, if I shutdown, then power back on, Fedora freezes again and I have to revert back to `nomodeset`. I have also tried `enable_guc=2` and `enable_guc=1` in i915.conf - the problem still persists.

What is the difference here between a cold and warm boot in regards to device discovery / driver loading? Is something extra needed for this to work from a cold boot? I feel like I am close to getting this working but its driving me crazy.

How did this poster get it to work on Fedora? I am using an Intel NUC 12th gen enthusiast, its brand new. I have seen a few other posts of people getting it to work without any mention of this sort of problem. They are doing the force_probe method, which sounds like most people are - but it is being really problematic for me. I'd even be happy at this point just to have the integrated graphics loaded if I can't use DG2/Arc for a few months.

https://www.reddit.com/r/Fedora/comments/y8yne8/intel_arc_a750_gpu_on_fedora_first_impressions/

I do not want to install Ubuntu, I want to use Fedora like these posters are, so please do not suggest to me to go install Ubuntu. 22.04 doesn't even recognize the wireless device in the Nuc 12 enthusiast. 

0 Kudos
3 Replies
Steven_Intel
Moderator
294 Views

Hello nucfan24,


Thank you for posting on the Intel® communities.


I am going to research about this. As soon as I have an update, I will let you know.


Best regards,


Steven G.

Intel Customer Support Technician.



Steven_Intel
Moderator
264 Views

Hello nucfan24,


After reviewing this information, our best recommendation is to visit Linux forums for further assistance, as the operating system is not officially supported on this device and this falls out of our scope.


Please find the following related article:


Supported Operating Systems for Intel® NUC Products: https://www.intel.com/content/www/us/en/support/articles/000005628/intel-nuc.html


Linux Support for Intel® NUC: https://www.intel.com/content/www/us/en/support/articles/000005499/intel-nuc.html


Best regards,


Steven G.

Intel Customer Support Technician.


nucfan24
Beginner
211 Views

I figured it out. Intel docs should note this.

I updated the BIOS to the latest available for the NUC12SNKi7200U.

Then, in the BIOS, I disabled both ACPI and PCIe power management options. With those two options disabled, Fedora 37 can successfully cold boot. This is stable Fedora 37, not Rawhide, and no updated firmware beyond what F37 has.

You still need to add this:

`options i915 force_probe=PCI-ID`

to /etc/modprobe.d/i915.conf and run sudo dracut -f.

After this point, I could successfully cold boot several times without any issue at all and now Fedora is using the Arc 770m.

To verify this, I wiped the machine and started over from scratch, worked my way back, replicated the issue, applied the above steps, and it worked again. I have not had an issue since.

Reply