Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JJose28
Beginner
2,124 Views

Intel NUC DE3815 XHCI settings an Linux

Jump to solution

Hi!

I finally installed CentOS 7 on my NUC and when I enable XHCI in UEFI setup, the system freezes at shutdown/reboot.

At boot, I can see the following line: "ehci-pci 0000:00:1d.0: port 1 reset error -110"

This happens every time if XHCI is enabled in BIOS. It does not matter if there are USB devices connected or not.

Currently I am using BIOS 0049 (latest) on this Bay Trail based NUC and all available updates to CentOS.

I installed CentOS with this guide: https://www.centos.org/forums/viewtopic.php?t=47536 e_MMC install on intel NUC DE3815TYKHE - CentOS (posts 7 and 9)

Here is some additional information: https://www.spinics.net/lists/linux-usb/msg112624.html https://www.spinics.net/lists/linux-usb/msg112624.html (Bay Trail)

Setting XHCI to Enabled/Disabled solves the problem: https://askubuntu.com/questions/565004/ubuntu-booting-error-ehci-pci-000000id-0-port-1-reset-error-1... 14.04 - Ubuntu booting error: ehci-pci 0000:00:id.0: port 1 reset error -110 - Ask Ubuntu (Acer Aspire E15 Start - Bay Trail)

BIOS-Update solves the problem: https://bbs.archlinux.org/viewtopic.php?id=208982 https://bbs.archlinux.org/viewtopic.php?id=208982 (Intel Celeron J1800 - Bay Trail)

If I unbind the ehci-pci driver, the system freezes. It doesn't even respond to ping.

If I use "lsusb -vv" it stops at "Bus 003 Device 002: ID 8087:07e6 Intel Corp." and freezes.

if I use udev to remove the PCI device, the system freezes.

This phenomenon should only happen if XHCI is set to Auto or "Smart Auto".

But I can only set it to Disabled or Enabled. It is clear that this setting is mislabelled as "Enabled", but it should be "Auto".

Please correct this issue in BIOS, rename "Enabled" to "Auto" and add a real "Enabled" option.

Best Regards,

Joe006

0 Kudos
1 Solution
JJose28
Beginner
390 Views

@Hellen:

It is installed in UEFI mode. The eMMC has a GUID partition table and fast boot mode is working.

Saying "Debian-like Linux' are supported, but Red-Hat-likes are not" is just plain nonsense!

KDD:

Why should I downgrade the BIOS if the newer version fix issues with Linux?

I guess it'S due to kernel 3.10 - I will install http://elrepo.org/ elrepo yum repository and try kernel 4.4 (package kernel-lt).

EDIT: Yes, it'S the old kernel version. The USB controller was not added to the list of switchable controllers.

Kernel 4.4 supports EHCI/XHCI switching for this controller and everything is fine.

It's a shame, that Intel does not correct their BIOS and that this change was not properly backported to kernel 3.10 by the community!

View solution in original post

6 Replies
idata
Community Manager
390 Views

Hi Joe006,

 

 

I suggest you to reinstall the OS with UEFI option enable, and let me know the outcome.

 

Please keep in mind that this OS is not in the list of supported operating system.

 

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-boards/000005628.html http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-boards/000005628.html

 

 

Regards,

 

Hellen.

 

KDann1
New Contributor I
390 Views

I have had this same problem, but it and others are not present with BIOS 0024.

idata
Community Manager
390 Views

Hi Joe006,

 

 

Please let us know if KDD suggestion helps you.

 

 

Regards,

 

Hellen.

 

JJose28
Beginner
391 Views

@Hellen:

It is installed in UEFI mode. The eMMC has a GUID partition table and fast boot mode is working.

Saying "Debian-like Linux' are supported, but Red-Hat-likes are not" is just plain nonsense!

KDD:

Why should I downgrade the BIOS if the newer version fix issues with Linux?

I guess it'S due to kernel 3.10 - I will install http://elrepo.org/ elrepo yum repository and try kernel 4.4 (package kernel-lt).

EDIT: Yes, it'S the old kernel version. The USB controller was not added to the list of switchable controllers.

Kernel 4.4 supports EHCI/XHCI switching for this controller and everything is fine.

It's a shame, that Intel does not correct their BIOS and that this change was not properly backported to kernel 3.10 by the community!

View solution in original post

KDann1
New Contributor I
390 Views

Use newer if you think it fixes something then. My experience has been very much the opposite, the newer BIOS releases break multiple things with Linux and the Intel support here is of no help whatsoever, no matter how many cases I have opened.

idata
Community Manager
390 Views

Hi,

 

 

Thanks for the feedback, nice to know that your NUC is working properly.

 

Intel has a special website where we put altogether open source work that Intel engineers are involved in. https://01.org/ https://01.org/

 

 

Development support is available through the open source community.

 

https://01.org/community https://01.org/community

 

 

Regards,

 

Hellen.

 

Reply