Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,032 Views

Intel NUC DN2820FYKH stuck at EFI screen

Yesterday my device restarted own suddenly and after boot I saw an error message first time:

The top of screen says "EFI Shell version 2.31 - Current running mode 1.1.2" followed below by "Device mapping table" "mapping"

Finally, the last line says "Press ESC in 1 seconds to skip startup.nsh, or any other key to continue". Nothing happens when I try pressing ESC or any other key though, and I can give commands by typing where "Shell>" is (it's below the "last" line). For example, if I type exit and press enter, I will enter BIOS.

 

I opened thge case and remove HDD and tried it but still no success. I removed and plugged RAM and I plugged out every cable and wait more than 30 minutes but I can't pass this error.

 

In this case what would you suggest to me?

 

I have Kingston SSD V300 60Gb and Win 8.1

 

0 Kudos
1 Reply
Highlighted
New Contributor II
5 Views

Re: Intel NUC DN2820FYKH stuck at EFI screen

(re)install the latest bios through the F7 method.