Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Wmrdjenovich
New Contributor I
1,085 Views

Intel NUC Hades Canyon (NUC8i7HVK) Sometimes Starts With Black Screen

Jump to solution

Issue: Sometimes when I go to start my Hades Canyon NUC I see a brief flash of the Intel NUC splash screen and then the screen goes dark. I can see that the computer starts reading from the SSD inside the computer as the LED starts to blink. In particular this occurs nearly every single time I adjust anything within the BIOS such as fan control. I have had it happen once on a normal reboot. The computer becomes completely unresponsive to any commands in this state, meaning no BIOS access. When this happens I perform a force shutdown by holding the power button. Then when I restart the NUC everything seems to work fine. The NUC splash screen appears, I can access the BIOS again, and I can boot into Windows 10. I once got text saying that a POST code said that an update to the BIOS settings (I had changed fan profile) caused an issue with a boot and whether I wanted to try again with the new settings which allowed me to boot successfully.

Troubleshooting: Here is a list of things I've tried.

  1. Resetting the BIOS from the menu
  2. Repairing the BIOS from the menu (3 second power button hold)
  3. Updating the BIOS from the menu (F7 function)
  4. Performing chkdsk on both my NVME SSDs (No errors)
  5. Checking the HDMI cable in both the NUC and the Monitor

Background: I have been experimenting with overclocking my GPU utilizing the WattMan utility in Radeon Settings page. I intermittently change the fan control in the BIOS to a custom higher setting to keep the GPU cool during the procedure. I don't overclock my GPU when it's unnecessary, and keep the computer at the stock GPU settings with the Balanced fan control profile during most operations. I only overclock whilst running MSFS2020. These issues began before I attempted to overclock and first appeared when I was learning how to change the fan settings.

I'm not sure whether this is a real major issue, though I don't enjoy force shutting down any computer to get it to work so if there is a fix it would help my sanity a bit. Thank you for your time! Let me know if you need more information.

0 Kudos

Accepted Solutions
Wmrdjenovich
New Contributor I
884 Views

Hello All

I devised a solution to the issue. The RX Vega M GH works fine once the computer boots successfully, so getting an entirely new system seems unnecessary. Additionally, I have overclocked the GPU which may void any sort of warranty for the NUC8i7HVK and I can't afford to spend a significant amount of money to replace a nearly perfectly working system. For those in a similar position, this was my fix.

Solution: I wrote batch scripts utilizing devcon.exe from Windows WDK to enable / disable the RX Vega M GH and shutdown the computer . You can also attempt to find the executable on it's own online. **Note** I can no longer utilize the start menu power option to shutdown as it won't disable the graphics in time. Instead, I created a shortcut to my Shutdown.bat from the desktop. The computer can remain functioning with the graphics disabled as it will utilize the i7-8890G integrated graphics (Intel HD Graphics 630). I have the computer set to enable the RX Vega M GH 10 seconds after log in utilizing the Windows task scheduler. This fix has successfully worked for several days so it will be the accepted solution. I will attach the code below. 

Description of Files

RD.bat: Will disable the RX Vega M GH utilizing devcon.exe and the hardware id.

echo "Starting RX Vega Disable Script"
cd\FILE ADDRESS OF RD.bat
set driverName=HARDWARE ID
devcon disable %driverName%
echo "Ending of Script"

RE.bat: Will enable the RX Vega M GH utilizing devcon.exe and the hardware id.

echo "Starting RX Vega Enable Script"
cd\FILE ADDRESS OF RE.bat
set driverName=HARDWARE ID
devcon enable %driverName%
echo "Ending of Script"

Shutdown.bat: Implements RD.bat. Then waits for user to confirm shutdown. Runs normal shutdown procedure from command line utilizing shutdown /s. This will allow the computer to boot normally during the next power on.

echo "Starting Shutdown Sequence"
cd\FILE ADDRESS OF Shutdown.bat
echo "Starting RX Vega Disable Script"
set driverName=HARDWARE ID
devcon disable %driverName%
echo "Ending of Script"
echo "Waiting for shutdown confirmation"
PAUSE
cd\Windows\System32
shutdown /s

**Note**: All programs must be run as an administrator to work correctly. Make sure to get hardware id from devcon.exe utilizing devcon hwid* from cmd.

To implement copy the code to a notepad document and change the file extension to .bat for the code to work.

Hopefully this can help someone else if this happens to them! Thank you for all your time.

View solution in original post

14 Replies
n_scott_pearson
Super User Retired Employee
1,072 Views

Well, it sounds like you may have damaged something during your overclocking, but let's not jump the gun completely. For starters, please download and run the Intel System Support Utility for Windows and have it save the report to a file. Then, using the Drag and drop here or browse files to attach dialog below the edit box for the body of your response post, upload and attach this file to the response post.

...S

 

LeonWaksman
Super User
1,069 Views

Hi @Wmrdjenovich 

1. Are you connected to the monitor with DP or HDMI cable?

2. When you have this black screen, instead of force powering OFF your NUC, please disconnect and reconnect the video cable. Occasionally, I have also black screen in my NUC8i7HVK and reconnecting the video cable (I'm connected with miniDP to DP cable) recovers display. I don't say that this is OK, but that what is happening in my NUC.

 

Leon

 

Wmrdjenovich
New Contributor I
1,035 Views

@LeonWaksman I have checked the HDMI input coming out of the computer and going into the monitor by disconnecting a reconnecting both during this issue. Unfortunately it did not lead to a solution.

Wmrdjenovich
New Contributor I
1,033 Views

@n_scott_pearson I successfully added the system report to the main post. Everything seemed in order with the hardware, though I only skimmed through the results. In particular the System Message may shed the most light on the issue. It seems to list some specific failures that resulted me initiating a force shut down. This could be the root of the issue? I certainly don't know what the message mean unless I started looking them up.

Wmrdjenovich
New Contributor I
1,024 Views

Update: So strangely enough this started happening every single time that I shut my computer down normally in windows. Now I can change settings in the BIOS freely with no consequence or black screen after exiting. In fact I found a workaround though it's quite annoying. Every time I shut down normally in windows, I can still access the BIOS before the screen goes completely black on the next startup. So long as I save and exit the BIOS with F10, the computer boots normally after it closes. Something also to note, the computer reboots fine when selecting the restart selection in the power menu of Windows 10. It's a workaround of sorts, though not something I'd like to do long term as I want my computers boot to remain fast and smooth.

LeonWaksman
Super User
1,016 Views

Hi @Wmrdjenovich 

I've read the SSU report form your NUC. You have very old and outdated version of AMD driver.  Please download and install the version 19.12.1 of the AMD Graphics Driver This is not the last released version, but is the best functioning version for NUC8i7HVK.  Before installing this driver, please open Apps and Features (Windows Settings) and uninstall the AMD Software. Reboot your NUC and install the previously downloaded driver version 19.12.1. 

Leon

 

Wmrdjenovich
New Contributor I
998 Views

Hi @LeonWaksman

I will look into your advice about the AMD driver update. It's a bit strange though, as I checked to see if the RX Vega M GH driver was updated. I'm currently running version 25.20.15002.58 from 1/10/2019. Intel driver support assistant says that this is the latest driver for the discrete graphics. If I understand your reply correctly, I also need to download AMD software.

LeonWaksman
Super User
989 Views

Hi @Wmrdjenovich 

Yes , you should download the software from AMD (see the link in my post above). After installing the driver you will see version 26.20.13031.20012.  Yes, the Intel DSA gives wrong indication in this case.  BTW, I've given you link to Driver Package 19.12.1 while the latest package version is 20.2.2  However, my advice is to install the version 19.12.1 which works better with Hades Canyon.

See the attached image showing driver from package 19.12.1 after installation.

Leon

 

 

Wmrdjenovich
New Contributor I
971 Views

I nearly declared victory after I installed the new AMD driver and the new BIOS version 0063; however, the second I changed the fan setting in the BIOS from Balanced to Cool, the problem resumed. Honestly not sure if anything really got fixed in the end.

Here is the chain of events:

  1. Installed AMD Driver which led to message that the BIOS has detected an unsuccessful POST attempt, I entered the BIOS, saved and exited, computer restarted normally and booted.
  2. Installed BIOS version 0063, installed properly, computer booted normally.
  3. Shut down computer and rebooted, computer turned off and on once and then booted properly.
  4. Shut down and rebooted properly.
  5. Decided to test if changing the BIOS caused an issue, changed fan profile from Balanced to Cool, computer booted normally, shut down, pressed power button, leading to black screen and forced shut down.
  6. Repeated shut down test after changing the fan setting back to Balanced, problem persisted. I can confirm that I can still enter the BIOS before the black screen occurs which fixes the problem once I save and exit (until the next shut down of course).

Hopefully there is another solution out there!

LeonWaksman
Super User
962 Views

Hi @Wmrdjenovich 

1. I suggest that you update BIOS using BIOS Recovery from the Power Button Menu method:

2. Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Format your USB on Windows machine (rather than Linux or MAC). Save the Bios file HN0063.bio  on this stick and insert it into front USB slot with amber color (NUC shall be OFF). You may use also one of the rear USB ports (do not use front blue USB port, since sometime the USB stick is not recognized during boot process).

3. Press and hold Power Button for about 3 seconds. Count 1001, 1002, 1003,1004. Release the Power Button. NUC should reboot into Power Button Menu. You should release the Power Button before 4-sec shut down override or when the Power Button LED changes color from blue to amber.

4. Press F4 and the recovery shall start (it can take up to 30 seconds for messages to appear on the screen).

5. When the recovery finishes, press on Power Button and hold it, until NUC switches OFF. Pull out the power cord. Remove the USB stick.

6. Replace the power cord and press Power Button to switch the computer to ON.

7. Enter Bios setting by pressing F2 during boot process.

8. Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.

9. If before update, you have customized bios settings, you can enter again to Bios setting to change the necessary settings. 

 

Leon

Wmrdjenovich
New Contributor I
950 Views

Hi @LeonWaksman

Unfortunately the recovery did not solve the issue. After resetting the BIOS with F9 and saving and exiting with F10, I was once again met with a black screen. I force shut down the machine which led to the computer booting normally.

We'll have to keep looking for a solution!

Update: An unfortunately development to the issue. The BIOS workaround no longer works and that every time I shut down the computer it will hang on the black screen until I force a shut down. 

Wmrdjenovich
New Contributor I
941 Views

Important Update: After some experimenting with Windows 10 Safe Mode, I've determined that the problem is either the RX Vega M GH itself or the AMD drivers.

When I disabled the AMD drivers for the graphics card, the computer was able to boot fine with no issues utilizing the integrated graphics. When I reenabled them, the computer once again presented a black screen until a forced restart allowed it to boot properly. Why a force power down fixes the problem I still have no idea.

Workaround: Utilize the device manager to disable the RX Vega M GH  before a shut down, this allows the intel integrated graphics to take over. Unfortunately this removes the sleep function. The computer will boot normally with the integrated graphics enabled. Then I go to the device manager and reenable the RX Vega M GH.

I still want to try and find a working solution, though for now this seems to be working.

LeonWaksman
Super User
927 Views

Hi @Wmrdjenovich 

I suspect that you have hardware problem. Could be that the Radeon chip was damaged during your overclocking attempts. You may open a support ticket to replace your NUC, which should be covered by three year warranty.

Leon

 

Wmrdjenovich
New Contributor I
885 Views

Hello All

I devised a solution to the issue. The RX Vega M GH works fine once the computer boots successfully, so getting an entirely new system seems unnecessary. Additionally, I have overclocked the GPU which may void any sort of warranty for the NUC8i7HVK and I can't afford to spend a significant amount of money to replace a nearly perfectly working system. For those in a similar position, this was my fix.

Solution: I wrote batch scripts utilizing devcon.exe from Windows WDK to enable / disable the RX Vega M GH and shutdown the computer . You can also attempt to find the executable on it's own online. **Note** I can no longer utilize the start menu power option to shutdown as it won't disable the graphics in time. Instead, I created a shortcut to my Shutdown.bat from the desktop. The computer can remain functioning with the graphics disabled as it will utilize the i7-8890G integrated graphics (Intel HD Graphics 630). I have the computer set to enable the RX Vega M GH 10 seconds after log in utilizing the Windows task scheduler. This fix has successfully worked for several days so it will be the accepted solution. I will attach the code below. 

Description of Files

RD.bat: Will disable the RX Vega M GH utilizing devcon.exe and the hardware id.

echo "Starting RX Vega Disable Script"
cd\FILE ADDRESS OF RD.bat
set driverName=HARDWARE ID
devcon disable %driverName%
echo "Ending of Script"

RE.bat: Will enable the RX Vega M GH utilizing devcon.exe and the hardware id.

echo "Starting RX Vega Enable Script"
cd\FILE ADDRESS OF RE.bat
set driverName=HARDWARE ID
devcon enable %driverName%
echo "Ending of Script"

Shutdown.bat: Implements RD.bat. Then waits for user to confirm shutdown. Runs normal shutdown procedure from command line utilizing shutdown /s. This will allow the computer to boot normally during the next power on.

echo "Starting Shutdown Sequence"
cd\FILE ADDRESS OF Shutdown.bat
echo "Starting RX Vega Disable Script"
set driverName=HARDWARE ID
devcon disable %driverName%
echo "Ending of Script"
echo "Waiting for shutdown confirmation"
PAUSE
cd\Windows\System32
shutdown /s

**Note**: All programs must be run as an administrator to work correctly. Make sure to get hardware id from devcon.exe utilizing devcon hwid* from cmd.

To implement copy the code to a notepad document and change the file extension to .bat for the code to work.

Hopefully this can help someone else if this happens to them! Thank you for all your time.

View solution in original post