Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
505 Views

Intel NUC Hades Canyon not properly recognising Mic input

Jump to solution

I am attaching the log from the SSU for ease of reference. I have been having issues with the mic 3.5mm jack input. The Microphone is tried and tested works well with every other pc, in fact I transferred it from my old NUC. I have noticed that the jack will only take Headset systems without problems (include mobile headsets) but not a microphone on its own. I also noticed that after unplugging the headset, if I plug the microphone in it will take sound for a while, but will after that while go back to the same problem (i.e. no sound input).

 

So which one is it? Is it a driver problem? Is it discontinued support for standalone microphones? I also had an open ticket about this issue (and I solved all the other issues): Service Ticket: 04589709

0 Kudos

Accepted Solutions
Highlighted
Novice
384 Views

Final Update for this Issue with Solution:

 

Firstly, I would like to thank Intel staff for taking the time to set up a support session. As already mentioned, it sorted out the irregularities with the drivers and BIOS. After testing, the staff contacted me saying that from their end, all the microphones they tested work without problems and unfortunately could not help me any further, suggesting that either I get a new microphone or resort to using the Mobile Phone headset, but since I use my microphone for gaming and streaming, getting low quality sound from the mic, even if it is the only working type just won't cut it. So I set out to find a solution by myself, having tested and proven that the microphones work flawlessly on other machines.

 

It turns out that the problem lied with the way the Realtek Audio Manager and the Control Panel are set up by default. They will only recognise headset types with a 4 gang (or TRRS) pin and give you average sound at best, unless you do the following steps:

 

  1. In Realtek Audio Console, select the microphone you just plugged in. Under Recording Device, if the first option is selected, i.e. "Tie up same type of input jacks..." (it should be by default), deselect it and instead select the one below (i.e. "Separate all input jacks..."). This will allow the driver to recognise and process sound from the plugged in mic, but will probably contain a background hiss.
  2. To remove the background noise, go to Control Panel (Type Control Panel in Start), open Sound and go to Recording. Go to Advanced and if it is not selected (if you hear a background hiss it probably isn't) select Enable audio enhancements and voilá! You can now enjoy using a microphone as it was intended on an Intel NUC Hades Canyon with Realtek Audio Drivers.

 

No need to downgrade to any old drivers or firmware. The new and updated ones work just fine - they are just not set up by default to take input from third party microphones (by default they give preference to the inbuilt microphone array).

View solution in original post

0 Kudos
5 Replies
Highlighted
Moderator
384 Views

Hello KCauc,

 

Thank you for submitting your question on this Intel® Community.

 

To better assist you, we recommend that you continue troubleshooting this issue with the Intel Customer Support team that is already working with you on case 04589709.

 

Rest assured that Intel Customer Support is doing their best to resolve this issue.

 

We will close this thread. If you have other inquiries, please open a new thread. We will be glad to help you.

 

Wanner G.

Intel Customer Support Technician

0 Kudos
Highlighted
Novice
384 Views

Just to give an update for the community out there. Intel has been in contact with me and we tried to resolve the issue. So far, installing and reinstalling the drivers has had no effect. The matter is being investigated internally by Intel and I am expecting a reply when they have any answers. We have tested 2 gang and 3 gang headset microphones (these are just headset wearable microphones without headphones/earphones). We also tried plugging these two types into a 4gang splitter as well as plugging them into a PnP USB adapter. On all trials, no sound could be registered. These two microphone types have been previously tested and worked 100% with an Intel NUC Skullcanyon so we have ruled out any defects with the microphones themselves. We also confirmed that standard mobile phone 4gang headsets (mine are from a Samsung A20e mobile phone) work fine with this NUC Hades Canyon. As stated, this matter is still being investigated by Intel and I will post any updates and final results (be it positive or negative) for the community just in case anyone else runs into a similar problem.

0 Kudos
Highlighted
Novice
385 Views

Final Update for this Issue with Solution:

 

Firstly, I would like to thank Intel staff for taking the time to set up a support session. As already mentioned, it sorted out the irregularities with the drivers and BIOS. After testing, the staff contacted me saying that from their end, all the microphones they tested work without problems and unfortunately could not help me any further, suggesting that either I get a new microphone or resort to using the Mobile Phone headset, but since I use my microphone for gaming and streaming, getting low quality sound from the mic, even if it is the only working type just won't cut it. So I set out to find a solution by myself, having tested and proven that the microphones work flawlessly on other machines.

 

It turns out that the problem lied with the way the Realtek Audio Manager and the Control Panel are set up by default. They will only recognise headset types with a 4 gang (or TRRS) pin and give you average sound at best, unless you do the following steps:

 

  1. In Realtek Audio Console, select the microphone you just plugged in. Under Recording Device, if the first option is selected, i.e. "Tie up same type of input jacks..." (it should be by default), deselect it and instead select the one below (i.e. "Separate all input jacks..."). This will allow the driver to recognise and process sound from the plugged in mic, but will probably contain a background hiss.
  2. To remove the background noise, go to Control Panel (Type Control Panel in Start), open Sound and go to Recording. Go to Advanced and if it is not selected (if you hear a background hiss it probably isn't) select Enable audio enhancements and voilá! You can now enjoy using a microphone as it was intended on an Intel NUC Hades Canyon with Realtek Audio Drivers.

 

No need to downgrade to any old drivers or firmware. The new and updated ones work just fine - they are just not set up by default to take input from third party microphones (by default they give preference to the inbuilt microphone array).

View solution in original post

0 Kudos
Highlighted
Beginner
366 Views

Hello everyone,

I was very happy when I found this thread as I hoped it would solve my problem which was exactly as described: my NUC7i5BNH does not work with a newly bought 3.5 mm 3-pin microphone which is a huge disappointment.

I tried to do as suggested in the Solution. To do this I had to fix some issues with drivers as Realtek Audio Console was not working.

Now I can open the Console, but the problem is I simply can’t find these options there: neither "Tie up same type of input jacks..." nor "Separate all input jacks...". Under Recording Devices I have Microphone Array (built-in microphone I assume) and a Microphone. There are also Device Advanced Settings below, but I can’t find anything similar there either.

Are there any ideas about what to do?

0 Kudos
Highlighted
Beginner
337 Views

I don't precisely know how it happened, but it seems like launching Windows speech recognition has had some effect, as after I launched and tested it, I finally saw the sound bar in Settings moving, and the recording worked as well. It seems like turning enhancements off/on have had no effect. 

 

0 Kudos