Community
cancel
Showing results for 
Search instead for 
Did you mean: 
APete10
Beginner
2,772 Views

Intel NUC8i7HVK, all driver updated+Samsung nvme driver latest. Slower boot time when 2 SSD disk enabled and with 2 disks enabled HD led Always on

Boot drive Samsung SSD 970EVO 1TB,

Second drive Samsung950 Pro 512GB, notice this drive is slower.

First Win 10 installation both drive where enabled, HD drive LED Always on, blinking when Active. Strange behavior while booting NUC screen coming up several times, could take up to 25 s Before win screen coming up.

Reinstalled, Clean, Everything, only ​970 Active, Everything OK, boot time 7-10 s. Then enable 950 in bios, reboot, now boot time slower, HD LED on, blinking when HD Active.

WHY HD LED Always ON?

WHY boot time longer with 2 SSD enabled?

Could it be because they have different speed?

Thanks in advance

Allan

0 Kudos
7 Replies
SChau10
New Contributor II
269 Views

Your issue may be related to the Samsung 950 PRO 512GB SSD. I have this SSD and noticed some of my NUCs took extra long to recognize the 950 PRO during system power-up. I recently reformatted my 950 PRO from MBR to GPT for use with NUCs configured in UEFI mode (legacy disabled) and the delay during power-on appears to have gone away, so my guess is the 950 PRO may have some strangeness when used with MBR disk partitions and systems in legacy (BIOS emulation) mode.

 

I also noticed that different NVMe M.2 SSDs exhibit different HDD LED behavior when installed into the same system, especially with different blink rates during drive activity. When you have two M.2 SSDs installed, they will "co-drive" the single HDD LED, so if the two SSDs have significantly different HDD activity signal drive behavior, you may end up with unexpected HDD LED behavior, such as it being stuck on.

 

Also, Samsung has released updated firmware for the 950 PRO, so you may want to install this if you have not already done so. Not sure whether this will help your situation, though the 950 PRO does seem better behaved to me with GPT/UEFI than with MBR/legacy BIOS.

 

MLevi
Valued Contributor I
269 Views

What a great reply SChau10

 

APete10
Beginner
269 Views

Hi SChau10,

Thanks for prompt answer.

I have disabled the Pro disk, in Windows, to my understanding win 10 cannot se the disk, no change.

 

Then disable the Pro disk in bios, everything ok.

Do you think it realy Will help to reformat the disk despite it is empty, only containing 1 primary partition?

I will try, if you think it Will help, but I cannot understand, booting uefi would delay the boot process.

Allan

 

 

 

SChau10
New Contributor II
269 Views

If your 950 PRO SSD is currently empty, you may want to try converting it from MBR to GPT, to see if it can help with the boot delay.

 

In Win10, you can run a utility called MBR2GPT in an elevated command prompt:

 

mbr2gpt /disk:1 /validate /allowfullOS

 

If the validation is successful, then proceed with actual conversion:

 

mbr2gpt /disk:1 /convert /allowfullOS

 

Restarting the NUC should complete the process.

 

The above assumes your 950 PRO SSD is a secondary (non-boot) drive (D:), thus disk 1 as opposed to the other SSD being disk 0 (C:).

 

 

APete10
Beginner
269 Views

Hi again,

I ran the first command, but it failed.

Disk layout vallidation failed for disk1.

 

By accidentell I notice in disk properties:

samsung 970 disk 0: Bus Number 0, Target Id 0, LUN 0

samsung 950 disk 1: Bus Number 0, Target Id 0, LUN 0

Both disks are claimed to be working correct

Is this realy ok?

In my Other PC all disks have different ids.

Allan

 

 

 

 

 

SChau10
New Contributor II
269 Views

Hmmm, I'm not sure about those disk properties.

 

If you don't have any files on the 950 PRO SSD, you can do a clean format and make it a GPT disk.

 

I can't tell if your NUC is running in UEFI or legacy mode. If the latter, the procedure below will need to be preceded by converting your C: OS disk (970 EVO) from MBR to GPT (using MBR2GPT /Disk:0), restart, enter Visual BIOS with F2 key, reconfigure the NUC into UEFI mode (uncheck Legacy under Boot), boot back into Windows, then continue with the following.

 

I recommend using a combination of "diskpart" and "Disk Management" tools for this:

  1. Launch diskpart in an elevated (admin) Command Prompt
  2. At the diskpart prompt:
    1. select disk 1 (warning: disk 0 should be your 970 EVO SSD with Windows OS, so don't select disk 0 for wiping!)
    2. clean (this completely wipes all existing partitions)
    3. exit
  3. Launch "Disk Management" app (position mouse pointer at display bottom left corner, right-click and select "Disk Management")
  4. This app should immediately offer a choice of MBR or GPT for initializing disk 1. Select GPT.
  5. Right-click on the Disk 1 bar, select "New Simple Volume"
  6. Click "Next" on successive dialogs to create a primary partition on Disk 1

 

Once this 950 PRO has partition style set to GPT, you can restart Windows and see if the BIOS can detect it faster. Hopefully the "Intel NUC" logo will not stay on for 25 seconds before OS starts to boot (spinning dots).

 

APete10
Beginner
269 Views

Hi again,

The 950 is now onGPT.

But unfortunatly no change.

Still slow and HD Led always on.

A strange thing : After reboot, The HD Led was off until I started Explorer to see the properties of the 950, then always on again.

Thanks for your support, I will disable the disk for the moment.

An intresting option is of Course to format the 970 typ Gpt.

But first I Will investigate the bus Number , Target id and Lun

Thanks again for you help, I leran a lot

Allan

 

 

 

 

Reply