Community
cancel
Showing results for 
Search instead for 
Did you mean: 
fatjoezz
Beginner
115 Views

Intel Nuc 10 (nuc10i5FNH) USB-C & thunderbolt not working with extension cable (1m / 3Feet)

Upgraded from Intel Nuc 8 (i5) to Nuc 10 (i5).

Hardware fault in Nuc 10 only (works on Nuc

USB-C passive hub (0.15m cable - 0.45 feet)
DOES NOT WORK if used with USB-C passive extension cable 1metre (3 feet).

Both front USB C & back thunderbolt do not work.
Fault: Windows 10 error: Usb Device Descriptor (Device Manager)


TESTED:
updating drivers
deleting device
reinstalling
checking bios settings
disabling usb selective suspend in windows
disabling fast boot
FRESH INSTALL WINDOWS - SAME FAULT!
2nd usb c extension cable same length, brand, model

NONE OF ABOVE WORKED.

Tested hub+extension cable on a Dell XPS Laptop & IT WORKS.

USB device descriptor issue seems to be related to power issue.
Either a hardware (not enough power) /bios / driver issue.
Intel has changed something in nuc 10 and broken usb power.

Please advise any fix?
I read another fix to short the +postive & negative- pins on the AC adaptor socket to reset?

If there is no fix I will return this when Nuc 11 is released.

 

0 Kudos
7 Replies
fatjoezz
Beginner
110 Views

Error details from Device Manager.

Device USB\VID_0000&PID_0002\5&b5f8a98&1&7 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\ROOT_HUB30\4&2fbf7a17&0&0
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Location Path:
Migration Rank: 0xF000FFFFFFFFF102
Present: false
Status: 0xC0000719

---------------

Device USB\VID_0000&PID_0002\5&b5f8a98&1&7 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.19041.488
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\ROOT_HUB30\4&744a86e&0&0

---------------

Device USB\VID_0000&PID_0002\5&b5f8a98&1&7 had a problem starting.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Service:
Lower Filters:
Upper Filters:
Problem: 0x2B
Problem Status: 0x0

 

Victor_G_Intel
Moderator
100 Views

Hello fatjoezz,


Thank you for posting on the Intel® communities.


To better assist you please provide the following report and information to continue with your support request.


1-Please run the following tool and attach the report generated.  


-Intel® System Support Utility (Intel® SSU)


Download link: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

•          Open the application and click on "Scan" to see the system and device information

•          By default, Intel® SSU will take you to the "Summary View".  

•          Click on the menu where it says "Summary" to change to "Detailed View".  

•          To save your scan, click on "Next", then "Save".


* Use the option under the reply window to attach the report to the thread (Drag and drop here or browse files to attach).


2-Please provide the following information so we can have a better understanding of your issue. 


-When did you buy the NUC?


-When did the problem start to happen?


-Do you remember if this issue happened after a new OS update or driver update?


-Were you able to have a normal/expected performance before?


I look forward to hearing from you.


Regards,


Victor G.

Intel Technical Support Technician  


fatjoezz
Beginner
95 Views

Hi Victor

- New NUC one week old replacing an old Nuc 8 (i5).

- Started immediately when new

- Operating system: Windows (10 version 20H2 - 64Bit) and testing

- Previous Nuc 8 (i5) with same operating system & the extension cable+hub worked OK.

- Have tested installing Windows 10 operating system again fresh & it does not work.

Victor_G_Intel
Moderator
87 Views

Hello fatjoezz,


Thank you for posting on the Intel® communities.


Based on the information provided we would like you to try the following:


-Thunderbolt port:


1-Check the Thunderbolt option in BIOS:


-Press F2 during boot to enter BIOS Setup.

-Go to Advanced > Devices > Onboard Devices.

-Check that the Thunderbolt Controller is enabled.

-Press F10 to save and exit BIOS Setup.


Note: Use a certified Thunderbolt™ 3 cable. The length of the cable can also be a factor. Try one that's 60 cm or shorter.


2- Reinstall the latest thunderbolt driver


https://downloadcenter.intel.com/download/28735/Thunderbolt-3-DCH-Driver-for-Windows-10-for-Intel-NU...


How to install


Double-click Thunderbolt™ Software Installer.exe.


Note: The Thunderbolt Control Center should load automatically after the driver is installed and if you're connected to the Internet. If it doesn't, you can download it from this link: https://www.microsoft.com/en-us/p/thunderbolt-control-center/9n6f0jv38ph1


The Thunderbolt Control Center allows you to approve and manage Thunderbolt devices.


-USB type C


1- Complete a BIOS recovery


Instructions


https://www.intel.com/content/www/us/en/support/articles/000033291/intel-nuc.html


*There are two methods in the link above please try the power button menu one. If the problem persists, continue to next step.


Latest BIOS:


https://downloadcenter.intel.com/download/30073/BIOS-Update-FNCML357-


2- Restore BIOS factory defaults:


-Press F2 during boot to enter BIOS Setup.

-Press F9 to set factory defaults.

-Press F10 to save and exit BIOS Setup.


If none of the steps provided worked, please shared with us the exact brand and model of both the cable(s) and HUB(s) you have tested so we can check on our end a different approach for this situation.


I look forward to hearing from you.


Regards,


Victor G.

Intel Technical Support Technician


Victor_G_Intel
Moderator
67 Views

Hello fatjoezz,


Were you able to check the previous post?  


Please let me know if you need further assistance.  


Best regards,


Victor G. 

Intel Technical Support Technician


fatjoezz
Beginner
58 Views

Thanks Viktor but no the problem still exist.

Further details & actions done below:

  • updated to latest BIOS version 47
  • thunderbolt option ON in bios
  • installed latest thunderbolt driver
  • checked thunder bolt control centre. no devices showing
  • default bios setting

Cables / Hub

Cable: ALogic USB C Extension cable 1M

Hub: Promate PRIMEHUB-C (3x USB 3.0, 1x HDMI, 1x USB-C, LAN, SDCARD)

ALSO noticed during testing that all USB ports have significant issues as below

  • When connecting ANY usb device (eg a USB memory stick or USB keyboard receiver)
    There is an unusually long delay 10-15 seconds before device is recognised in Windows

    25 years using computers I never seen this until using Intel NUC

  • USB keyboard receiver does not work reliably.
    (Microsoft Sculpt Comfort)
    Keyboard key presses are missed randomly and keyboard slow to respond.
    Unplugging & replugging keyboard takes around 10-15 seconds for keyboard to respond.
    After that the same issue usually reoccurs or it will work for a while then randomly keypresses are missed.
    It is not specific keys, it is all keys, randomly being missed.

  • USB Memory sticks take around 10-15 seconds to become visible in windows after connecting.
    This includes already recognised & installed memory sticks being reconnected.
    Every single time, 10-15 second delay.

 

Nuc version: NUC10FNH

Product code: BXNUC10i5FNH4

Based on above I believe there is an issue with the USB / Power output on the NUC.

I suggest we warranty replace it and probably replace with 11th generation is a better idea.

Victor_G_Intel
Moderator
50 Views

Hello fatjoezz,

 

Thank you for posting on the Intel® communities.

 

We are deeply sorry to hear that our recommendations didn’t make any changes, in this case, based on the information provided and the troubleshooting completed, we consider that there is something wrong internally speaking with the NUC; therefore, our strongest recommendation will be that if you are within the first 30 days from the date of purchase for this unit, try contacting your place of purchase to check the warranty options for your system; otherwise, try contacting us directly to check what will be the warranty options available for your unit; feel free to refer to this post once you contact Intel Customer Support.

 

Here is our "contact us" information:

 

https://www.intel.com/content/www/us/en/support/contact-support.html#@7

 

We would recommend phone or chat support venues during your regular working hours.

 

 

Regards,

 

Victor G.

Intel Technical Support Technician