Intel® NUCs
Assistance in Intel® NUC products
All support for Intel® NUC 7 - 13 systems is transitioning to ASUS. Read more.
13487 Discussions

Intel nuc not working with Samsung UHD tv




Hi everyone.

first, apologies if this has already been answered - been hunting for a while and cant find an answer.


I have an intel Nuci5 running ubuntu 20.04.5LTS - had it hooked up to an old visio tv for a couple years and love having it as my media center.


just bought a new samsung Cristal uhd tv - hooked the intel nuc into HDMI port 1 with the same cable i have been using and nothing. the tv recognizes something is plugged in but when i select it, the tv tells me to check the power is on to the nuc.. which it is. 


I have swapped the hdmi cable back and forth to the old TV and it works fine. pops straight on.


I have tried connecting to the new TV while the nuc is powered off, then powering it on - still not working.


Unbuntu is upto date - i have tried every setting on the 'device manager'  on the TV, still nothing.


side note - I connected my macbook air with the same hdmi cable and nothing came up until i went into settings on the mac book and selected the samsung TV as the monitor then it popped up.


anyone got any ideas of what to try?


I REALLY don't want to go back to typing with a tv remote




0 Kudos
3 Replies
Super User

Which NUC i5?  There are only several dozen.


Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos

the nuc is model number D54250WYK.


you think trying with windows OS would work? i probably have an old version of windows laying about but im really not very good at this stuff so installing windows on the nuc will be a lot of effort and swearing.

0 Kudos

problem solved - I connected the intel nuc to the TV with a HDMI eARC cable - now its working. guess it was my standard HDMI cable that is too old for the new TV



Thanks for your help AlHill

0 Kudos