Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,627 Views

LibreELEC graphics error NUC 7PJYH

Hello,

I have graphics errors in the upper part of the screen. These are not available throughout. I have tried most LibreELEC builds. Everywhere the same mistake. Hardware Used:

NUC 7 PJYH -> Denon 1300H AVR -> Samsung UE70KU6079 TV

In the LibreELEC forum others have the same mistake.

Can this be eliminated by a Driver update or is it even your faulty hardware?

 

 

 

0 Kudos
16 Replies
Highlighted
Novice
248 Views

The intel support here will probably not now it again, since this is Linux........

Set i915.enable_fbc=0 as kernel parameter or set in /etc/modprobe.d/i915.conf will fix the issue.

This is caused by the intel kernel driver and will be hopefully fixed some day.

https://bugs.freedesktop.org/show_bug.cgi?id=108085

 

By the way. How is your playback experiance? Are all your videos smooth or do you see some micro stuttering or judder?

0 Kudos
Highlighted
Beginner
248 Views

Yes, the main issue is that the clock speed for the graphics chip needs the min frequency set or your get judder. Would be great to see this happen automatically.

0 Kudos
Highlighted
Beginner
248 Views

Hello,

the video playback is perfect. But in the menu it stutters. Whether 1080P 60Hz or 2160P 60Hz. can I manually set the GPU clock to a specific value?

 

0 Kudos
Highlighted
Novice
248 Views

Which GPU clock did you set manually and how? I tried intel gpu tools, but it does not seem to work. Just does not change anything. The gpu still goes down to 100MHz.

0 Kudos
Highlighted
Beginner
248 Views

On Libreelec I have this in autostart.sh

 

(

echo 400 > /sys/devices/pci0000:00/0000:00:02.0/drm/card0/gt_min_freq_mhz

) &

0 Kudos
Highlighted
Beginner
248 Views

Hello,

 

I'm sorry bothering you guys but I don't understand the fix you talked about in previous posts.

 

I use libreelec 9.0.1 and I'm still experiencing this "colored line" glitch on top of the screen. I tried to set i915.enable_fbc=0 but it doesn't change anything for me.

 

You say you use libreelec do you have the issue too?

 

Setting the min freq of the GPU doesn't solve the colored line issue, only the stutter, correct?

0 Kudos
Highlighted
Beginner
248 Views

Can you share your autostart.sh?

 

Also, how you configured the  i915.enable_fbc=0?

0 Kudos
Highlighted
Beginner
248 Views

I tried doing that:

 

echo "options i915 enable_fbc=0" >> /storage/.config/modprobe.d/i915.conf

 

Basically I added drivers options...but no luck.

 

Did I miss some steps?

 

Regarding the autostart.sh I didn't modify it already...

 

I can have a look this evening and give you the file content.

 

0 Kudos
Highlighted
Beginner
248 Views

I'm not sure of the correct way to add the fbc change. @KEgal​ how exactly did you add this so it works?

 

Since LibreElec 9 full release the autostart.sh I posted above no longer appears to work for stuttering. Anyone have it working?

0 Kudos
Highlighted
Novice
248 Views

I don't know about librelec, but on Manjaro or Ubuntu I just added i915.enable_fbc=0 as kernel parameter in /etc/default/grub and ran update-grub command.

If you add it to the driver config file, the syntax is a bit different.

In /etc/modprobe.d/i915.conf you can add

options i915 enable_fbc=0

 

You should do the one or the other. Not both.

 

See for example. https://wiki.archlinux.org/index.php/intel_graphics#Framebuffer_compression_(enable_fbc)

 

To the stuttering topic:

Setting the min frequency to 400 or any other frequency does not fix the stuttering for me. Disabling tripple buffering on KDE reduced it a little bit, but it's still there.

0 Kudos
Highlighted
Beginner
248 Views

Actually I added it to /etc/modprobe.d/i915.conf in libreelec.

 

The issue still seems to be there...

 

Somebody told me to run the following commande(see: https://bugs.freedesktop.org/show_bug.cgi?id=108085):

cat /sys/module/i915/parameters/enable_fbc

 

and the result is "1"...but I'm not clear about the result: does that mean that fbc is still activated?

 

If so I guess I need to ask on libreelec forum how I can force the init to take into account fbc...but I'm not sure...

 

If you have any knowledge regarding that result (the "1") I will be glad to know...then I will try to ask on libreelec forum...but currently I'm stuck...

 

Actually I'm not the only one to have this issue with libreelec:

https://forum.libreelec.tv/thread/12380-le-8-2-5-with-uhd-630-coffee-lake-gemini-lake-support-and-lu...

 

My knowledge are limited...but I guess that by asking the right people we will find a solution at some point... :-)

 

 

0 Kudos
Highlighted
Beginner
248 Views

I think you need the value in that file to be 0

0 Kudos
Highlighted
Beginner
248 Views

Hello,

 

Just to keep you informed following recommandation given by james in the following thread:

 

https://bugs.freedesktop.org/show_bug.cgi?id=108085

 

I checked if fbc was still activated despite me creating the driver option file...and it is not.

 

I guess some additional actions are required with libreelec.

 

I posted my udpate on libreelec forum to see how I can force the option.

 

I will keep you guys updated if we find a solution so that it can help somebody else in the future.

 

Thanks for your help in any case. :-)

0 Kudos
Highlighted
Beginner
248 Views

OK so after checking on libreelec forum the only way with libreelec to solve the issue is to add the option to one of those three file (depending on your installation:

 

/flash/EFI/BOOT/syslinux.cfg, /flash/syslinux.cfg or /flash/extlinux.cfg

 

Just before "quiet".

 

This fix works fine but creating the i915.conf doesn't work with this specific distribution.

0 Kudos
Highlighted
Beginner
248 Views

Could you post the file above after you made the update?

 

Not clear it it's add "options i915 enable_fbc=0" before quiet or "enable_fbc=0" before quiet.

0 Kudos
Highlighted
Beginner
248 Views

Hello you have to put "i915.enable_fbc=0" before quiet.

0 Kudos