Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CellCulSel
Beginner
3,719 Views

Likely BIOS bug, refuses to boot from USB key automatically . Bean Canyon NUC8i5BEH.

Jump to solution

Good morning,

 

I believe I've found a minor but very frustrating boot order / booting bug with the BIOS for the Bean Canyon i5.  (NUC8i5BEH)

 

I have the latest BIOS, which seems to be 2.2.23

It refuses to boot /automatically/ from a USB key in the device, it spits out an error "A bootable device has not been detected"

 

If I reboot, F10 and /manually/ choose the device, it will boot from it.

 

I have configured the boot order to definitely have the USB Key as #1

I have disabled UEFI boot.

In desperation, I have disabled my SATA and M.2 devices.

I have ticked boot USB devices first.

I have disabled network booting.

 

Please see the photos which make it very apparent.

https://i.imgur.com/zTQ7ztE.png

https://i.imgur.com/6PT9DcT.png

Especially this photo

https://i.imgur.com/SEng9f7.png

 

 

This is a pretty critical issue, because I can NEVER reboot my NUC, without being at the device to press F10 and chose the key again

 

Again, to make it clear:

I disabled so many boot devices in that last pic, there's only 1 boot option, the key.

It STILL wont' boot from this, unless I intervene, press F10, manually select it.

 

Surely, surely this is not intended behaviour?

0 Kudos
1 Solution
SChau10
New Contributor II
1,822 Views

My NUC8i7BEH with 0056 BIOS has no issues booting Windows To Go (Win10 Enterprise) OS from a USB storage device (mSATA SSD in Apricorn mSATA Wire enclosure) in either Legacy or UEFI mode. When Legacy is enabled in Visual BIOS, Win10 boots in legacy mode. When UEFI is enabled and Legacy is disabled, Win10 boots in UEFI mode. "Boot USB devices first" is enabled under Boot Configuration and "USB Legacy" is enabled under the USB tab. I did not need to press F10 to bring up the boot device menu to get Win10 to boot from this external USB storage. I just plugged in this USB drive and pressed the power button to turn unit on. I also have another USB drive set up to boot WinPE and it also works fine in either UEFI or Legacy mode.

 

All indications suggest the NUC BIOS is capable of properly detecting and starting OS bootup with bootable USB devices, in either UEFI or Legacy mode.

 

@CellCulSel, it's starting to look like your issue has something to do with how your USB key was set up to be bootable, and the NUC BIOS is unable to automatically detect this drive as being bootable. What is the brand & model of your USB key?

 

View solution in original post

20 Replies
Leonardo_C_Intel
Moderator
1,822 Views
Hello CellCulSel Thank you for posting in the Intel Community. Bear in mind that when no bootable disk or USB device is found, the system will default to network boot. • Does the USB have a bootable operating system (OS)? If yes: o What OS is it? o What format does the USB key has UEFI or fat? o What tool was used to create the bootable device? Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Hi Leo,

 

Please read the original post in full and look at the screenshots.

The USB is bootable, linux (LibreElec)

The USB boots when I press F10 and manually select it. The key IS not only bootable, it BOOTS on the NUC, only if I manually select it.

 

It will not automatically boot from the key though, it requires intervention with F10.

 

Leonardo_C_Intel
Moderator
1,822 Views
Hello CellCulSel Thank you for the information. Allow me to share with you that I have successfully tried to boot automatically form a Intel® NUC Kit NUC8i7BEH from a Bootable USB key with Windows® 10; in the BIOS settings I enable the following: • Go to the boot tab. o Boot configuration.  Under UEFI boot. • Enable: boot form USB device first.  Boot devices. • Enable USB. Use F10 to save and exit. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Leo:

 

A video says 1000 words.

 

https://www.dropbox.com/s/s0h26sx0lq842of/Intel%20NUC.mp4?dl=0

 

Bootable key, machine set to boot from USB, machine set to boot legacy, key, I believe is Legacy. System CAN boot from key manually.

System CAN'T boot from key automatically. NOTE THE AUTOMATICALLY. I can never run my OS off this key.

 

 

Leonardo_C_Intel
Moderator
1,822 Views
Hello CellCulSel Thank you for the information. We support USB bootable devices with UEFI mode, but not with the Legacy mode, as I saw on your video that you have enabled. We will do some research to see if there is a workaround. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Hi Leo,

 

Based on the video and the logic / wording of the BIOS, it's certainly not clear, that the system won't boot from Legacy - it's available to be ticked and the device is listed, as you saw.

I won't go as far to say it's an outright bug, but the system is capable, yet unwilling to boot from the desired boot order, that can and is defined in the BIOS.

 

I would imagine, rectifying this, wouldn't be too difficult, all things considered.

 

I've also discussed this, with an online reviewer of a pretty well known hardware site, he's expressed disappointment in the same issue, so clearly I'm not the only one impacted by this.

Appreciate your time, let me know if you need more information / diagnostics etc.

 

 

Patricia_S_Intel
Employee
1,822 Views
Hello CellCulSel, We are researching this and will get back to you soon. In the meantime, can you confirm the BIOS version you are using or have tested? We need the four digits after 86A [BECFL357.86A.####] https://downloadcenter.intel.com/download/28394/?product=126148 Thank you, Pat S. Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

I'll check this evening, but I have the latest bios as per the Windows based "Intel Driver & Support Assistant tray" of 1 week ago.

 

BIOS was flashed and updated upon purchase of the devices approx 3 weeks ago.

 

CellCulSel
Beginner
1,822 Views

Took a snap this morning.

 

BECFL357.86A.0056.2018.1128.1717

Patricia_S_Intel
Employee
1,822 Views
Hello CellCulSel, I just tested the different boot modes with the Intel® NUC Kit NUC8i7BEH with a bootable USB thumb drive with Ubuntu and it worked. Configuration: Intel® NUC Kit NUC8i7BEH BIOS 0056 Kingston Data Traveler 3.0 USB drive with Ubuntu 17.04 The BIOS settings were: Advanced > Boot > Boot Priority > UEFI Boot Priority (left side) > UEFI Boot = unchecked Legacy Boot Priority (right side) > Legacy Boot = checked Legacy Boot Priority (right side) > Boot Drive Order = moved bootable USB device to the top (click and drag). The USB device should be connected to the unit before entering the BIOS or it may not be detected. I recommend loading the BIOS defaults, Save and Exit and then re-enter BIOS to make the settings. Can you confirm the settings and BIOS and let us know how it goes? Regards, Pat S. Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Can you confirm it worked, without an F10, automatically booting or it required F10 intervention?

Key is permanently plugged in. (rear top port)

MRoss5200
New Contributor III
1,822 Views

Try doing a low-level (slow) format of your USB drive. There has been issues with USB drives not being detected properly if they are fast formatted. If you are booting a Legacy OS, make sure it is formatted as FAT32 and MBR. I use Rufus to format my USB drives.

 

When you created your boot drive, did you use the LibreElec USB creator tool? Under Select Version, did you select Generic Intel install?

 

I tried it on my i7 BE with BIOS 0051 using this tool with a USB 3.0 Kingston 16GB flash drive and it boot first fine. I even used the same settings you used.

CellCulSel
Beginner
1,822 Views

This is literally, a bootable key, when manually selected. There is nothing wrong with the key, please watch the video earlier on to see what the issue is.

 

Yes, I used generic, the key is fine, the BIOS refuses to boot from it automatically, only manually.

Patricia_S_Intel
Employee
1,822 Views
Hello S L, We have tested it multiple times with different BIOS versions and units (BEH & BEK) and we have not been able to replicate the issue that your unit is having. Just to confirm, what is the exact OS version/flavor and revision you are testing on the USB key? If you feel the unit is defective, I recommend you to contact Intel Customer Support for your region via Phone, Live Chat or via an Online Service Request for the warranty options. https://www.intel.com/content/www/us/en/support/contact-support.html#@6 If you have the same issue after a warranty replacement, then you will need to recheck at your configuration (BIOS settings, thumb drive, OS ISO/boot, etc.) since that is more than likely what is causing the issue. Regards, Pat S Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Hi Pat,

 

Here is an exact link to the software.

http://releases.libreelec.tv/LibreELEC-Generic.x86_64-9.0.0.img.gz

A very common piece of HTPC software running on top of Linux - infact these guys literally show a picture of the NUC on the website.

https://libreelec.tv/downloads_new/generic-pc/

 

I wrote the image using the very common win32diskimager.

https://sourceforge.net/projects/win32diskimager/

 

Are you suggesting you managed to boot from USB key AUTOMATICALLY without intervention, in Legacy mode?

You still have not clarified, the ability to _automatically boot_ from the source without pressing F10? Are you pressing F10 or no?

 

 

Patricia_S_Intel
Employee
1,822 Views
Hello S L, Yes, we successfully booted with a different USB thumb drives with different Ubuntu versions (16.04 & 17.04) and different BIOS versions (0041 & 0056) on different units of the Intel® NUC Kit NUC8i5BEH. However, we used RUFUS with the default/generic settings to create the bootable Ubuntu media. Below I provided BIOS settings we used. If you are still having issues, it may be an issue with the USB key, image or how you are creating it. Have you tried the instructions on this page to create the bootable USB with Win32 Disk Imager? iso2usb > Win32DiskImager makes an Ubuntu family USB boot drive in Windows https://wiki.ubuntu.com/Win32DiskImager/iso2usb Since we have not validated LibreELEC/Kobi, have you tried to contact them for support? Here is the link to Kodi forums: https://forum.kodi.tv/forumdisplay.php?fid=111 From our side, are you using a genuine Intel product? Can you provide the SA # and BIOS string? Identify Your Intel® NUC https://www.intel.com/content/www/us/en/support/articles/000005804/mini-pcs.html Identify BIOS Version on Intel® NUC https://www.intel.com/content/www/us/en/support/articles/000023777/mini-pcs.html If you have Windows or Linux installed on a drive on the unit, you can provide us the SSU report instead: Downloads for Intel® System Support Utility https://downloadcenter.intel.com/product/91600/Intel-System-Support-Utility BIOS Settings: 1. Advanced > Boot > Boot Priority > * UEFI Boot Priority (left side) > UEFI Boot = unchecked * Legacy Boot Priority (right side) > Legacy Boot = checked * Legacy Boot Priority (right side) > Boot Drive Order = if detected, move to the top (click and drag). 2. Advanced > Boot > Boot Configuration > * * UEFI Boot > Fast Boot = unchecked * UEFI Boot > Boot USB Devices First = checked 3. Advanced > Boot > Secure Boot > ** Secure Boot Config > Secure Boot = unchecked * These settings should not matter if UEFI is disabled, but confirm the settings. ** Secure Boot should uncheck automatically if Legacy mode is enabled Regards, Pat S Intel Customer Support Technician Under Contract to Intel Corporation
CellCulSel
Beginner
1,822 Views

Pat..

You​ still haven't answered my question.

Did​ you boot WITHOUT pressing F10.

There​ is a very good chance we're talking about two different things.

Patricia_S_Intel
Employee
1,822 Views
Hello S L, I apologize if I was not clear. We did not need to use F10 to boot. When we powered/retarted the NUC with the USB thumb drive connected that had the Ubuntu image on it, it went directly to the Ubuntu installation. Regards, Pat S Intel Customer Support Technician Under Contract to Intel Corporation
SChau10
New Contributor II
1,823 Views

My NUC8i7BEH with 0056 BIOS has no issues booting Windows To Go (Win10 Enterprise) OS from a USB storage device (mSATA SSD in Apricorn mSATA Wire enclosure) in either Legacy or UEFI mode. When Legacy is enabled in Visual BIOS, Win10 boots in legacy mode. When UEFI is enabled and Legacy is disabled, Win10 boots in UEFI mode. "Boot USB devices first" is enabled under Boot Configuration and "USB Legacy" is enabled under the USB tab. I did not need to press F10 to bring up the boot device menu to get Win10 to boot from this external USB storage. I just plugged in this USB drive and pressed the power button to turn unit on. I also have another USB drive set up to boot WinPE and it also works fine in either UEFI or Legacy mode.

 

All indications suggest the NUC BIOS is capable of properly detecting and starting OS bootup with bootable USB devices, in either UEFI or Legacy mode.

 

@CellCulSel, it's starting to look like your issue has something to do with how your USB key was set up to be bootable, and the NUC BIOS is unable to automatically detect this drive as being bootable. What is the brand & model of your USB key?

 

View solution in original post

Patricia_S_Intel
Employee
257 Views
Hello cellCulSel, Did you have additional questions or doubts about the feedback provided? Let us know. Regards, Pat S Intel Customer Support Technician Under Contract to Intel Corporation
Reply