Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Ollie75
Beginner
154 Views

Multiple monitors not detected after reboot

Hello,

I am running a NUC10i7FNB, version K61360-303, with Windows 10 Professional 64-bit with all the latest and greatest updates and drivers for both Intel and Windows at the time of writing.

Recently my multiple monitor setup started to act up. I guess this has started after the latest Intel driver update but I am not 100% sure.

There are two monitors connected to the USB-C/Thunderbolt port via an A-Konic 4K HDMI hub. Normally the desktop is extended across these two monitors.

Whenever the NUC needs a reboot only 1 monitor is detected and the display is copied onto the two screens. Neither the Windows driver nor the Intel display configurator is able to detect two different monitors anymore.

Another reboot or even shutdown and boot makes no difference.

However, and this is the kicker, when the NUC is shutdown and the power taken off and re-applied then presto, two monitors are automatically detected and the display is extended as I want it to be.

I have tried uninstalling and reinstalling graphics drivers but this does not seem to make a difference.

Does anyone have any idea what might be causing this?

Thank you

Labels (2)
0 Kudos
6 Replies
Victor_G_Intel
Moderator
129 Views

Hello Ollie75,

 

Thank you for posting on the Intel® communities.

 

To better assist you please provide the following report and information.

 

Intel® System Support Utility (Intel® SSU)

 

Download link: https://downloadcenter.intel.com/download/25293/Intel-System-Support Utility-for-Windows-

 

  • Open the application and click on "Scan" to see the system and device information
  • By default, Intel® SSU will take you to the "Summary View".  
  • Click on the menu where it says "Summary" to change to "Detailed View".  
  • To save your scan, click on "Next", then "Save". 

 

Note: You can use the option under the reply window to attach the report and any other files to the thread (Drag and drop here or browse files to attach)

 

  1. Did you test the NUC with only straight-through connections (One cable for each display) without using the HUB? If yes, does the issue persists?
  2. Have you test the NUC with a different HUB or check if the HUB’s manufacturer has any update for it?
  3. Please provide the model and brand of your monitors.

 

 

I look forward to hearing from you.

 

Regards,

 

Victor G.

Intel Technical Support Technician

 

Ollie75
Beginner
116 Views

Hi Victor,

First of all thank you for replying and looking into this.

I have attached the system scan as requested.

To answer your questions;

1. I cannot use the USB-C port without the HUB, as my monitors do not have a USB-C connector. What I have tried is to hook up 1 monitor with the HUB and the other straight to the embedded HDMI connector. Then this problem does not occur.

2. I do not have another HUB (yet) to test with. There does not seem to be an updated driver (or any particular driver for that matter) available for this HUB but I have contacted the manufacturer (A-Konic) to look into this as well. I am waiting for their reply.

3.The monitors are Samsung Syncmaster P2770.

 

One would think that the HUB is acting up here but the thing is that it has been working flawlessly before.

Best regards,

Victor_G_Intel
Moderator
106 Views

Hello Ollie75,

 

Thank you for posting on the Intel® communities.


We appreciate the information that you have provided. When it comes to problems like this it is very important to know that the use of any adapters, converters, docking stations, and HUBs are not fully validated on our end when it comes to setting up two or even three displays, what we recommend when it comes to this issues is to test the NUC with straight-through connections only since that is how we have validated that the NUC can take for example a dual display setup. Even though the HUB has worked before doesn’t mean that it can’t give you issues now; however, and fortunately, as you mentioned if you use the HUB with only one monitor and then use the NUC’s HDMI port this problem does not occur.


Our recommendations for this issue will be the following:


1-Reinstall the latest thunderbolt driver


How to install


Double-click Thunderbolt™ Software Installer.exe.


Note: The Thunderbolt Control Center should load automatically after the driver is installed and if you're connected to the Internet. If it doesn't, you can download it from this link.


  • The Thunderbolt Control Center allows you to approve and manage Thunderbolt devices.


2-Reinstall the USB Type C Power Delivery Controller


Note: If you need help installing this driver, see How to Install a Driver without a .exe File.


3-Please try the following graphics driver by performing a clean installation of it and let us know if the issue persists


Version: 27.20.100.9316


Clean Installation intructions


4-Complete a BIOS recovery


Instructions


Note: There are two methods in the link above please try the power button menu one. If the problem persists, continue to the next step.

 

Latest BIOS

 

5-Restore BIOS factory defaults


  • Press F2 during boot to enter BIOS Setup.
  • Press F9 to set factory defaults.
  • Press F10 to save and exit BIOS Setup.

 

I look forward to hearing from you.

 

Regards,

 

Victor G.

Intel Technical Support Technician  


n_scott_pearson
Super User Retired Employee
99 Views

Are you sure that this isn't simply a case of the MST Hub device starting to fail? Your 'kicker' case simply says to me that you repowered the adapter and it happens to work after doing so (whether consistent or not). I would try replacing this adapter and see if this addresses the issue.

Hope this helps,

...S

Victor_G_Intel
Moderator
42 Views

Hello Ollie75,


Were you able to check the previous post?  


Please let me know if you need further assistance.  


Best regards,


Victor G. 

Intel Technical Support Technician


Victor_G_Intel
Moderator
25 Views

Hello Ollie75,


We have not heard back from you.


If you need any additional information, please submit a new question as this thread will no longer be monitored.


Victor G. 

Intel Technical Support Technician


Reply