Intel® NUCs
Support for Intel® NUC products
12506 Discussions

NUC 10i7FNH ram issues

Peti
Beginner
101 Views

Morning 

folks, I hope it's ok if I start a new thread for this one. I have got a new NUC which I was planning to use for music playback through JRiver.

 

Anyhoodle, ever since I inserted the ram disks and fired it up, it has been been giving me issues, namely, freezing up, blue death and sometimes the dreaded blue death loop.

 

Checked the ram disks and win10 says my ram is faulty but gave no explanation. I have ordered a new set of appropriate ram disks and I'm getting the same issue. Did clean install, same results.

 

As soon as win10 boots and I start to use it, stuttering of the mouse starts and it intensifies until the point the monitor freezes or getting blue death. The blue death error message is not the same all the time though. If I tax the ram modules by opening and running sundry programs at the same time, the freezing occurs a bit even earlier than if I just let the machine idle.

 

I noticed if I only insert one ram disc the inevitable freezing/blue death occurs later. If both discs are inserted, things get bad really fast.

 

Updated all the drivers and bios, no change. I'm admittedly not a computer expert and I wonder if the community has any ideas what's going on in my NUC? Thank you in advance!

 

P.S.: That's the ram I have purchased: https://www.amazon.com/dp/B08C4Z69LN?psc=1&ref=ppx_yo2ov_dt_b_product_details

0 Kudos
3 Replies
AlHill
Super User
97 Views

Try compatible memory as listed here:

https://compatibleproducts.intel.com/ProductDetails?EPMID=188811

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

Peti
Beginner
81 Views

Thank you. I was lead to believe that the ram I purchased is indeed compatible with my NUC. Just tried to run the computer in safe mode and it has been working flawlessly for hours now. In the device manager I see all the drivers updated. I'm dumbfounded.

LeonWaksman
Super User
73 Views

Hello @Peti 

1. Although the Crucial CT8G4SFRA32A you bought wasn't validated by Intel for your NUC, it was validated by Crucial. So, not memory incompatibility is causing this problem. It can be hardware failure in your NUC as well or some problem in software installation. 

2. I understand that you tried to run with one SO DIMM only. Did you tried both SO DIMMS separately, testing each memory module in each memory slot?

3. Please reset your BIOS to default settings. Enter BIOS by pressing on F2 when you see the Intel NUC logo after power ON. Click on F9, followed by "Y" and then F10, followed by "Y" to save the default settings and exit from BIOS.

4. Did you updated all drivers and BIOS manually or by means of Intel Driver & Support Application (IDSA). If the IDSA was used, did you downloaded and manually installed the Chipset Device Software before installing any other device drivers?

 

Leon

 

Reply