Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11282 Discussions

NUC 6i7KYK Bios update

parkbenchbruce
Beginner
250 Views

Hi,

I had my lovely NUC running Windows 10 for a few months and decided to update Bios. It was going from the 2016 to 2020 (version 9/9/2020). I went to https://downloadcenter.intel.com/download/29887/BIOS-Update-KYSKLi70-86A- downloaded new Bios bio file flashed it F7 (did this many times in the past) then reboot.

Error message missing windows/system32/winloader.exe. I then tried to Repair the boot sequence (I figured the boot had been corrupted). I found the Recovery section to create a usb recovery boot. I went to repair via command prompt using bootrec/fixmbr, (successful) bootrec/fixboot (not found) and bootrec/rebuildbcd (successful).

No luck. I wondered if my SSD had a problem Samsung 860 EVO. I am about to try Samsung magician but was going to restore old bios which I have not been able to find.

I will update this as I troubleshoot the problem.

Thanks in advance,

 

0 Kudos
3 Replies
parkbenchbruce
Beginner
236 Views

Hi,

I took a recovery usb from an Asus laptop and installed Windows 8 (original os) on Nuc. I then went to connect to internet as the drivers were not recognised. I then went to get the bundled drivers from Intel for the NUC. https://downloadcenter.intel.com/product/89187/

Tried three times each showed an error with download. I need to get correct drivers to talk to the internet to run the Samsung Magician plus upgrade to Windows 10. 

Each step seems to present new problems

n_scott_pearson
Super User Retired Employee
222 Views

That All-Drivers package is a pretty big download. If you are not in North America, I recommend that you download the packages one at a time. The other option is to install the Intel Driver and Support Assistant (IDSA) and have it manage it for you.

Hope this helps,

...S

parkbenchbruce
Beginner
213 Views

Scott,

Thanks. I usually download large files in Australia without any problems with checksum and I was worried that it was tampered with - I teach cybersecurity. I now have Windows 10 operational on the NUC.

I did make a mistake when I downloaded the wifi driver (yes I did it case by case) as I went straight to the Windows 10 version. No good it wanted the Windows 8 version which was further down on the list. 

One trick was to do a reset to default settings F9.  Not sure if it worked but always reset to factory.

Now here is the interesting thing. The Bios is the 9/9/2020 version happily working with Windows 10. I visualise it as Win 10 block on top of another Bios block. When I first changed the bios the mbr was broken and hard to repair. Always do bios updates first was my rule of thumb for many years.

All good - time to close

Reply