Showing results for 
Search instead for 
Did you mean: 

NUC 7i7BNH not booting from USB

Intel NUC Kit Mini PC (Intel i7-7567U, 32GB RAM, Intel 512GB NVMe SSD + 1TB HDD

BIOS version 60

Windows came installed, boots and runs that fine.

I can't get it to generally boot off a USB stick.

I have loaded a standard Ubuntu OS on 3 different sticks (USB2, USB3 and USBC). All three can boot on another PC as a test case, so all three are good images.

I have tried booting each of the three units from all four of the USB slots, using a wired keyboard in another USB slot. Using F10/Select, it merely flashes the screen and returns to the screen unchanged. If I move the USB slot to the top of the boot order in BIOS, it just skips it and boots to the windows partition.

I'm take out first the HDD, then both the HDD and the NVMe SDD, and get the same results.

Sorta by accident (cue X files music) I had a USB key in the rear slot and one in the front (both with an Ubuntu install iso image) and it actually booted to ubuntu install image. I swapped locations of the two sticks and it skipped them. I swapped back, laid out Ubuntu over windows, so that worked, I can boot to Unbuntu

What I really wanted (and how I got here) was to install a IMG -- so with the voodoo of stick placement and having multiple present, I attempted to boot a image, but it never recognizes it and boots to the main disk.

I'm ready to pack it up and return it -- even the weirdness with what does and does not boot is nuts, so something seems really wrong. But I thought I would ask here first, perhaps someone has some insight.

Tags (1)
0 Kudos
1 Reply
Community Manager

Have you enabled legacy boot? If legacy boot is off and the USB is non UEFI you won't be able to boot from it.