Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,303 Views

NUC DE3815TYKH won't shutdown with Ubuntu 15.10

Jump to solution

When I press the power button or shutdown from the command line, the device starts shutting down but hangs at the line "Reached target shutdown". I have to hold the power button for 5 seconds to get it to reset. This is with firmware TYBYT10H.86A.0046.2015.1014.1057. Any suggestions? I've tried messing around with kernel acpi options but none of them seemed to help.

0 Kudos

Accepted Solutions
Highlighted
New Contributor I
74 Views

I reported this same defect 5 months ago, and after all this time support's first reaction as usual was still to blame the OS. Unbelievable! It is not a driver bug, you will find this defect is not present when using an earlier BIOS. I find disabling USB 3.0 to be a completely unacceptable "workaround".

View solution in original post

0 Kudos
7 Replies
Highlighted
74 Views

Hello, laner:

Thank you for contacting the Intel Communities.

As per my research on the error, I was able to find out this is happening in different systems from different brands.

And also it seems like it is a reported bug from the OS.

My recommendation would be to visit the OS' forums to find a possible solution for the bug in the OS.

https://lists.ubuntu.com/archives/foundations-bugs/2015-November/258798.html [Bug 1464917] Re: reboot hangs at 'Reached target Shutdown'

https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1464917 Bug # 1464917 "reboot hangs at 'Reached target Shutdown'" : Bugs : systemd package : Ubuntu

http://askubuntu.com/questions/620132/laptop-doesnt-shut-down-lubuntu-15-04 shutdown - Laptop doesn't shut down - Lubuntu 15.04 - Ask Ubuntu

If you require any further information or support, feel free to contact us back.

Regards,

Esteban C

0 Kudos
Highlighted
Beginner
74 Views

Thanks Esteban.

0 Kudos
Highlighted
Beginner
74 Views

Interestingly, if I go into the BIOS and change Boot Configuration -> UEFI Boot -> OS Selection from "Linux" to "Windows 8.x/Windows 10" then power down works properly under Linux!

Any idea what that setting actually changes?

0 Kudos
Highlighted
Beginner
74 Views

Found a solution! Disabling Devices and Peripherals -> USB -> USB Configuration -> XHCI Mode did the trick. I guess there is a bug in the linux xhci driver...

0 Kudos
Highlighted
74 Views

Hello, laner:

Thank you for providing your outcome and workaround for this scenario, it will help other peers having this scenario for sure.

If you require any further or future information/support, feel free to contact us back.

Regards,

Esteban C

0 Kudos
Highlighted
New Contributor I
75 Views

I reported this same defect 5 months ago, and after all this time support's first reaction as usual was still to blame the OS. Unbelievable! It is not a driver bug, you will find this defect is not present when using an earlier BIOS. I find disabling USB 3.0 to be a completely unacceptable "workaround".

View solution in original post

0 Kudos
Highlighted
Beginner
74 Views

I know what you're saying. Fortunately we're only using the nuc as an interim solution - the AMD-based Fujitsu S720 on my desk is a lot quicker!

0 Kudos