Intel® NUCs
Support for Intel® NUC products
12336 Discussions

NUC Kit NUC6CAYH: F2 key does not work at system start

Berecz
Beginner
707 Views

USB keyboard: Logitec K200
When I press the F2 key at system start the NUC does not react at all.
How can I overcome this problem?

Labels (1)
0 Kudos
9 Replies
n_scott_pearson
Super User Retired Employee
696 Views

Many Logitech keyboards support alternate functions on the F keys. You have to hold down the FN key to activate the send of the original F key scan codes. Unfortunately, all of the portable keyboards I have are 400 series, not 200 series, so I do not know if this applies. Still, it's something to check...

...S

Berecz
Beginner
625 Views

My USB keyboard Logitec K200 works perfectly when Windows is already running.
Is it possible that the key scan codes are different while the prompts for F2, F7 and F10 key are displayed at system start?

LeonWaksman
Super User
688 Views

Hi @Berecz 

Your keyboard is disabled during boot since probably you have enabled Fast Boot option in BIOS. In order to disable Fast boot:

1. While NUC is OFF, press and hold the Power Button until the system beeps.

2. If the above will not work, disable Fast Boot from the Power Button Menu:

  2.1 While NUC is OFF, press and hold the Power Button for about three seconds count 1001, 1002, 1003, 1004 and release the Power Button. NUC will boot into Power Button Menu.

  2.2 In Power Button Menu press F3 to Disable Fast Boot. 

 

Leon

 

Berecz
Beginner
623 Views

Hi @leon

I tried all your suggestions, unfortunately none of them worked.
My USB keyboard Logitec K200 works perfectly when Windows is already running.
Is it possible that the key scan codes are different while the prompts for F2, F7 and F10 key are displayed at system start?

LeonWaksman
Super User
601 Views

Hu @Berecz 

"Is it possible that the key scan codes are different....?" The codes are the same. There must be an other reason for this problem.

Leon

 

LeonWaksman
Super User
685 Views

Hi @Berecz 

An other reason for your problem, may be that the BIOS Security Jumper is installed in locked position (between pins 2-3 instead 1-2). Please refer to page 50 - 51 in the Technical Product Specification

 

Leon

 

Berecz
Beginner
618 Views

Hi @leon

The BIOS Security Jumper is certainly not installed in locked position (between pins 2-3 instead 1-2).
According to page 50 - 51 in the Technical Product Specification this would mean:
'All POST Hotkeys are suppressed prompts are not displayed and keys are not accepted. For example, F2 for Setup, F10 for the Boot Menu'.
But the All POST Hotkeys prompts are displayed.

LeonWaksman
Super User
599 Views

Hi @Berecz 

I agree that if you can see the F2, F7, F10 labels during power ON, the jumper is in NORMAL position. According to your previous answer, you also entered the Power Button Menu and verified that there is no Fast Boot disabled.

The reason with comes on my mind now, for wired keyboard not reacting during boot may be:

1. The USB ports are set in BIOS to "Not detect" instead of "Enabled"

or

2. Your keyboard is connected trough some USB hub with this problem.

This is my advice to do next:

1. Connect your keyboard  to rear USB port (same for mouse, if you are using wired mouse). Connect this devices directly to the rear port. Do not use HUB.

2. While in Windows, hold Shift key and click on Restart (in Windows Power). Release the Shift key, NUC will restart into "Choose an option" menu.

3. Click Troubleshoot.

4. Click Advanced options

5. Click on UEFI Firmware Settings.

6. Click on Restart. NUC will enter BIOS.

7. Check in Advanced > Devices > USB that the USB ports are set to Enabled.

8. If the keyboard works now, click on F9, confirmed by "Y" (default settings) and then F10 (Y), to save the settings and exit to Windows.

9. Check.

Leon

 

 

n_scott_pearson
Super User Retired Employee
606 Views

The other possibility to look at is whether Fast Boot has been enabled in the BIOS. In this case, the keyboard would be ignored completely during BIOS POST. To see if this is the case, power on holding the power button in/down for a full three seconds. After a short time, the Power Button Menu should be displayed. As indicated in the menu, pressing F2 at this point should get you into BIOS Setup. If it works, go to Advanced and then Boot and check if Fast Boot has been enabled.

If this doesn't work, all I can suggest is to try moving the dongle to different USB ports.

Hope this helps,

...S

Reply