Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12749 Discussions

NUC NUC11TNHi7 -- Unable to access AMT via BIOS


Hi folks:


I just bought a NUC11TNHi7 and I'm unable to access the AMT menu.   I've updated the BIOS to the current version and I've tried doing CTRL-P with a couple of different keyboards pressing it constantly from the instant it powers on with no luck.   I've also tried it with caps-lock and by doing CTRL-SHIFT-P, none of which work.   I've tried resetting the bios to the default values (F9) and also turning on Expansion Card Text, per some other threads.   The BIOS info screen indicates that Management Extension is there, so I'm sort of stuck at this point.   I paid extra for this model explicitly because of the AMT, so if I can't get it to work I'll need to return it.


BIOS Info ScreenBIOS Info Screen

0 Kudos
1 Reply

Hello srwsol,

Thank you for posting on the Intel️® communities.  

We understand you have opened an email ticket with us and we will continue to help you through that channel now. We will therefore close this community case. Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  

Best regards

Jean O.  

Intel Customer Support Technician