Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11299 Discussions

NUC i7 10710 doesn't boost over 3,9 GHz

drsp
Beginner
620 Views

Hello,

with single thread load I'd expect to run my NUC at 4,7 GHz.
But it clocks only 3,9 GHz on all cores.

I'm running Ubuntu 20.04.

I've disable the buggy port flooding interrupts as in this post:
https://community.intel.com/t5/Intel-NUCs/NUC10i3-IRQ-problem/td-p/669863
with modprobe -r tps6598x

When the program terminates all cores are reduced to 800 MHz.

Somehow the clock speed of all cores seems be synchronized.
Is this the intended behavior?
How can I fix it?

Thanks, Ingo

 

0 Kudos
16 Replies
Davidfi01
New Contributor I
606 Views

I've seen the same thing and asked intel to provide optimized bios settings.  Basically, was told to use defaults (f9) and high performance under power ....

 

D

JUSTIN_W_Intel
Employee
595 Views

Hi drsp,
I'm not 100% sure either of these will solve your problem, but I found these threads that I think matches your needs. This one describes how to Lock CPU frequency and this one on Setting CPU frequency.
I have not tried them myself yet, but I'll see if either one works on one of my systems.
Hope this helps,
Justin Wright (#iamintel)

JUSTIN_W_Intel
Employee
568 Views

I also found this thread that seems to address your issue directly:

https://community.intel.com/t5/Intel-NUCs/NUC10i7FNH-never-reaches-its-specified-frequency-of-4-7-GH...

After setting it to "performance" the cpu clocks up to 4.7GHz. The command to do this is:

for i in /sys/devices/system/cpu/cpu?/cpufreq/scaling_governor ; do echo performance | sudo tee ${i} &> /dev/null ; done

There is still some fine tuning necessary. But it clearly unleashes the power of this small computer..

-Justin Wright (#iamintel)

Davidfi01
New Contributor I
563 Views

How can this be done in Windows 10?

 

drsp
Beginner
557 Views

Thanks a lot Justin,

changing the governor really brings the CPU to 4.7 GHz for a single thread.
But it also stays there when idle.

I noticed that the clock goes down to 3GHz with 6 threads and 2.8GHz with 12 threads.
From the datasheet I was expecting 3,2 GHz under full load.

The fan is not running at max speed. And the core temperature is about 70°C.
I think the BIOS is limiting power to 30W.

Would it be safe to set a higher package power limit in the BIOS for continuous operation?

Thanks again for your helpful support! Much appreciated!
Ingo

AndrewG_Intel
Moderator
534 Views

Hello @drsp

Thank you for posting on the Intel® communities.

We are checking this thread and we would like to know if you need further assistance. If yes, could you please provide us with the full exact model of the Intel® NUC and the following logs:


Best regards,

Andrew G.

Intel Customer Support Technician


drsp
Beginner
529 Views

Thanks for your support.
I attached the log files you requested.

My impression is that with setting fan speed to "cool" in the BIOS clock speed are a bit higher under load.
I will test with higher custom settings (faster fan) to see if this helps...

Please let me know, if you find something in the log in the mean time.

Regards, Ingo

drsp
Beginner
512 Views

no, setting the fan even higher doesn't lead to high cpu frequencies.

3,0 GHz is the best I can get out of my box with scaling governor set to performance.
according to the pcm-tool the package has 24deg of thermal headroom.

Why can't it clock faster?

Thanks and all the best for your season holidays!

AndrewG_Intel
Moderator
516 Views

Hello drsp

Thank you very much for the information provided.

Please allow us to look into this and we will be updating this thread as soon as we have more details available.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
505 Views

Hello drsp

Thank you very much for these additional details. As soon as we have more information available we will be updating this thread.


Happy Holidays,

Sincerely,

Andrew G.

Intel Customer Support Technician


Ronny_G_Intel
Moderator
471 Views

Hi drsp,

I have not tried any of this in Linux but for Windows (Davidfi01) I would recommend that you use Intel Extreme Tuning Utility (Intel XTU) and go to "Stress Test" option and select the "CPU Stress Test" this will immediately ramp up the Max Core Frequency and I would also suggest opening a Task Manager Resource Monitor to observe the CPU behavior (you should see all CPU running at Max Utilization).


Now, and this also applies for Linux, if the system has all Cores enabled it will be more difficult to observe the system reaching out to Max Turbo Boost Frequency. I would recommend that you go into the BIOS and set the number of cores to one and run the Intel® Processor Identification Utility or Intel Extreme Tuning Utility (Intel XTU), it shows the highest Turbo Boost frequency. Make sure you reset the switch in the BIOS to reactivate all cores. I was able to get closer to the Max Turbo Boost Frequency but not to the one specified for the NUC processor, this of course depends on the headroom available and working conditions.

I hope this helps,
Ronny G

Ronny_G_Intel
Moderator
469 Views

By the way, to enable only 1 core in BIOS:

- Press F2 during boot up to access the BIOS

- Go to Performance tab

- Click on Processor

- Select "1" at Active Processor Cores drop down menu

- Press F10 to Save and Exit

AndrewG_Intel
Moderator
434 Views

Hello @drsp

We are checking this thread and we would like to know if you were able to review our previous posts. Please do not hesitate to contact us back if you have additional inquiries.


Best regards,

Andrew G.

Intel Customer Support Technician


drsp
Beginner
420 Views

Dear Andrew,

thank you for following up on my problem.

To be honest, I didn't try to turn off all other cores in the BIOS.
Even if it would work - it wouldn't be a usable scenario for me.

I expected to get 4.7 GHz out of my box at single thread load - not under special lab conditions.
I understand that clock drops at multi-threaded load. But I think by too much.

Could you please comment on the thermal headroom available. To me it looks like a lot. And a solution could be to set the thermal power limit in the BIOS higher? I think that's what's limiting the CPU.

Best regards,
Ingo

Ronny_G_Intel
Moderator
394 Views

Hi Ingo,

I am not aware of any way to accomplish what you are describing, there could be but this would be out of the scope of our support,  Intel® Turbo Boost Technology is not supposed to work that way, the maximum frequency for processor function can't be specified, the frequency is automatically set up and it depends on the working conditions as mentioned before.

I totally understand that the previous instruction I provided you with is not feasible under real-life conditions, it was just a way for you to test how the technology works to its max.

Perhaps other community members can assist you to accomplish your goal.

 

Regards,

Ronny G

 

AndrewG_Intel
Moderator
403 Views

Hello @drsp

Thank you for your response. Please allow us to check further regarding your concerns and we will be posting back in the thread as soon as we have more details available.


Best regards,

Andrew G.

Intel Customer Support Technician


Reply