Community
cancel
Showing results for 
Search instead for 
Did you mean: 
luckman212
Novice
28,854 Views

NUC10 - can't enable Legacy Boot ??

Jump to solution

Just got a NUC10i7FNH after weeks of waiting. Trying to get up to speed with it, and right out of the gate I noticed I'm not able to enable Legacy Boot at all. The options are greyed out and can't be enabled/disabled. Tried updating to the current (0037) BIOS. Searched thru all BIOS screens & options that I could find.

 

screenshot: https://i.imgur.com/2MAD5Sq.png

 

Is this just not possible??

 

0 Kudos
1 Solution
n_scott_pearson
Super User Retired Employee
26,719 Views

Did you disable both Secure Boot and Modern Standby? Both of those must be disabled before you can enable Legacy Boot.

 

Let me add: there is no modern version of Linux that doesn't support UEFI.

 

Hope this helps,

...S

View solution in original post

34 Replies
AlHill
Super User
25,722 Views

Because legacy bios is dead. Is there any specific reason you need it?

 

Doc

 

luckman212
Novice
25,725 Views

Yes - some bootable linux (e.g. xcp-ng) and other bootable USB disks don't work in UEFI, so unable to e.g .install Xen or update the Firmware on my internal Micron SSD...

n_scott_pearson
Super User Retired Employee
26,720 Views

Did you disable both Secure Boot and Modern Standby? Both of those must be disabled before you can enable Legacy Boot.

 

Let me add: there is no modern version of Linux that doesn't support UEFI.

 

Hope this helps,

...S

View solution in original post

luckman212
Novice
25,727 Views

Wow, Not sure HOW you knew that or figured it out (I spent hours searching) but THANK YOU !!

Disabling Modern Standby did indeed allow Legacy Boot mode to be enabled.

 

Jack37
Beginner
15,557 Views

Hi evrybody !

This is my my first post on this forum, as I am stumped !

This is in response to N_SCOTT_PEARSON...

I am having the same problem, unable to enter legacy mode on a NUC10i5 minipc. Yes, I had read about the Modern StandBy and the SecureBoot, both of which I disabled with no effect : the Legacy Mode option remain seadfastly grey !

 

And yes, I do need this legacy mode, as my home office computer "fried" recently, and I had my accounting software on it...

I took off the hard disk (2.5" SSD) and would like to install it on the NUC and boot off it. I know I will have to reactivate Windows (Windows 10 pro, 2004 update), etc., but it is the only way to avoid buying a new accounting package (over 600 $US)...

I read that the legacy was not avalaible anymore, period. Is that true, or is there any hope for me ?

 

Best regards

AlHill
Super User
15,547 Views

I am not Scott, and I do not play him on TV.

But, I have to ask - Why do you think you need legacy mode to run your accounting software?

Doc (not an Intel employee or contractor)

Jack37
Beginner
15,542 Views
Hi AlHill,

Just so I can boot directly on the « old » disk...
By the way, I finally was able unlock the legacy mode, and it booted up 2mn ago !
Yeeeh !!!
n_scott_pearson
Super User Retired Employee
15,538 Views

(Try as he might)             ;^)

AlHill
Super User
9,445 Views

@Jack37   A boot disk that is MBR is easily converted to GPT and UEFI boot.  Do yourself a favor and convert.

Doc (not an Intel employee or contractor)

 

AlHill
Super User
9,442 Views

https://www.youtube.com/watch?v=9JDzlhW3XTM    <VBG>

Doc (not an Intel employee or contractor)

AlHill
Super User
9,438 Views

@Jack37   Also, if you took a boot drive from some other *non-NUC" system, and are going to boot it on your NUC, even in legacy mode, you are carrying a lot of baggage, and hoping the system will work flawlessly.  Even using a driver from some other NUC is not without the possibility of problems.

I have done a number of these conversions and, trust me, there are issues that "may" occur.  It does not mean it will not work, but do not be surprised when you have a failure, or unexplained problem.

Doc (not an Intel employee or contractor)

 

Jack37
Beginner
9,433 Views

No worries, this only temporary, as I'll be retiring next March. I'll then stick a NVMe SSd in there, and reformat the 2.5 to serve as data disk...

Tanner
Beginner
5,550 Views

There is no option to enable Modern Standby or to change the Sleep Type Support in my BIOS settings, but my Boot page looks just like his.

Daniel-Tredway
Beginner
1,249 Views

I also have the NUC10 with same problem, I disabled secure boot and put sleep type support to Legacy S3 Standby and it still doesn't allow me to enter legacy mode? Any more ideas? 

LeonWaksman
Super User
1,240 Views

Hi @Daniel-Tredway 

Is the SATA Mode Selection set to AHCI (in Advanced>Storage)?

Leon

 

Daniel-Tredway
Beginner
1,221 Views
Daniel-Tredway
Beginner
1,207 Views

Well I was having trouble with windows update. I tried to update it multiple times but kept getting the same error.  When I was putting the OS on the NUC it lost connection with the storage device a couple of times when installing windows. So I wanted to get a fresh install of windows again and I couldn't erase Samsung storage device without legacy mode. I had to break out old big bertha and I swapped out M.2 storage device with berthas and technically she doesn't support M.2 storage on PCIE and had to modify the BOIS to take it 1 years ago(some  people jerry rigged a way to make it work with out Intel's support) . I finally was able to use Samsung's secure erase on bertha. Then I put the storage device on the NUC again and did a fresh install and now it was able to update completely. This 7 year old mother board still works great, I wish that engineers and software developers would focus more on longevity now. I mean what is faster than instant. It's to a point people need durability and longevity more now. As many time as I have tried to bury bertha, I have to come back and resurrect her.  Technically she operates just as fast as some of the newer ones out and it's 8 years old.  The difference isn't even humanly noticeable for the most part. 

MHuus1
Beginner
25,728 Views

Having the same problem but cannot find in the bios where to disable Modern standby :-(

 

luckman212
Novice
25,728 Views

POWER > Secondary Power Settings > Sleep Type support: Legacy S3 Standby

LeonWaksman
Super User
25,728 Views

Hello @MHuus1​ 

  1. The Modern Standby function is usually activated in Power > Secondary Power Settings. It depends on Bios configuration. In you NUC it may be something like this: " Native ACPI OS PCIe Support". By default it is disabled. So, you don't need to change this setting. In order to enable Legacy Boot, disable Secure Boot only.
  2. I want to warn you. You can not switch between ACPI S3 mode and Modern Standby. Switching from one standby power model to another is supported only with complete Operating System reinstallation.

 

Leon

 

Reply